FOG 33b - installation - HP Elite 8300 SFF

  • Developer

    the GPT formatted disk means that you installed windows with UEFI enabled, and it has configured the hard disk as such. if you wipe the drive and re-install windows like you did before, but under Legacy, your hard disk will not be configured as GPT.

  • [INDENT][I]it sounds to me like it would work if you wiped the drive and installed windows under legacy boot options. [/I][/INDENT]
    [INDENT]Not sure how to do that or what the ramifications will be. [/INDENT]
    [INDENT]Do you mean I could deactivate UEFI in the BIOS and somehow install windows again.[/INDENT]
    [INDENT]But it just stops dead and says GPT disk or just shows the flashing cursor. How do I format the disk if I cannot get past the bios?[/INDENT]

  • Have just deactivated UEFI and done a legacy network boot on the USDT.
    It worked and I registered the client with fog.
    But as expected when it rebooted and timed out past the fog page, and returned control to the PC, all I see is a flashing cursor in the top left corner.

    It cannot legacy boot to the disk because it is a GPT-formatted disk. Whatever that means.

    I have appreciated your help but must cycle home now. It’s 9:30 PM. I’ll log in to the forum when I get home, but will not be able to test anything.

  • Developer

    it sounds to me like it would work if you wiped the drive and installed windows under legacy boot options.

  • PXE timeout is now 10 seconds which gives plenty of time on the legacy network boot on the SFF, but makes no difference for the UEFI network boot on the USDT.

  • 2 - Deactivate UEFI and then legacy pxe boot works but then after the timeout period (when fogserver is offline) it tries to boot further to the internal harddisk and gives an error message “GPT-formatted disk. Legacy boot not supported”.

    Here is the the description I sent to Experts Exchange:

    One group are USDT (ultra slim desktop). The other are SFF (small form factor).
    All have the same latest BIOS. I have installed Win 8.1 Enterprise on one of each model in the same way. Before I installed Win 8.1 I deleted all partitions and allowed Win 8.1 to create its own 3 partitions:
    300MB Recovery,
    100MB EFI-system,

    PXE Boot works on the SFF, but not on the USDT. I should say that the FOG imaging server which provides the PXE boot file is turned off. What I see on the 2 clients is that the SFF is clearly trying to find the PXE boot file for a while before booting further to the internal harddisk. The USDT makes no attempt to locate the PXE file. It just boots straight into the internal harddisk.

    They have a slightly different BIOS Boot Order list. Here is the USDT:

    UEFI Boot Sources

    • Windows Boot Manager
    • Atapi CD/DVD
    • USB HD
    • USB floppy/CD

    Legacy Boot Sources
    -Network Controller
    -Hard drive
    —USB Hard Drive

    • USB floppy/cd

    This list is identical on the SFF except for “Windows Boot Manager”
    “Windows Boot Manager” is missing on the SFF which has no problem PXE-booting.

    If I disable “Windows Boot Manager” on the USDT, then it attempts to PXE boot (fantastic), but then after a while it tries to boot further to the internal harddisk and gives an error message “GPT-formatted disk. Legacy boot not supported”. I have no idea what this means or how to get PXE working without getting this GPT problem.

    Both BIOSes have:
    SATA emulation: AHCI
    Network boot: enabled
    Secure Boot configuration: Legacy support:“enabled”, Secure boot:“disabled”
    Remote wakeup boot source: Remote Server
    NIC PXE option ROM download: PXE
    Option ROM launch Policy - PXE Option ROMS: “Legacy Only” (can be UEFI Only)

  • Developer

    the PXE boot menu configuration page allows you to choose how long the menu shows up

  • Interesting comments and advice.

    But to the real priority now: All the new PCs are HP Elite 8300.
    Most are USDT (ultra slim) and some are SFF (Small form format).

    The BIOS in the SFF model allows the use of legacy network boot.
    As I had hoped, it worked almost perfectly and I registered the client.
    But note that the FOG pxe option window went past in a split second.
    I had to reboot to catch it again. It was VERY fast. How can I slow that down?

    The USDT did not work. I have already had a long back and forth with Experts Exchange on how to get the network boot to work.
    There are 2 ways.

    1 - UEFI boot options: IP4 Network boot at the top of the list.
    I never saw any sign of the FOG page. It waited for the pxe file for a short time and then booted to windows.

  • Developer

    Tom, do you think it would be a good idea to change that line from [CODE]sanboot --no-describe --drive 0x80 || goto MENU[/CODE] to [CODE]sanboot --no-describe --drive 0x80 || exit[/CODE] or would that not work, since it sounds like it may lock up on the first bit

  • Developer

    a bit of research says that this is likely a hardware/firmware specific bug that occurs a lot on HP machines

  • sanboot --no-describe --drive 0x80 is the line in BootMenu.class.php that deals with how to pass to the harddrive. That said, not all systems like this method. If your systems are freezing. Try changing those lines to just say: exit.

    Thank you,

  • Developer

    i’m not sure why it is failing to boot to the hard drive of the computer after ipxe loads, but fog appears to be working properly. I would actually be willing to bet that if you took an image of the computer, then imaged it again with fog, it would work fine when not pxe booting. fog is typically used on windows clients, but many people have it working on linux as well.

  • Developer

    :eek: side stepped us there lol. so [U]Client is Ubuntu 12.04.4[/U]

  • Just to explain, I want to put Ubuntu 12 on all the old HP PCs as a way of both erasing the hard drives and also making it possible for the parents in the school to have a free linux PC if they want, instead of throwing them away.

    But the real priority is getting the new Windows 8.1 HP clients deployed.

  • I have just changed the boot order on the client with Ubuntu 12, to boot straight to the HD and Ubuntu booted as expected.
    The harddisk is not corrupt.

    It’s definitely the fog pxe file creating the problem.

  • Developer

    This post is deleted!
  • Developer

    i mean on the client that is pxe booting, not the server

  • Ubuntu 12.04.4

  • Developer

    SAN device 0x80 is the local hard disk. is there a valid OS on the drive?

  • Thanks Junkhacker, I forgot to put in a DNS reference to fogserver.
    Now PXE is working on the old HP
    The registration works.
    But now when the PC is rebooted, and I don’t touch anything, when it defaults past the FOG options, whilst the FOG pxe page is still visible, I see:

    “Booting from SAN device 0x80”

    and it freezes there. Nothing I press takes me further …

    I have not set an imaging task or anything like that.

    I’ll try the new HP and get back to you.