Errors on perform full host registration and inventory - hardware problem?

  • When i “perform full host registration and inventory” i get a lot of errors and it doesn’t work.

    Loading fog/kernel/bzImage and Loading fog/images/init.gz becomes ready, then it stops:

    0.196026 tps65010: no chip?
    0.365692 acpiphp_ibm: ibm_acpiphp_init: acpi_walk_namespace failed
    0.366090 Could not find Carillo Ranch MCH device
    0.366331 uvesafb: failed to execute /sbin/v86d
    0.366356 uvesafb: make sure that the v86d helper is installed and executable
    0.366382 uvesafb: getting vbe info block failed (eax=0x4f00, err=-2)
    0.366408 uvesafb: vbe_init() failed with -22

    After a minute the pc hangs itsself as i think… i added a picture of the screen.

    Any help is welcome. So far i did a BIOS-update which changed nothing and now i have no clue.


  • unfortunately it doesn’t. And i have no clue why the downloaded file is shown as an archive instead of a binary file.
    That the filesize differs significantly (i guess it was 6mb instead of 11mb) is not relevant, right?

    Do you have an idea what i could do or test?

  • It is technically the same. It shouldn’t be a compressed “file” persay. It is compressed, but not at the level of which we use it. The internals are zipped to make it smaller, and gets decompressed on load.

    Copy bzImage32 and rename to bzImage should work perfectly well.

  • Okay, here comes a lot together, one solved problem leads to two others. 😉

    I noticed that the original bzImage and the file from you have different file icons. The original one is a binary file, the just downloaded one seems to be an archive (you see i’m not much familiar with Linux (and miss my file endings g)

    Since i thought it ccould be something with the download i made, i tried to solve the thing with the not working wget and found that it probably has to be
    [I]–no-check-certificat[/I] instead of [I]–no-check-certificates[/I]…
    Unluckily, changing that, wget tells me now that i have no right to access the file.

    Tom, i’m not sure if i understand what you wrote. As i understand it, doing the file download with wget as you
    suggested it would replace the old and backuped bzImage with your file which gets the exact same name.

    My questions are:

    1. When i download bzImage32 and rename it to bzImage, is this tecnically the same in the result and may i do so?
    2. Does i have to run a command on the file downloaded from you (since it seems to be not a binary file)?

    Thank you for your help and patience!

  • bzImage is the filename your server defaults to, so with bzImage32 and you didn’t move the bzImage, or only renamed that, but never made bzImage, it would not work at all because as far as the system is concerned, the file bzImage no longer exists.

    As I’m building for 0.33, we’ve moved now to 64 bit systems in hopes for more compatibility in UEFI stuff later on. So my links bzImage is a 64 bit file, where the bzImage32 is for 32 bit systems.

  • Thank you, Tom.
    Since i had difficulties with the wget-line i downloaded it with firefox, while i have the bzImage32 under /tftpboot/fog/kernel it should be fine anyway…
    I wondered that the filenames differ (bzImage vs. bzImage32) but it doesn’t seem to be a problem. I copied the file for testing and named it bzImage again, so now both are there. Anyway, made these changes, when the first fog-screen appears i neither can execute the Host registration prozess nor can i get the client system information (running MemTest / boot from hdd works).
    Maybe i did something wrong… 😞

  • It’s not hung when you’re seeing the “Snow” screen, it’s just the drivers don’t load modesetting properly. I’ve built my kernels to keep this from happening. For the 32 bit kernel, which I’m assuming is what you need, simply follow the steps below:
    [code]cd /tftpboot/fog/kernel
    mv bzImage bzImage.orig.14MAR2014
    wget -O bzImage --no-check-certificates

    You should be set and everything should display properly.