Packet Fragmentation



  • Hi All,

    We are running into a bit of an issue with our fog server. It seems the packet fragmentation that fog does is causing a bottleneck on our firewall, from what our network guy is telling me. He said something about having to modify the rsize and wsize parameters when fog pushes the image out.

    Typically how we do it as far as imaging goes is we boot up via pxe to the menu and select “Perform Host Registration and Inventory” and chose to image it at this point.

    How and where do I make the necessary config changes to keep our Firewall and Network Admin happy? We’re running Fog on Centos via a VM. Works great when we image from our office, just when we move out of our IT office and image pc’s on the production floor in the locked down zone is when we have issues.

    Please help!!!


  • Senior Developer

    Try the command
    [code]sed ‘s:&$tmp:$tmp:g’ -i /var/www/fog/management/includes/tasks.confirm.include.php[/code]



  • Here is the error_log:
    [Fri Apr 04 15:48:00 2014] [error] [client 192.168.206.7] PHP Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of createCronScheduledPackage(). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in /var/www/html/fog/management/includes/tasks.confirm.include.php on line 1951, referer: [url]http://192.168.96.5/fog/management/index.php?node=tasks&type=host&direction=down&noconfirm=527[/url]
    [Fri Apr 04 15:48:00 2014] [error] [client 192.168.206.7] PHP Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of createSingleRunScheduledPackage(). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in /var/www/html/fog/management/includes/tasks.confirm.include.php on line 2045, referer: [url]http://192.168.96.5/fog/management/index.php?node=tasks&type=host&direction=down&noconfirm=527[/url]
    [Fri Apr 04 15:48:00 2014] [error] [client 192.168.206.7] PHP Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of createCronScheduledPackage(). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in /var/www/html/fog/management/includes/tasks.confirm.include.php on line 2072, referer: [url]http://192.168.96.5/fog/management/index.php?node=tasks&type=host&direction=down&noconfirm=527[/url]
    [Fri Apr 04 15:48:00 2014] [error] [client 192.168.206.7] PHP Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of createSingleRunScheduledPackage(). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in /var/www/html/fog/management/includes/tasks.confirm.include.php on line 2158, referer: [url]http://192.168.96.5/fog/management/index.php?node=tasks&type=host&direction=down&noconfirm=527[/url]
    [Fri Apr 04 15:48:00 2014] [error] [client 192.168.206.7] PHP Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of createCronScheduledPackage(). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in /var/www/html/fog/management/includes/tasks.confirm.include.php on line 2185, referer: [url]http://192.168.96.5/fog/management/index.php?node=tasks&type=host&direction=down&noconfirm=527[/url]
    [Fri Apr 04 15:48:00 2014] [error] [client 192.168.206.7] PHP Notice: Undefined index: noconfirm in /var/www/html/fog/management/includes/tasks.confirm.include.php on line 29, referer: [url]http://192.168.96.5/fog/management/index.php?node=tasks&type=host&direction=down&noconfirm=527[/url]
    [Fri Apr 04 15:48:00 2014] [error] [client 192.168.206.7] PHP Notice: Undefined index: shutdown in /var/www/html/fog/management/includes/tasks.confirm.include.php on line 732, referer: [url]http://192.168.96.5/fog/management/index.php?node=tasks&type=host&direction=down&noconfirm=527[/url]
    [Fri Apr 04 15:48:00 2014] [error] [client 192.168.206.7] PHP Notice: Undefined index: singlesched in /var/www/html/fog/management/includes/tasks.confirm.include.php on line 845, referer: [url]http://192.168.96.5/fog/management/index.php?node=tasks&type=host&direction=down&noconfirm=527[/url]
    [Fri Apr 04 15:48:00 2014] [error] [client 192.168.206.7] PHP Notice: Undefined index: cronsched in /var/www/html/fog/management/includes/tasks.confirm.include.php on line 846, referer: [url]http://192.168.96.5/fog/management/index.php?node=tasks&type=host&direction=down&noconfirm=527[/url]
    [Fri Apr 04 15:48:00 2014] [error] [client 192.168.206.7] PHP Fatal error: Call to undefined function sys_get_temp_dir() in /var/www/html/fog/commons/functions.include.php on line 1552, referer: [url]http://192.168.96.5/fog/management/index.php?node=tasks&type=host&direction=down&noconfirm=527[/url]



  • hey tom, have that issue again like above where task management is blank. I’m on irc and could really use your help if you are around



  • Thanks for the help on IRC Tom!



  • Hey Tom,

    Some more issues, though I may be onto something. With our .30 fog server that is on a VM, I can image 6 or 7 pc’s at a time without issue. With the new .32 server, which is a dedicated server (hardware not vm) connected directly to our core switch, I can’t image more than 2. If I try a third, it just locks up. I’ve tried an old Dell 860 and a Dell 2850 (getting very good at building a FOG server now, only takes about half an hour lol).

    Before our Sys Admin left, he told us to always use the bzImage file and pxelinux.0 from the original FOG server (can’t remember why). My question is, would those files from .30 be compatible with the .32 FOG? Could this be what is causing the issue?

    Our network guy noticed a lot of DUP ACK packets. This happens with the .30 server as well, just not as much as the .32 server.

    So I’ve tried different server hardware, different network cables, different ports on the core. All with the same results. The only thing the same everytime is using those 2 files. Also, 32 always fails for me at clamav (yes I modified the config.sh file to remove the -update) so I install that prior to running the ./installfog.sh using yum (yum install clamav).

    Any ideas that could help me out here?



  • It’s not just the web gui, if I do it from the pxe menu, I have the same result



  • [quote=“Tom Elliott, post: 23756, member: 7271”]In the file tasks.confirm.include.php change the references to &$tmp to $tmp and you should be good.[/quote]

    Ya, did that but it didn’t change anything.


  • Senior Developer

    In the file tasks.confirm.include.php change the references to &$tmp to $tmp and you should be good.



  • K, installed Fog on Centos 5.9 but have another issue. Sorry, I know I’m a pain…

    When I go to create a task and get to the part to confirm the task, All I get is the Task Management title and a Confirm Task sub title, but no buttons or any way to confirm.



  • Hey Tom, got a minute?



  • Just an update, looks like I used 5.9 last time. Did so again this time and had fog up and running in minutes…



  • I’m going to fire up that mobile version I made last week and go through the history. It only took a little bit and I had it up and running, there’s just something I either messed up bad or am missing. I’ll get it figured out.


  • Senior Developer

    You’re fine man. Thanks for attempting. Hopefully all works well tomorrow. Try using the wiki though to install. It may help a little bit.



  • Thanks for the help again. You left before I could tell you that! FYI, I’m the one that sucked…lol ;)


  • Senior Developer

    Then try:
    [code]yum -y update[/code]


  • Senior Developer



  • no joy :(

    [root@fog bin]# yum -y install glibc-common; yum update
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile

    • elrepo: mirror.symnds.com

    • epel: fedora.mirror.nexicom.net

    • remi: mirrors.mediatemple.net
      Setting up Install Process
      Resolving Dependencies
      –> Running transaction check
      —> Package glibc-common.x86_64 0:2.12-1.107.el6_4.5 will be installed
      –> Processing Dependency: glibc = 2.12-1.107.el6_4.5 for package: glibc-common-2.12-1.107.el6_4.5.x86_64
      –> Running transaction check
      —> Package glibc.i686 0:2.12-1.107.el6_4.5 will be installed
      –> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.107.el6_4.5.i686
      –> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.107.el6_4.5.i686
      –> Running transaction check
      —> Package nss-softokn-freebl.i686 0:3.14.3-3.el6_4 will be installed
      –> Finished Dependency Resolution
      Error: Multilib version problems found. This often means that the root
      cause is something else and multilib version checking is just
      pointing out that there is a problem. Eg.:

        1. You have an upgrade for glibc which is missing some
           dependency that another package requires. Yum is trying to
           solve this by installing an older version of glibc of the
           different architecture. If you exclude the bad architecture
           yum will tell you what the root cause is (which package
           requires what). You can try redoing the upgrade with
           --exclude glibc.otherarch ... this should give you an error
           message showing the root cause of the problem.
      
        2. You have multiple architectures of glibc installed, but
           yum can only see an upgrade for one of those arcitectures.
           If you don't want/need both architectures anymore then you
           can remove the one with the missing update and everything
           will work.
      
        3. You have duplicate versions of glibc installed already.
           You can use "yum check" to get yum show these errors.
      
      ...you can also use --setopt=protected_multilib=false to remove
      this checking, however this is almost never the correct thing to
      do as something else is very likely to go wrong (often causing
      much more problems).
      
      Protected multilib versions: glibc-2.12-1.107.el6_4.5.i686 != glibc-2.12-1.132.el6.x86_64
      

    Error: Protected multilib versions: nss-softokn-freebl-3.14.3-3.el6_4.i686 != nss-softokn-freebl-3.14.3-9.el6.x86_64
    You could try using --skip-broken to work around the problem
    ** Found 4 pre-existing rpmdb problem(s), ‘yum check’ output follows:
    MAKEDEV-3.24-6.el6.x86_64 has missing requires of /usr/bin/getent
    glibc-2.12-1.132.el6.x86_64 has missing requires of glibc-common = (‘0’, ‘2.12’, ‘1.132.el6’)
    rpcbind-0.2.0-11.el6.x86_64 has missing requires of glibc-common
    udev-147-2.51.el6.x86_64 has missing requires of /usr/bin/getent
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile


  • Senior Developer

    try just:
    [code]yum -y install glibc-common; yum update[/code]

    You may have to reboot the system once complete.



  • LOL, might be just easier to use an older version of centos…


Log in to reply
 

473
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.