Fog 0.33b Snappin deployment


  • Senior Developer

    Did r1162 fix the Hardware issue you were seeing, if you use the available init.gz (the one I packed, not the one I packaged for you specifically)?


  • Senior Developer

    So the changing hostname before restart after imaging probably isn’t happening because you disabled HOSTNAME_EARLY in the FOG Settings, if I recall correctly.

    What does the fog.log say in regards to the hostname changer?


  • Testers

    [quote=“Tom Elliott, post: 22172, member: 7271”]What do you mean, “you get the same thing?”

    The host name or no host name happens?

    I’m about to release r1162, found the place where ntfsresize was supposed to happen in my scripts, but wasn’t happening. Why?, you ask with a slight bit of confusion. Because I forgot to add the resize part.

    My guess with your issue is, the sysprepped system was trying to expand, but the way the drive was sized, it couldn’t expand any further, therefore it wouldn’t work on your system. I’m using VM’s so things can happen in the background dynamically which would be why I wasn’t seeing the same issue you where. I’m surprised others weren’t as well.[/quote]

    I get the same thing as before. The host name doesn’t change, nor do I see it reporting that its changing the hostname like in .32fog right before restart after imaging.


  • Senior Developer

    What do you mean, “you get the same thing?”

    The host name or no host name happens?

    I’m about to release r1162, found the place where ntfsresize was supposed to happen in my scripts, but wasn’t happening. Why?, you ask with a slight bit of confusion. Because I forgot to add the resize part.

    My guess with your issue is, the sysprepped system was trying to expand, but the way the drive was sized, it couldn’t expand any further, therefore it wouldn’t work on your system. I’m using VM’s so things can happen in the background dynamically which would be why I wasn’t seeing the same issue you where. I’m surprised others weren’t as well.


  • Testers

    Reinstalled like you asked and I get the same thing… I dont see the hostname change anymore like i used to. I used to see it right after the image was deployed right before reboot.


  • Senior Developer

    Can you do the reinstall of FOG at 1161 (of course backing up the init.gz)

    But before running the install script,

    rm -rf the /var/www/fog directory (whereever it actually is.)


  • Testers

    Here is my fog.log
    I change the name to PC1824 manually hoping maybe it would join the domain, but no go.

    [CODE]1/29/2014 11:24 AM FOG::ClientUpdater Zero byte response returned
    1/29/2014 11:24 AM FOG::ClientUpdater Checking Status : UserCleanup.dll
    1/29/2014 11:24 AM FOG::ClientUpdater Zero byte response returned
    1/29/2014 11:24 AM FOG::ClientUpdater Checking Status : UserTracker.dll
    1/29/2014 11:24 AM FOG::ClientUpdater Zero byte response returned
    1/29/2014 11:24 AM FOG::ClientUpdater Checking Status : config.ini
    1/29/2014 11:24 AM FOG::ClientUpdater Zero byte response returned
    1/29/2014 11:24 AM FOG::ClientUpdater The remote server returned an error: (500) Internal Server Error.
    1/29/2014 11:24 AM FOG::ClientUpdater at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)
    at System.Net.WebClient.DownloadString(Uri address)
    at System.Net.WebClient.DownloadString(String address)
    at FOG.SnapinClient.getAllPublishedModules()
    at FOG.SnapinClient.startUpdate()
    1/29/2014 11:24 AM FOG::ClientUpdater Client update will be applied during next service startup.
    1/29/2014 11:24 AM FOG::ClientUpdater Client update process complete, exiting…
    1/29/2014 11:26 AM FOG::TaskReboot Attempting to connect to fog server…
    1/29/2014 11:26 AM FOG::TaskReboot Module is active…
    1/29/2014 11:26 AM FOG::TaskReboot Attempting to connect to fog server…
    1/29/2014 11:26 AM FOG::TaskReboot No task found for client.
    1/29/2014 11:27 AM FOG::SnapinClient Attempting to connect to fog server…
    1/29/2014 11:27 AM FOG::SnapinClient Module is active…
    1/29/2014 11:27 AM FOG::SnapinClient No Tasks found for: 00:25:64:BD:7D:1A
    1/29/2014 11:31 AM FOG::TaskReboot Attempting to connect to fog server…
    1/29/2014 11:31 AM FOG::TaskReboot Module is active…
    1/29/2014 11:31 AM FOG::TaskReboot Attempting to connect to fog server…
    1/29/2014 11:31 AM FOG::TaskReboot No task found for client.
    1/29/2014 11:32 AM FOG::SnapinClient Attempting to connect to fog server…
    1/29/2014 11:32 AM FOG::SnapinClient Module is active…
    1/29/2014 11:32 AM FOG::SnapinClient No Tasks found for: 00:25:64:BD:7D:1A
    1/29/2014 11:36 AM FOG::TaskReboot Attempting to connect to fog server…
    1/29/2014 11:36 AM FOG::TaskReboot Module is active…
    1/29/2014 11:36 AM FOG::TaskReboot Attempting to connect to fog server…
    1/29/2014 11:36 AM FOG::TaskReboot No task found for client.
    1/29/2014 11:37 AM FOG::UserTracker Event: LOGIN for RENAME\Administrator
    1/29/2014 11:37 AM FOG::UserTracker Record processed by server!
    1/29/2014 11:37 AM FOG::PrinterManager New user detected: RENAME\Administrator
    1/29/2014 11:37 AM FOG::PrinterManager Waiting for tray to load…
    1/29/2014 11:38 AM FOG::SnapinClient Attempting to connect to fog server…
    1/29/2014 11:38 AM FOG::SnapinClient Module is active…
    1/29/2014 11:38 AM FOG::SnapinClient No Tasks found for: 00:25:64:BD:7D:1A
    1/29/2014 11:43 AM FOG::SnapinClient Attempting to connect to fog server…
    1/29/2014 11:43 AM FOG::SnapinClient Module is active…
    1/29/2014 11:43 AM FOG::SnapinClient No Tasks found for: 00:25:64:BD:7D:1A
    1/29/2014 11:48 AM FOG::SnapinClient Attempting to connect to fog server…
    1/29/2014 11:48 AM FOG::SnapinClient Module is active…
    1/29/2014 11:48 AM FOG::SnapinClient No Tasks found for: 00:25:64:BD:7D:1A
    1/29/2014 11:53 AM FOG::SnapinClient Attempting to connect to fog server…
    1/29/2014 11:53 AM FOG::SnapinClient Module is active…
    1/29/2014 11:53 AM FOG::SnapinClient No Tasks found for: 00:25:64:BD:7D:1A
    1/29/2014 11:55 AM FOG Service Engine Version: 3
    1/29/2014 11:55 AM Starting all sub processes
    1/29/2014 11:55 AM 14 modules loaded
    1/29/2014 11:55 AM * Starting FOG.AutoLogOut
    1/29/2014 11:55 AM * Starting FOG.SnapinClient
    1/29/2014 11:55 AM * Starting FOG.DirCleaner
    1/29/2014 11:55 AM * Starting FOG.DisplayManager
    1/29/2014 11:55 AM * Starting FOG.GreenFog
    1/29/2014 11:55 AM * Starting FOG.GUIWatcher
    1/29/2014 11:55 AM FOG::GUIWatcher Starting GUI Watcher…
    1/29/2014 11:55 AM * Starting FOG.HostNameChanger
    1/29/2014 11:55 AM * Starting FOG.HostRegister
    1/29/2014 11:55 AM * Starting FOG.MODDebug
    1/29/2014 11:55 AM * Starting FOG.PrinterManager
    1/29/2014 11:55 AM FOG::MODDebug Start Called
    1/29/2014 11:55 AM FOG::MODDebug Sleeping for 100 Seconds
    1/29/2014 11:55 AM * Starting FOG.SnapinClient
    1/29/2014 11:55 AM * Starting FOG.TaskReboot
    1/29/2014 11:55 AM FOG::TaskReboot Taskreboot in lazy mode.
    1/29/2014 11:55 AM FOG::TaskReboot Starting Task Reboot…
    1/29/2014 11:55 AM * Starting FOG.UserCleanup
    1/29/2014 11:55 AM FOG::HostRegister Starting host registration process…
    1/29/2014 11:55 AM FOG::ClientUpdater Starting client update process…
    1/29/2014 11:55 AM FOG::ClientUpdater Sleeping for 313 seconds.
    1/29/2014 11:55 AM FOG::PrinterManager Starting interprocess communication process…
    1/29/2014 11:55 AM FOG::UserCleanup Sleeping for 19 seconds.
    1/29/2014 11:55 AM FOG::DirCleaner Sleeping for 58 seconds.
    1/29/2014 11:55 AM FOG::DisplayManager Starting display manager process…
    1/29/2014 11:55 AM FOG::AutoLogOut Starting process…
    1/29/2014 11:55 AM FOG::PrinterManager interprocess comm startup: OK
    1/29/2014 11:55 AM FOG::GreenFog Sleeping for 58 seconds.
    1/29/2014 11:55 AM * Starting FOG.UserTracker
    1/29/2014 11:55 AM FOG::HostnameChanger Starting hostname change process…
    1/29/2014 11:55 AM FOG::HostnameChanger Yielding to other subservices for 9 seconds.
    1/29/2014 11:55 AM FOG::UserTracker Starting user tracking process…
    1/29/2014 11:55 AM FOG::SnapinClient Starting snapin client process…
    1/29/2014 11:55 AM FOG::HostRegister Exiting because only 1 mac address was found.
    1/29/2014 11:55 AM FOG::SnapinClient Sleeping for 419 seconds.
    1/29/2014 11:55 AM FOG::DisplayManager Attempting to connect to fog server…
    1/29/2014 11:55 AM FOG::PrinterManager Attempting to connect to fog server…
    1/29/2014 11:55 AM FOG::UserTracker Attempting to connect to fog server…
    1/29/2014 11:55 AM FOG::TaskReboot Attempting to connect to fog server…
    1/29/2014 11:55 AM FOG::PrinterManager Module is active…
    1/29/2014 11:55 AM FOG::PrinterManager Starting printer manager…
    1/29/2014 11:55 AM FOG::PrinterManager Yielding to other services for 41 seconds.
    1/29/2014 11:55 AM FOG::AutoLogOut Module is active…
    1/29/2014 11:55 AM FOG::AutoLogOut Timeout value is Zero, disabling module.
    1/29/2014 11:55 AM FOG::TaskReboot Module is active…
    1/29/2014 11:55 AM FOG::TaskReboot Attempting to connect to fog server…
    1/29/2014 11:55 AM FOG::DisplayManager Module is disabled globally on the FOG Server.
    1/29/2014 11:55 AM FOG::TaskReboot No task found for client.
    1/29/2014 11:55 AM FOG::UserTracker Module is active…
    1/29/2014 11:56 AM FOG::HostnameChanger Attempting to connect to fog server…
    1/29/2014 11:56 AM FOG::HostnameChanger Module is active…
    1/29/2014 11:56 AM FOG::HostnameChanger General Error Returned:
    1/29/2014 11:56 AM FOG::HostnameChanger #!er: Join domain disabled on this host.
    1/29/2014 11:56 AM FOG::HostnameChanger Host name was not found in the database.
    1/29/2014 11:56 AM FOG::UserCleanup Starting user cleanup process…
    1/29/2014 11:56 AM FOG::UserCleanup Attempting to connect to fog server…
    1/29/2014 11:56 AM FOG::UserCleanup Module is disabled globally on the FOG Server, exiting.
    1/29/2014 11:56 AM FOG::UserTracker Event: LOGIN for PC1824\Administrator
    1/29/2014 11:56 AM FOG::UserTracker Record processed by server!
    1/29/2014 11:56 AM FOG::PrinterManager Management level = 0
    1/29/2014 11:56 AM FOG::PrinterManager This host is set to NO MANAGEMENT, we will exit now.
    1/29/2014 11:56 AM FOG::PrinterManager Major printing operations complete, moving to tracking mode.
    1/29/2014 11:56 AM FOG::PrinterManager New user detected: PC1824\Administrator
    1/29/2014 11:56 AM FOG::PrinterManager Waiting for tray to load…
    1/29/2014 11:56 AM FOG::DirCleaner Starting directory cleaning process…
    1/29/2014 11:56 AM FOG::DirCleaner Attempting to connect to fog server…
    1/29/2014 11:56 AM FOG::DirCleaner Module is active…
    1/29/2014 11:56 AM FOG::DirCleaner Determining which directories should be cleaned…
    1/29/2014 11:56 AM FOG::DirCleaner No directories are configured to be cleaned.
    1/29/2014 11:56 AM FOG::DirCleaner Starting directory cleaning loop…
    1/29/2014 11:56 AM FOG::DirCleaner Module has finished work and will now exit.
    1/29/2014 11:56 AM FOG::GreenFog Attempting to connect to fog server…
    1/29/2014 11:56 AM FOG::GreenFog Module is active…
    1/29/2014 11:56 AM FOG::GreenFog No actions were found.
    1/29/2014 11:56 AM FOG::GreenFog No tasks found after validation!
    1/29/2014 11:57 AM FOG::MODDebug Reading config settings…
    1/29/2014 11:57 AM FOG::MODDebug Reading of config settings passed.
    1/29/2014 11:57 AM FOG::MODDebug Starting Core processing…
    1/29/2014 11:57 AM FOG::MODDebug Operating System ID: 6
    1/29/2014 11:57 AM FOG::MODDebug Operating System Minor: 1
    1/29/2014 11:57 AM FOG::MODDebug MAC ID 0 00:25:64:BD:7D:1A
    1/29/2014 11:57 AM FOG::MODDebug MAC POST String: 00:25:64:BD:7D:1A
    1/29/2014 11:57 AM FOG::MODDebug A user is currently logged in
    1/29/2014 11:57 AM FOG::MODDebug Username: PC1824\Administrator
    1/29/2014 11:57 AM FOG::MODDebug Hostname: PC1824
    1/29/2014 11:57 AM FOG::MODDebug Attempting to open connect to: http://10fogserver/fog/service/debug.php
    1/29/2014 11:57 AM FOG::MODDebug Server responded with: Hello FOG Client
    1/29/2014 11:57 AM FOG::MODDebug Module has finished work and will now exit.
    [/CODE]


  • Senior Developer

    I’m sorry I haven’t been able to fix all these issues, but glad these issues are happening.
    So I’m going to go home tonight and figure out the issue with chkdisk. I think you’re right with that.

    Basically, the file you’re using is just using the known working fog script. (The original one from 1141.)


  • Testers

    Its not renaming the host or joining to the domain…
    I have tried it with the Hostname_Early turned on as well.


  • Testers

    Good news! the image with the driverpacks worked!


  • Senior Developer

    Maybe I fix/broke the chkdisk feature. Now we’re getting somewhere.


  • Testers

    Tom, I dont know if this helps any… but i noticed that when the image is going to work i see this screen before it boots into setup.
    [IMG]http://imagizer.imageshack.us/v2/800x600q90/822/tvgtx.jpg[/IMG]

    I dont know what made it work, probably your init.gz because i re-sysprepped without the driverpacks.
    I will try with the image that has the driverpacks and see if it works.


  • Senior Developer

    download the new init.gz with the original fog script: (slightly modified to use double quotes where there was single quotes.)

    [code]cd /tftpboot/fog/images
    mv init.gz init.gz_r1161
    wget -O init.gz --no-check-certificate https://mastacontrola.com/fogboot/images/init.gz_origfog[/code]


  • Senior Developer

    Can you try sysprep without driver pack installation?

    It would seem possible, to me at least, that that whole Hostname early thing is causing the issue. To my knowledge, hostname_early sends if the hostname=blahblahblah in the 01-XX-XX-XX-XX-XX-XX file is filled out. It’s supposed to check if hostname_early is enabled on the server and, if so, set this up, but I have a sneaky suspicion that this variable is being sent in either case.

    While this doesn’t affect me, it would seem to make sense that driver packs are making changes to the sysprepped system, after another change has already happened. This would, theoretically, explain why you’re seeing this issue. This is what my mind is telling me. I really haven’t changed anything too drastically. I can, if you’re willing, create an init.gz file with the original fog script and see if all works for you.


  • Testers

    I did as you asked. and I still get the error message.
    My image is sysprepped as well, with driver packs from driverpacks.net.


  • Senior Developer

    I ask this because I am only using a sysprepped image at work and all works perfectly fine.


  • Senior Developer

    If you revert the system to r1141 (before the fog scripts were regenerated) and deploy an image, then update to r1161, and re-upload the image, then try to redeploy, does it work?


  • Testers

    Tom, I updated to R1160 and I am still getting the error…


  • Senior Developer

    With any luck, this issue is now fixed.

    It seems, with all the coding I’ve done, I made a little typo, I had a 2 where a 3 should have been. Basically what this means is, it was converting your hard-disk to gpt. The imaging would work fine because, for all technical purposes, the partitions were created and created properly, but then sgdisk would run when it shouldn’t have.

    Hopefully this fixes our issue with this. r1160 should contain this fix.


  • Testers

    I tried R1157 and still get the message Tom.
    I am heading home for the night. I can pickup where we left off tomorrow.


Log in to reply
 

308
Online

7.1k
Users

14.3k
Topics

135.0k
Posts