• While the issues in my other thread, FOG Server Communication Issues have largely been solved there is a problem which has cropped up during the image upload process. I am able to create an image in the web interface, set the upload task, and have it start automatically upon reboot of the target machine. The problem is I am confronted with the screen in the attached image. What stands out is that the IP address next to “mount” is wrong. I was able to mount the volume locally on the server, but am unsure where to change the IP address. Here is some information about my setup:

    FOG version .32
    Running on Debian 7 in VMware player (Windows 7 host OS)
    Target Machine runs Windows 7. It is an Optiplex 780. I’d thought there were three partitions (primary, boot, and one more), but FOG only shows the boot sector and file system as partitions. In any case the upload has failed whether I set the image a single or multiple partitions.
    Kernel version is something like 3.12.7. It is one that Tom Elliot posted back in December. I’d had problems with registration hanging which were solved by updating the kernel.


  • What sort of code change are we talking about? The feature would be nice, but is not critical.

  • chad,

    progress does get displayed now, on all imaging tasks.

  • Moderator

    If the image type is not single-partition, resizable, the base FOG code does not update the task status until it finishes. There is a quick code change that will enable showing of progress for multiple partition, single disk images.

    I don’t think the code is in place yet to show progress on upload tasks either.

  • In regards to the test machine at work, renaming the services corrected the issue. I was able to start the imaging process. Unfortunately I could not finish because it is necessary to repartition the virtual hard drive to make more space which might require some doing. I have but two questions:
    1. Why do active tasks always display as “queued” until finished?
    2. For some reason pressing * does not cancel an image upload in progress.

  • A fresh install did the trick. I am in the process of imaging my desktop PC. For some reason it would only work if I set the OS to be windows 7 (it runs 8.1) and multiple partitions. However it is currently working. The only problem is my laptop refuses to connect to the internet which has forced me to write this from a cellphone. But that is a temporary problem. Over the next two days I will recreate the fog server in a virtual machine on my laptop in case renaming the NFS services does not help.

  • All perfectly understandable. I don’t expect you to go to work on a saturday, but if you work at home on your own systems, you might come up with a workable procedure for yourself when you finally do get back to work.

  • Hmmm maybe I’ll give it a shot. I just can’t stop thinking about this but don’t want to go into work on a Saturday.

  • I have a motorola Surfboard Modem on my network and have yet to have any issues pxe booting. It listens for tftp yes, but only from the isp, not my network as the specifics it’s looking for is unavailable on my network.

  • Yes, that’s why I chose to put it there. It’s not being used for anything else, but is already configured so it was just a matter of downloading and installing FOG. Of course there is a firewall and one of these new Motorola Surfboard modem/router combo deals on the network which will make any PXE booting attempt a pain. So I’ll still create the second VM just in case and rename those files come Tuesday.

  • It’s possible, I’m assuming your home server you’re using Debian 7 as well?

  • A thought. Could the names of the NFS services be the root cause of all of this nonsense? The proper terms for my fresh install were nfs-common and nfs-kernel-server as opposed to nfs-common.dpkg-new and nfs-kernel-server.dpkg-new. Portmapper is running, mountd is running, there is no firewall, the config files seem fine. There is no other differences I can spot between my home server install and the one at work.

  • Well even Windows programs leave pieces of themselves behind. FOG runs in a virtual machine so I can delete and recreate without much difficulty. I made that decision for this very reason. Part of the issue here is also that I didn’t make a copy of the VM like I should have.

    An uninstall script would make a lot of sense for a future release. The effect may be mostly psychological, but it helps to know I can get rid of a program by clicking a file and running a command or two. Also to be perfectly honest after weeks of work I want something guaranteed to be effective. No offense, but I feel a clean slate is badly needed right now and the delete key has yet to fail me :p. Also there is a soft deadline to all of this. The library must go to Windows 7 by April which really means Spring Break (Mid-March) since there will be no other time before then when the library will be nearly empty. So I have to figure all of this out and by then. Except the Dean wants to meet in a week or two and I need something to show him.

  • I can probably make that all happen for you.

    The only issue I forsee with it is the deleting of the fog database (if you’re doing a full install of course)

  • Not feeling the awesomeness myself, but thank you for all of your help, Tom. Hopefully this will be of use to future users. I suspect something became corrupted during one of the reruns of the installer. It’s too bad there isn’t a script to uninstall the way one installs. If only I had the programming skills I’d write one. Till next time … :D.

  • Awesome then. I’m sorry about all the hassle.

  • Well I did a fresh install on my home server and encountered no errors whatsoever. Sadly my network would not play ball and I don’t have the energy to deal with it so I can’t say if FOG would totally work. But since none of my research has turned up anything that makes sense it seems the best course of action is to delete the whole VM and start from scratch. Something somewhere may have been corrupted and I’d rather burn the house down then try to root out all of the termites. Fortunately I have a three day weekend to get started.

  • It turns out you have to add .dpkg-new after both nfs-kernel-server and nfs-common. I was able to restart both although it did not help (also the web interface said the task could not be started). As for the last file it is /usr/share/nfs-kernel.server/conffiles. I have no idea what it does in relation to /etc/exports. Curiously FOG now seems to be able to resolve the host names and it is possible to tell whether they are on or off via the web interface, so some good has come of this.

  • The last one looks a little funny to me. Is that your /etc/exports? Why is it all commented? Maybe add the info I provided above into that one and restart. I might have the service scripts wrong in restart, take a look in /etc/init.d and find the one that deals with nfs. Maybe debian doesn’t use nfs-kernel-server but rather uses just nfs?

    [code]sudo service nfs-kernel-server restart
    sudo service nfs restart[/code]

    Maybe do a search for nfs blankly:


    Has info on nfs and might help.

    Of course replace portmap with rpcbind.

  • Sadly that has not helped, although it may make my life easier down the road. nfs-kernel-server and nfs-common are still unrecognized as services when I try and start them (and a reboot hasn’t helped) and the upload still fails when I try and start it. Have we ruled out the configuration files? I’ve attached four which seem relevant.