• They are both on the same subnet and behind a switch. And I’m game for a test.


  • I’ve got a little bit of a test if you don’t mind me trying something out.


  • It’s all good. One issue at a time.

    I’m assuming that both the FOG server and the client (the one your trying to upload from) is on the same subnet? Are they behind a switch or a router?


  • Oh my goodness, I can’t believe I did that! Unfortunately, I’m still getting the same error after making that change and restarting the dhcp server.


  • [code]option bootfile-name “prelinux.0”;[/code]

    Should read:
    [code]option bootfile-name “pxelinux.0”;[/code]

    You need to replace the letter r with an x.


  • Thank you Tom for your help!

    I think I installed the DHCP server. I believe I just did whatever the standard default install is. I would like the DHCP server to be on the same machine as the FOG server (Is that ok?), and that’s how I’ve been treating it. I’m not sure if I’ve set up my dhcpd.conf (on the FOG server) correctly, but I’ve added the following:

    [INDENT=1]option tftp-server-name “10.1.50.1”;[/INDENT]
    [INDENT=1]option bootfile-name “prelinux.0”;[/INDENT]

    Additionally, should I need to change any other options within that file, for example (subnet, option domain-name-servers, etc)? I’m sorry for not mentioning this earlier, but could a problem be occurring because the two Windows machines are both on two networks. One of the networks is the same as the FOG server, and the other is separate from the FOG server.


  • Also,

    Add the fact that the tftp command you performed downloaded the file with no ill effects, means your tftpd-hpa service was/is running. This issue only plagues 12.04 on bootup and is easily fixed by appending:

    [code]sudo sleep 30; sudo service tftpd-hpa restart[/code]

    rc.local file. This tftpd-hpa issue is not your current issue, and is easily fixed, if you don’t add the restart to the rc.local, by command line restarting.

    The issue I’m seeing, seems to be that the system isn’t receiving an IP address at all. This may be indicative that your current setup has 2 dhcp servers, and the system doesn’t know which server to receive the IP address from, as after it’s booted, all else seems to work fine.


  • albero,

    When you installed fog, did you install the DHCP server or not?

    If you didn’t you will have to tell your DHCP server were to point boot-dhcp requests.

    On a windows server, this is done in DHCP. Under, I think, option 66, you’ll put the pxelinux.0 file, and option 67, you’ll input your fog server’s IP address. This is why it’s not working, it doesn’t know how to send the BOOT information to the client.

    If your boxes, the one you want to upload the image from, is on a separate VLAN, you need to point it to your DHCP server so it can pick up, and receive, a valid IP address.


  • Sorry for taking awhile to get back to you. When I ran the command I got the following:

    [INDENT=1]“Transfer successful: 16967 bytes in 1 second, 16967 bytes/s”[/INDENT]

  • Developer

    albero, can you try running a command from a windows machine for me?

    run this command and tell me what the output is
    [code]tftp x.x.x.x get pxelinux.0[/code]

    Dont feel bad, this is the problem that plagued me when I set up fog 🙂


  • Hello Jaymes,

    Thank you for your response!

    So far I’ve done everything via the web GUI. That is due mainly in part because, as I am finding out, I have not completely setup FOG or at least not correctly. I’ve been attempting to set it up correctly so that the windows systems will be able to PXE boot. Currently, I get the following error:

    [INDENT=1]"[COLOR=#000000][FONT=Segoe UI]PXE-E51: No DHCP or proxyDHCP offers were received."[/FONT][/COLOR][/INDENT]

    This leads me to believe there is something wrong with the way I have DHCP set up. I’ve been looking through the User Guide and FOG Forums for any relevant information, but I haven’t gotten it to work yet. Additionally, I’ve seen that 12.04 has a bug where “it tries to start tftpd before the NIC interface has an IP address and it can’t bind properly”. I’m not sure if that is related, but I’ve started and stopped tftpd with no successful results.

    I was a little hesitant to post this on this thread because it is somewhat unrelated to the original problem, but here goes. Any insight is appreciated, and if I should create a new thread just let me know. Meanwhile I’ll just try to get this working.

  • Developer

    Albero,

    I use the PXE menu for everything I can, uploading hosts, quick image, etc.

    I create the image name save on the WEB gui, so the image NAME can be assigned to my hosts.

    I start by PXE booting and performing a full host registration, give it a name, tell it the image store you will be using (What you set up in the web GUI). Then reboot the machine.

    Now I go to the web GUI again, and under hosts, click the list all hosts, find the machine I just added. I click on basic tasks and tell it to upload.

    You can check the tasks and delete errant tasks so you can try again if you would like.

    Please check to make sure your machines display the PXE boot menu when you try to boot up the machine, if not you need to check the BIOS settings to make sure it is accepting Lan Option Rom (or something similar, enable PXE booting). Reboot, if you still don’t see the PXE boot screen, verify that the Option 66 and Option 67 are being supplied to your DNS and pointing to your fog server.

    These are just some steps I would try.

    Tom is probably closer to home than I, he actually develops and works really hard to keep fog going, but I would verify that the PXE boot screen is displaying, if not I would check the BIOS and tftpboot settings.


  • Ah, ok. I have the systems set up as KVM clients. I’ll see if I can set them up to PXE boot, then I’ll try the upload again and I’ll update this post with the results afterwards.

    Thanks again.


  • No, but I’m assuming you’re not seeing the PXE menu system which means on the system you need to enable PXE Boot.


  • Tom,

    Thank you for the quick reply.

    Yes, I have assigned the image to the host under “Host Management”. After I created the task I restarted the system I tried to create the image from, but the task is still queued and the /images directory is empty. Should the system being imaged be off when I create the task?


  • albero,

    From what I can tell, you told it to create the task, then you tried having it create the same task again. This is why you’re getting the “Unable to start task” issue. As you stated, the task is queued and waiting.

    I’m assuming you’ve inventoried a host and assigned the image you created to that host. Yes or no?

    If you have done the above, you need to start the system you’re trying to create the image from.

396
Online

8.8k
Users

15.5k
Topics

144.5k
Posts