• Hello,

    I followed the installation guide on the [URL=‘http://www.fogproject.org/wiki/index.php/FOGUserGuide’]Fog User Guide[/URL] and have everything set up accordingly (I think). The problem I’m running into is when I try to upload an image for the first time, using the web GUI and following the directions [URL=‘http://www.fogproject.org/wiki/index.php/Booting_into_FOG_and_Uploading_your_first_Image’]here[/URL]. After clicking “Upload Image” to finish creating the task I receive the error “Unable to start task” and nothing else. However, when I view active tasks I see the task I just created in the list and it’s state is “queued”. It remains in this state without doing anything and there are no images in the ‘/images/’ or ‘/images/tmp’ directory.

    I installed FOG 0.32 on an Ubuntu 12.04 64-bit server. The machine I am trying to image is running Windows 7 64-bit, but I also have a Windows XP 32-bit machine that has the same error.

    Any help is much appreciated.

  • As you’re getting the error when starting the task, what do you get when you try to create a simple directory in /tftpboot/pxelinux.cfg/?

    My guess is the permissions are not correct.

    To make sure all is fine in the tftpboot directory make sure you run the command:
    [code]chown -R fog:root /tftpboot[/code]

    This is a very simple command that I find people saying they’ve performed, but in actuality, the they’ve only run:
    [code]chown fog:root /tftpboot[/code]

    While they look the same, I assure you they are not. The -R tells the chown command so set everything within the directory to change ownership as well.

  • “unable to start task” and “unable to connect to tftp server”
    My current setup is Ubuntu 10.04 *updated/upgraded
    Installed Fog with the following settings;
    Server is
    DHCP is
    DNS DHCP is
    I’ve installed the DHCP server option for FOG, because I want this on a laptop to make it portable for imaging, along with an 8 port switch. I am totally off the network.

    Ubuntu username is fogger
    Password is password

    Everything installed great, I am even connect to the ‘defaultmember’ storage without problem.
    I now get PXE successfully sent to my clients, but only after I sudo \etc\init.d\dhcp3-server start manually after reboot
    I am able to do a full host registration, I can see my client and the MAC.
    BUT, when I now to go assign a task, (upload in this case) I get the infamous “unable to start task” and “unable to connect to tftp server” error.

    I’ve double checked that everything username is “fogger” and “password”. This includes the GUI change and the config.php file.
    I’m successful from the command line with ftp’ing with the username and password above.

    Any ideas?

  • You are not wrong, I just had my order wrong.

  • [I][quote=“Tom Elliott, post: 20836, member: 7271”]albero,[/quote][/I][quote=“Tom Elliott, post: 20836, member: 7271”]

    [I]On a windows server, this is done in DHCP. Under, I think, option 66, you’ll put the pxelinux.0 file, and option 67, you’ll input your fog server’s IP address.[/I]

    Not being cheeky and correct me if im wrong but in Windows server:
    [INDENT=1]066 Boot Server Host Name = fog server IP or hostname if you have added it in DNS[/INDENT]
    [INDENT=1]067 Bootfile Name = pxelinux.0[/INDENT]
    Pls let me know if I’m wrong so i can change my DHCP scope options - thx[/quote]

  • That seemed to do the trick. Some things that I ran into that gave me unnecessary trouble (I’m partially really dumb):
    [INDENT=1]chkdsk /f didn’t actually run fully because some process had the disk locked[/INDENT]
    [INDENT=1]When booting from the network it looked like it froze after starting to throw the same error as explained before.[/INDENT]
    [INDENT=2]I restarted the box instead of letting it continue (which if I had done would have let it finish successfully).[/INDENT]
    [INDENT=2] [/INDENT]
    Thanks again for all your help! I really like this forum, both for the support and it’s layout. Did you guys make the forum from scratch?! 🙂

  • Try following the instructions:

    NTFS is inconsistent. Run chkdsk /f on Windows then reboot it TWICE!

    Delete the task you’ve created. Then Boot the system and perform chkdsk /f, reboot the system twice after this has happened. They recreate the task and try again.

  • I’ve put the kernel in /tftpboot/fog/kernel/ then I restarted the FOG server and tried to boot from PXE (Onboard Network Controller). Thats when I receive the errors:
    [INDENT=1]tps65010: no chip?[/INDENT]
    [INDENT=1]acpiphp_ibm: imb_acpiphp_init: acpi_walk_namespace failed[/INDENT]
    [INDENT=1]LocalTalk card not found; 220 = ff, 240 = ff[/INDENT]
    [INDENT=1]wistron_btns: System unkown[/INDENT]
    [INDENT=1]acer_wmi: No or unsupported WMI interface, unable to load[/INDENT]
    [INDENT=1]acerhdf: unkown (unsupported) BIOS version Dell Inc./OptiPlex 96/A14, please report, aborting![/INDENT]
    [INDENT=1]Accounting clusters…[/INDENT]
    [INDENT=1]Cluster accounting failed at 2031117 (0x1efe0d): missing cluster in $Bitmap[/INDENT]
    [INDENT=1]Filesystem check failed! Totally 25936 cluster accounting mismatches.[/INDENT]
    [INDENT=1]ERROR: NTFS is inconsistent. Run chkdsk /f on Windows then reboot it TWICE![/INDENT]
    [INDENT=1] [/INDENT]
    I’ve been looking around for solutions on what to do, but none have been successful. Do you have any ideas?

  • No,

    It’s the tftpboot/fog/kernel/bzImage kernel.

  • Hello,

    I’m finally able to get started on this again, and hopefully get it working. I’m going to put the kernel you linked above on the FOG server. Just to check, is this a 12.04 64 bit ubuntu kernel?

  • Okay,

    I’m sorry about that. The “scribbly screen” as I like to call it, just means it can’t process the kms (kernel mode setting) properly. It should be creating the image though.

  • Ahh okay, I’ll do that tomorrow or whenever is next possible for me. My FOG server is unable to be connected to the internet, so I’ll need to do some extra work to get the kernel onto the machine.

    Thanks so much for the help so far! I didn’t expect such quality help from forums this quickly, but you’ve been great!

  • It’s not the error that’s giving you the issue.

    Download my kernel:


    Copy it to your FOG Server with the following commands: (ON THE FOG SERVER TERMINAL OR CONSOLE)
    [code]sudo cp /tftpboot/fog/kernel/bzImage /tftpboot/fog/kernel/bzImage.orig
    cd /tftpboot/fog/kernel/
    sudo wget --no-check-certificate https://mastacontrola.com/fogboot/kernel/bzImage[/code]

    Then try uploading again. You may have to recreate the task.

  • So I was able to PXE boot on the Win 7 machine and it produced the following output seen in “2.png” attached below. After a few moments, the screen displayed static that can be seen in “3.png”.

    I believed it to be frozen in this state (3.png), but as I was typing this the VM restarted and looks to be functioning again. I’m not sure what happened, but the task is still listed in “Task Management” for all active tasks as “queued” and there is a new empty directory in /images/dev on the FOG server whose name is the same as the MAC address of the machine whose image was to be uploaded.

    Found this post, [url]http://fogproject.org/forum/threads/no-chip-hp-compaq-6910p.202/[/url] ,that may be pertinent. I’m reading through it now myself.


  • I don’t see the picture, I’m assuming meant to put in, but no worries,

    Just describe what the error message says.

  • This post is deleted!

  • I was in the middle of recording what I think was an error when all of a sudden the screen looked like [URL=‘http://ak0.picdn.net/shutterstock/videos/529198/preview/stock-footage-television-static-noise-audio-included-black-white.jpg’]this[/URL]. I’m going to try to reproduce it.

  • So it’s, hopefully, working?

  • Things are happening!

    Not good things anymore 😞

  • Try putting these values into your fog’s dhcpd.conf file:

    Essentially create a new dhcpd.conf file, and don’t forget to restart the dhcpd service.

    [code]use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;

    subnet netmask {
    option subnet-mask;
    range dyncamic-bootp;
    default-lease-time 21600;
    max-lease-time 43200;
    option domain-name-servers; <-- USE YOUR REAL DNS SERVER IP ADDRESS
    filename “pxelinux.0”;

    I hope this helps you out.

    One you’re done editing, don’t forget to restart the dhcp service.

    For ubuntu it should be:
    [code]sudo service isc-dhcp-service restart[/code]