SSD not detectable on 0.32 with latest kernel 8.3.3

  • I have a HP DC8300 Elite that had a SATA drive which i could upload as image just fine, but im tryin to deploy that same image to a SSD on same host and I get these errors when trying to inventory with the HP DC8300

    3.) Partition Information
    Error: /dev/sda: unrecognized disk label
    4.) Disk…[Fail]

    Is there a newer kernel then the latest you can grab from the “Other Information Section>Kernel Updates” or do I need to be looking at FOG 0.33 beta 😞

  • It sounds like the partitioning scheme on the hdd is causing this particular issue.

    You may try an fdisk on the drive to verify what partitioning scheme is setup on it. It sounds like the first drive was initialized with the MBR tables and the other one is partitioned with GUID Tables.

    I don’t have much more information to help out with this.

  • ok I did try it on my lab fog server and no go…i also tried to build my own kernel with added scsi drivers and no go…well i guess i will stick to x32 for now on my home lab…ok back to my ssd issue

    This is my issue with SSD and HP DC8300
    A.) WD Black SATA3 320GB - inventories/uploads/downloads perfectly on the exact same HDD
    B.) EXACT SAME DRIVE AS STATED ABOVE - WD Black SATA3 320GB - NO GO, I have 10 exact models dc8300 and HDDs WD Black SATA3 that are identical.

    • Partition Information
    • Error: /dev/sda: unrecognized disk label
      C.) EDGE BoostPRO SSD
    • Partition Information
    • Error: /dev/sda: unrecognized disk label

    Im lost on why I could get one SATA to work perfectly then I pop in another exact HDD in original box and deploy and FOG doesnt recognize HDD, not to mention the original issue of not detecting my SSD, Tom I havent tried your new kernel you sent me for my Fog server at work I will try now…

  • I have included scsi drivers into my kernel including those for VM scsi. I don’t know if it will work. The best I can say is try it. If it doesn’t you’re not in any different boat than you are currently.

  • well i know its off topic with this VM business i brought up, but I have VMWare Workstation 7 and I have a lab fog server vm and I can grab images from x32 Windows 7 but not x64 and I have read to change your HDD bus type but you can do that in workstation even if you create a new vm and install with advanced settings…its always scsi.

  • As you state the System you’re using is VM’s, is it VMWare or Virtuabox?

    I don’t think my kernel will read the VM HDD’s from a setup of Win 7 64 because the configuration makes some change to how the drive is created. That change, probably works with Win 7 32 because of the way the VM Creates the HDD’s. I had a similar problem on VMWare and Win 7 64, but I got it to work. When I get back to work, I’ll take a look at the type of VM Drive I had to use to get it to work.

  • hey tom would this new bzImage also help with trying to get fog to see x64 Windows7 VM hdd’s? for some reason even on latest kernel running fog 0.32 with 3.3.8 I cant get my lab fog server at home to detect a Windows7 x64 when trying to inventory I always get the “failed with drive issue” but if i use x32 Windows7 works perfect.

  • By format, I’m referring to 4k (Advanced Format), or regular format drives. ext3 or ntfs should work regardless.

  • i will try tom, regarding the format are you talking ntfs vs ext3? im just trying to get a ssd to register with the fog server then deploy/upload just the same as my other test workstations with sata and Windows 7 x64 but these dc8300s use UEFI

  • I don’t know how well the kernel will help, but you can try mine as it has more Drive options available like scsi and the like. Maybe this will work, maybe it won’t as I don’t know the format the drive is using.

    My kernel is on 3.12.0


  • im thinking i need a newer kernel that supports ssd or UEFI enabled workstations…its truly the only difference between my current HP boxes…

  • well i do use the lastest kernel which 3.8.8 and of course it works perfectly with my HP dc5800, dc6000, dc6200 with Sata 3 drives and even my dc8300 works with sata but i cant get ssd. is there a reason why your not using latest kernel?

  • Moderator

    have you tried searching the internet for the error message to see what the problem might be or what steps you can take to find out more information. I image over 300 tablets with SSD drives in them without issue using an older 2.6.38 kernel.