Fog was working fine until a power outage


  • okay, thanks.

    Maybe this fixes it fingers crossed lol.


  • [quote=“Tom Elliott, post: 18126, member: 7271”]I’m going to ask that you reboot the server, if that’s okay with you?

    But before you reboot type:

    [code]touch /forcefsck
    shutdown -rF now[/code]

    The shutdown -rF now command will force the system to shutdown and ensure that, if for some other reason, forcefsck will work on next reboot.[/quote]

    Rebooting now.


  • I’m going to ask that you reboot the server, if that’s okay with you?

    But before you reboot type:

    [code]touch /forcefsck
    shutdown -rF now[/code]

    The shutdown -rF now command will force the system to shutdown and ensure that, if for some other reason, forcefsck will work on next reboot.


  • [quote=“Tom Elliott, post: 18124, member: 7271”]Okay,

    When you performed the install, did you have any special parameters involved. Such as:

    [LIST]
    []Is your tftpboot folder in a location other than /tftpboot?
    [
    ]Is your tftpboot folder hosted on another filesystem?
    [/LIST]
    Has your system performed a filesystem check and/or is your filesystem on a RAID setup? Is it possible one of the drives has failed?[/quote]

    The only special perameter was /images is mounted on a seperate drive. I just checked it and it appears to be mounted properly and I can navigate to it.
    The system as far as I know has not performed a filesystem check and I am not on a RAID setup.


  • Okay,

    When you performed the install, did you have any special parameters involved. Such as:

    [LIST]
    []Is your tftpboot folder in a location other than /tftpboot?
    [
    ]Is your tftpboot folder hosted on another filesystem?
    [/LIST]
    Has your system performed a filesystem check and/or is your filesystem on a RAID setup? Is it possible one of the drives has failed?


  • [quote=“Tom Elliott, post: 18122, member: 7271”]what is the output of the command:
    [code]umask[/code][/quote]

    0022


  • what is the output of the command:
    [code]umask[/code]


  • [quote=“Tom Elliott, post: 18116, member: 7271”]This is also going to sound a bit odd, I think, but is there a firewall running on the FOG Server? Is iptables disabled?

    To find out run:
    [code]iptables -L -n[/code]

    If you get the text such as:
    [code]Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination[/code]

    Then chances are it’s already disabled. If you get anything more than that run:

    [code]chkconfig iptables off; service iptables stop[/code][/quote]

    The firewall is off.


  • [quote=“Tom Elliott, post: 18114, member: 7271”]This may sound really odd, but can you try tftp from your fogserver with:

    [code]cd
    yum -y install tftp
    tftp -4 localhost
    get
    pxelinux.0
    exit[/code]

    Does this work?[/quote]
    I get the following:

    ]# tftp -4 localhost
    tftp> get
    (files) pxelinux.0
    Error code 0: Permission denied

    I am running as root.


  • No, you shouldn’t have to restart any services that I’m aware of, is there a reason you ask?


  • [quote=“Tom Elliott, post: 18113, member: 7271”]This is starting to make some sense.

    The files that you’re working with are all currently 666, or rw-rw-rw- try chmoding all folders as 755 with:
    [code]chmod -R 755[/code]

    Then perform:
    [code]find /tftpboot -type f -exec chmod 744 {} ;[/code]

    This should put all files as rwxr–r-- which is what my system looks like. It will also place all the directories as their natural state of rwxr-xr-x[/quote]

    Do I need to restart any services?


  • This is also going to sound a bit odd, I think, but is there a firewall running on the FOG Server? Is iptables disabled?

    To find out run:
    [code]iptables -L -n[/code]

    If you get the text such as:
    [code]Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination[/code]

    Then chances are it’s already disabled. If you get anything more than that run:

    [code]chkconfig iptables off; service iptables stop[/code]


  • This may sound really odd, but can you try tftp from your fogserver with:

    [code]cd
    yum -y install tftp
    tftp -4 localhost
    get
    pxelinux.0
    exit[/code]

    Does this work?


  • This is starting to make some sense.

    The files that you’re working with are all currently 666, or rw-rw-rw- try chmoding all folders as 755 with:
    [code]chmod -R 755[/code]

    Then perform:
    [code]find /tftpboot -type f -exec chmod 744 {} ;[/code]

    This should put all files as rwxr–r-- which is what my system looks like. It will also place all the directories as their natural state of rwxr-xr-x


  • [quote=“Tom Elliott, post: 18110, member: 7271”]Well,

    One way to be ensure it’s a permissions issue is to make sure all permissions are out of the question. Most Directories follow a 755 rule, and many of the files follow that as well. It sounds like it can’t write any request data to the filesystem, which means when you’re accessing it, it can’t modify the last access time. One way to verify if it’s permissions is to put the whole directory as rwx all the way through with:[code]chmod -R 777 /tftpboot[/code]

    Then try your ftp command. if that allows it to work, then try [code]chmod -R 755 /tftpboot[/code]

    It should still work. I can’t fully remember, though, if you have to specify the full path either, in reference to the command you’re writing in windows…[/quote]

    Changed the permissions to 777 and tried to rerun the command. I still get the same error. I even made up a filename to make sure I didnt have to enter the full path and it came back with a file not found. So I know my command should work. Scratches head


  • Well,

    One way to be ensure it’s a permissions issue is to make sure all permissions are out of the question. Most Directories follow a 755 rule, and many of the files follow that as well. It sounds like it can’t write any request data to the filesystem, which means when you’re accessing it, it can’t modify the last access time. One way to verify if it’s permissions is to put the whole directory as rwx all the way through with:[code]chmod -R 777 /tftpboot[/code]

    Then try your ftp command. if that allows it to work, then try [code]chmod -R 755 /tftpboot[/code]

    It should still work. I can’t fully remember, though, if you have to specify the full path either, in reference to the command you’re writing in windows…


  • forgot to mention I also restarted the service you mentioned as well.


  • [quote=“Tom Elliott, post: 18094, member: 7271”]Also,

    Please try service xinetd restart as that should control tftp for Centos 6.4[/quote]

    I tried the following command in Windows:
    [CODE]tftp x.x.x.x get pxelinux.0[/CODE]
    and I get:
    [CODE]tftp: can’t write to local file ‘pxelinux.0’[/CODE]

    Seems like a permission issue. But I’m somewhat of a newb.


  • Also,

    Please try service xinetd restart as that should control tftp for Centos 6.4


  • Try tftp command line windows lookup.

350
Online

9.0k
Users

15.6k
Topics

145.0k
Posts