• [QUOTE] I have to try to figure out about this sysprep thing with Windows 7. I understand the reasoning, but at the same time I think imaging a system should just be upload image, deploy when needed, presto/chango complete with imaging process. I not a huge fan of: make master, sysprep, upload, verify sysprep didn’t screw up activation (as necessary of course), then try again until you know you’re good, then deploy.[/QUOTE]

    Oh man, if you can find some way to either eliminate the need for sysprep or integrate it into FOG that would be awesome! Keep up the good work, I am glad to see this project is still active. I am preparing to use FOG in an environment with around 300 computers right now.

  • Moderator

    If you have a sysprep your using for tests, could you post it? I’m in the process of putting one together… one of the new places i’m working with need to sysprep… and unfortunately they don’t currently have an unattend.xml

  • Senior Developer

    r963 is out, addresses many more of the changes and allows redirect action in DatabaseManager.class.php to operate properly.

  • Senior Developer

    r961 is out as a quick fix to hopefully get you back rolling with install. I was trying to have it set the database values (username, host, password) from the GUI for both. Will update bz2 shortly.

  • Moderator

    I receive same error, Ubuntu server 10.04

    Also the fog sql database didn’t seem to be created using 960


  • Trying to install this latest release. Everything appears to install correctly, but I get this when loading management interface:

    FOG ERROR: DatabaseManager: Failed: DatabaseManager->__construct(): Error: Host not set
    FOG ERROR: DatabaseManager: Failed: DatabaseManager->connect(): Error: Class not constructed correctly
    Not sure what the deal is. My /etc/apache2/httpd.conf file is totally blank also. I don’t know if that’s supposed to be the case. Tried both the svn and the bz2.

  • Moderator

    This post is deleted!
  • Senior Developer

    I know I skipped two, just trust me.

    r960 is out.

    With it comes a new link on the host management page to view all groups associated with a host. From here, you can remove the association and join other groups. I hope this is what you wanted per feature requests.

  • Senior Developer

    r958 is out, apparently it didn’t take earlier with my move of processlogin to commons. This also has a processmobile login page just to ensure that is there.

  • Senior Developer

    Fixed the weirdness with the fog.css file and scroll bars, especially on the dashboard page. Hopefully you all are liking the fixed elements. r957 out.

  • Senior Developer

    [quote=“falko, post: 18095, member: 48”]Tom your a MACHINE with these updates!![/quote]

    I think that’s what I was born to do. I know there’s plenty more to do, but I am also starting to see the light at the end of the tunnel with 0.33 release. I have to try to figure out about this sysprep thing with Windows 7. I understand the reasoning, but at the same time I think imaging a system should just be upload image, deploy when needed, presto/chango complete with imaging process. I not a huge fan of: make master, sysprep, upload, verify sysprep didn’t screw up activation (as necessary of course), then try again until you know you’re good, then deploy.

  • Moderator

    Tom your a MACHINE with these updates!!

  • Senior Developer

    Good luck, and if there’s any pertinent issues, just let me know.

    Thanks,

  • Developer

    Dammit Tom, you’re awesome.

    I got some new server hardware today, I’m going to set up a 0.33b server and start merging my images, I’m excited to get this out of the VM and on a real box! Wish me luck 😄

  • Senior Developer

    r956 is out.

    With this comes Timers for Scheduled tasks, Both delayed and cron-style scheduled tasks appear to work properly. The mobile site appears to work properly now. You can now remove scheduled tasks and view what’s listed. It displays all scheduled tasks, whether active or not, but it displays the active status and the Type of job it’s set for.

    Hope you all enjoy.

  • Senior Developer

    Scheduled tasks, I hope, work on an actual basis now.

    I’ve, still, only tested the cron style as that was the most difficult to figure out for me. Maybe over the week I’ll try to fix and test single/delayed.

  • Senior Developer

    r949 is out. I’ve been able to test and watch tasks be created on a schedule. They never cleanup though, probably because I don’t have a real thing to test it with. The only thing I could watch be created on a schedule goes to the active tasks, and because the task doesn’t truly run the job doesn’t cleanup from active. It’s only cron jobs that I could test. I’m looking at some issues with entry so I couldn’t figure out how to do the single/delayed start.

    Thank you,

  • Senior Developer

    r948 is out. It should have everything, I imagine, needed for Scheduled Tasks to work. On the Tasks Management Page, comes the scheduled tasks list as well. It displays the type of task, and provides the needed items to delete the task.


  • Thanks!
    I will try this out out over the weekend in a VM and go from there!

  • Senior Developer

    r945, had error were it thought there was a duplicate key, it’s fixed now.

359
Online

8.0k
Users

14.9k
Topics

140.7k
Posts