Latest FOG 0.33b


  • Senior Developer

    The way the path get’s specified is by the isMaster AND isEnabled node. So if your NAS is simply a storage node, but is not labeled as Master, (there can only be on master node within a group) it will display whichever node is the master which my guess is currently your FOG Server. The FOG Server’s storage path is /images/



  • [quote=“Tom Elliott, post: 24307, member: 7271”]I’m going to guess that you have more than one node per group?[/quote]
    I’ve one group and one node in this group.


  • Senior Developer

    I’m going to guess that you have more than one node per group?



  • When i give a “Storage Group” to a Image, the Image Path do not change…
    example for the “Storage Group = NAS” the path do not modify to “/volume1/images/”

    [url="/_imported_xf_attachments/0/594_img1.png?:"]img1.png[/url][url="/_imported_xf_attachments/0/595_img2.png?:"]img2.png[/url][url="/_imported_xf_attachments/0/596_img3.JPG?:"]img3.JPG[/url]



  • [quote=“Tom Elliott, post: 24302, member: 7271”]That’s just a warning so it shouldn’t be affecting the operation.

    Is the service started and still running?

    Does the log have any information?
    [code]cat /opt/fog/log/fogreplicator.log[/code][/quote]
    it’s ok for me, thank Tom


  • Senior Developer

    That’s just a warning so it shouldn’t be affecting the operation.

    Is the service started and still running?

    Does the log have any information?
    [code]cat /opt/fog/log/fogreplicator.log[/code]



  • When i start the service FOGScheduler there is this message : PHP Warning: filesize(): stat failed for /opt/fog/log/fogreplicator.log in /opt/fog/service/common/functions.php on line 24



  • [quote=“Tom Elliott, post: 24296, member: 7271”]Warp,

    I think you need to check your fog server and make sure the FOG services are actually running:
    [code]sudo service FOGScheduler status
    sudo service FOGMulticastManager status
    sudo service FOGImageReplicator status
    [/code]

    To restart, change the part that says status to restart.

    Thanks,[/quote]
    Actually they are not Started, because I thought it was starting automatically after installation.


  • Senior Developer

    Warp,

    I think you need to check your fog server and make sure the FOG services are actually running:
    [code]sudo service FOGScheduler status
    sudo service FOGMulticastManager status
    sudo service FOGImageReplicator status
    [/code]

    To restart, change the part that says status to restart.

    Thanks,


  • Senior Developer

    r1341 released.

    Should fix issue reported on Imaging Log.php line 137. It was missing a ). I’m sorry about that.

    Add’s Delete label to the scheduled tasks. I’m sure other’s need this entered as well, but I still have to add hooking to this page, so it should be fixed once I complete that.

    Thank you,



  • I can not operate “Task manager” :
    when I created a Task it does not execute the indicated time was, is this a problem date.timezone? my Linux CentOS 6.5 is a good time.


  • Senior Developer

    [quote=“JiC, post: 24288, member: 15487”]Hi to all,

    I tried to install the latest 0.33b release (r1340) ; it’s a fresh install on a Debian 7 system.

    I had 3 problems :
    [LIST]
    []During the installation process, when Fog installer asks “What is the IP address to be used by this FOG Server? [adr:111.222.111.222]” if I submit as is for default value, the installer rejects the IP Address. I must specify it manually if I want to continue.[/LIST][/quote][LIST]
    [/LIST]
    This is a known issue. I haven’t quite been able to see where the issue lies exactly. As you can see it displays the IP just fine, but it doesn’t seem to like using it. My guess is just the place it’s looking at is adding more data than what it actually needs.
    [quote=“JiC, post: 24288, member: 15487”]
    [LIST]
    [
    ]When I go on the page “Service configuration”, if I enable/disable the status of a service (check/uncheck “Service Status” box) and click on the “update” button, I only have a white page ([url]http://myserver/fog/management/index.php?node=service&sub=edit&tab=displaymanager[/url]) and the change I made is not applied. If I edit the same settings in “FOG Configuration”->“FOG Settings”, it works. Maybe it’s a known bug ?[/LIST][/quote][LIST]
    [/LIST]
    It shouldn’t be a white page, but I’ll take a look today.
    [quote=“JiC, post: 24288, member: 15487”]
    [LIST]
    []After installing Fog, everything seems Ok. But I think there is a problem with TFTP Server settings :
    [/LIST]
    [LIST]
    [
    ]FOG_TFTP_PXE_CONFIG_DIR contains “TFTP_PXE_CONFIG_DIR” (which doesn’t seem set elsewhere)
    []FOG_TFTP_PXE_KERNEL_DIR contains nothing
    [
    ]FOG_TFTP_PXE_KERNEL only contains “bzImage”[/LIST][/quote][LIST]
    [/LIST]
    FOG_TFTP_PXE_CONFIG_DIR is no longer really required as we’ve moved the pxelinux.cfg directory to /var/www/fog/service/ipxe. The “config” is done dynamically from the boot.php/BootMenu.class.php files. Tasks aren’t “saved” anywhere anymore so we don’t need to ftp the 01-XX-XX-XX-XX-XX-XX files anymore.
    FOG_TFTP_PXE_KERNEL_DIR should be set based on the variables during install time. If it’s not set, I don’t know why. However, this should be set to /var/www/fog/service/ipxe
    FOG_TFTP_PXE_KERNEL should only contain “bzImage” as iPXE uses relative links. So when it chains to iPXE, it’s chaining to [url]http://{fogserverip}/service/ipxe/boot.php[/url]

    The relative location in full form when loading bzImage and init.xz would then be:
    [url]http://{fogserverip}/service/ipxe/{bzImage,init.xz}[/url]

    The location of the init.xz and bzImage files is in: /var/www/fog/service/ipxe which is why you set the KERNEL_DIR parameter to that folder. If for some reason permissions weren’t setup properly, this folder should be chown -R fog.root /var/www/fog/service/ipxe
    [quote=“JiC, post: 24288, member: 15487”]My /tftpboot folder contains this (there’s no file “bzImage”) :

    [INDENT=1] [/INDENT]
    [INDENT=1][CODE]-rw-r–r-- 1 fog root 828 mars 18 12:17 boot.txt[/INDENT]
    [INDENT=1]-rw-r–r-- 1 root root 75 mars 18 12:17 default.ipxe[/INDENT]
    [INDENT=1]-rw-r–r-- 1 fog root 395760 mars 18 12:17 ipxe.krn[/INDENT]
    [INDENT=1]-rw-r–r-- 1 fog root 25340 mars 18 12:17 memdisk[/INDENT]
    [INDENT=1]-rw-r–r-- 1 fog root 16794 mars 18 12:17 pxelinux.0.old[/INDENT]
    [INDENT=1]-rw-r–r-- 1 fog root 169248 mars 18 12:17 snponly.efi[/INDENT]
    [INDENT=1]drwxr-xr-x 2 fog root 4096 mars 18 12:17 tftpboot[/INDENT]
    [INDENT=1]-rw-r–r-- 1 fog root 100430 mars 18 12:17 undionly.kpxe[/INDENT]
    [INDENT=1]-rw-r–r-- 1 fog root 147728 mars 18 12:17 vesamenu.c32[/CODE][/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1]When I boot with a test computer, it can’t find any PXE Boot…[/INDENT]
    [INDENT=1]Do you know what I must change ?[/INDENT]
    [/quote]

    Please see above.

    Also, you’ll need to change your dhcp option 67 (I think) to point to undionly.kpxe rather than pxelinux.0



  • Hi to all,

    I tried to install the latest 0.33b release (r1340) ; it’s a fresh install on a Debian 7 system.

    I had 3 problems :
    [LIST]
    []During the installation process, when Fog installer asks “What is the IP address to be used by this FOG Server? [adr:111.222.111.222]” if I submit as is for default value, the installer rejects the IP Address. I must specify it manually if I want to continue.
    [/LIST]
    [LIST]
    [
    ]When I go on the page “Service configuration”, if I enable/disable the status of a service (check/uncheck “Service Status” box) and click on the “update” button, I only have a white page ([url]http://myserver/fog/management/index.php?node=service&sub=edit&tab=displaymanager[/url]) and the change I made is not applied. If I edit the same settings in “FOG Configuration”->“FOG Settings”, it works. Maybe it’s a known bug ?
    [/LIST]
    [LIST]
    []After installing Fog, everything seems Ok. But I think there is a problem with TFTP Server settings :
    [/LIST]
    [INDENT][LIST]
    [
    ]FOG_TFTP_PXE_CONFIG_DIR contains “TFTP_PXE_CONFIG_DIR” (which doesn’t seem set elsewhere)
    []FOG_TFTP_PXE_KERNEL_DIR contains nothing
    [
    ]FOG_TFTP_PXE_KERNEL only contains “bzImage”
    [/LIST]
    My /tftpboot folder contains this (there’s no file “bzImage”) :

    [CODE]-rw-r–r-- 1 fog root 828 mars 18 12:17 boot.txt
    -rw-r–r-- 1 root root 75 mars 18 12:17 default.ipxe
    -rw-r–r-- 1 fog root 395760 mars 18 12:17 ipxe.krn
    -rw-r–r-- 1 fog root 25340 mars 18 12:17 memdisk
    -rw-r–r-- 1 fog root 16794 mars 18 12:17 pxelinux.0.old
    -rw-r–r-- 1 fog root 169248 mars 18 12:17 snponly.efi
    drwxr-xr-x 2 fog root 4096 mars 18 12:17 tftpboot
    -rw-r–r-- 1 fog root 100430 mars 18 12:17 undionly.kpxe
    -rw-r–r-- 1 fog root 147728 mars 18 12:17 vesamenu.c32[/CODE]

    When I boot with a test computer, it can’t find any PXE Boot…
    Do you know what I must change ?[/INDENT]



  • In the Task manager, there is no possibility to kill one task.

    [url="/_imported_xf_attachments/0/593_Capture.JPG?:"]Capture.JPG[/url]



  • Hi Tom,

    In the report Management -> Imaging Log -> there is no page and there is message log in the /var/log/httpd/error_log :
    [SIZE=2][COLOR=#3366ff][Tue Mar 18 10:29:47 2014] [error] [client 172.16.8.167] PHP Parse error: syntax error, unexpected T_VARIABLE in /var/www/html/fog/management/reports/Imaging Log.php on line 137, referer: [url]http://srvfog.cavp.fr/fog/management/index.php?node=report&sub=file&f=RXF1aXBtZW50IExvYW4ucGhw[/url][/COLOR][/SIZE]


  • Senior Developer

    r1340 released.

    Fixes a syntax error on Host Management Page.


  • Senior Developer

    [quote=“Daryl Lee, post: 24278, member: 452”]I’ve been trying to keep up with the version changes, everything has been working for the most part pretty good and REALLY appreciate all the effort you have made for this project. i was wondering if a recent change did something that pushed a different kernel display setting again. For a while it was working fine in old school text mode but then it switched to something else which is having problems being displayed on some HP systems I have. I’ve memorized debug mode enough to type what i need and get it working, but are there kernel switches i can use to force a more compatible display mode?[/quote]

    What version of FOG are you using? What kernel are you using? I don’t know how to help if I don’t know this information. Nothing’s changed that I’m aware of as all of my systems are still coming up with the default text mode. I didn’t add any video drivers to my kernels either. I remove the i2c parameters to see if I could get baremetal systems to boot a little faster, but so far haven’t seen any issues with removing it or any major difference in how the kernel acts.


  • Senior Developer

    r1339 released. 1337 1338 both as well (obviously).

    1337 fixed issue with the kernel update screen where the input field was not displayed.

    1338 fixes the 64bit init.xz. No more IP request from the full inventory either.

    1339 fixes the advanced many system.

    Thank you,



  • I’ve been trying to keep up with the version changes, everything has been working for the most part pretty good and REALLY appreciate all the effort you have made for this project. i was wondering if a recent change did something that pushed a different kernel display setting again. For a while it was working fine in old school text mode but then it switched to something else which is having problems being displayed on some HP systems I have. I’ve memorized debug mode enough to type what i need and get it working, but are there kernel switches i can use to force a more compatible display mode?



  • You’re a star! I’ll try this out tomorrow!


Log in to reply
 

270
Online

7.0k
Users

14.2k
Topics

134.4k
Posts