• r1097 released.

    Made minor change in wol.php to report if there’s an invalid mac address.
    Updated TomElliott.config. It should include the bnx2 firmware during the build. It has other firmware’s as well but I’m more worried, at this point, of bnx2.

  • r1096 released.

    Contains, hopefully, fix for Wake-On-LAN Functionality through the web host. Will test more tomorrow with it just to ensure all is working properly.

    Contains new init.gz that has linux-firmware included and fixes the fog.capone file in the /bin/ of the init.gz file. I missed a back-tick and I’m sorry for that.

    Shortly, after some testing, I’ll post the updated TomElliott.config file. It’s filesize, once all is said and done, is 6.5 MB. This should also include embedded bnx2/bnx2-mips-09-6.2.1b.fw in the kernel as well.

  • VincentJ,

    Does hostname changer work with the FOG Client installed? I ask because I know the early hostname changer is working for XP, I’m still not sure on Windows 7 though as I’ve been working on fixing actual problems rather than tinkering with this little nuisance. Not that I’ve forgotten about it, just been busy trying to get other elements operating for people.

  • Moderator

    [quote=“Troye Johnson, post: 21308, member: 3048”]Question should the host name changer and joining a domain work by default?[/quote]

    Any word on the early hostname change for windows 7 or the client being made to change the hostname again?
    (Been a couple of weeks since my last test so a bit out dated.)

  • Developer

    running 1095 on Fedora 20
    when trying to set up deploy task.
    “FOG DEBUG: FOGPageManager: Class: TaskManagementPage, Method: deploy, Error: Method not found in class, defaulting to index()” at top of screen.
    Constant WEB_ROOT already defined in /var/www/html/fog/commons/config.php on line 92, referer: [url]http://localhost/fog/management/index.php?node=tasks&sub=deploy-post&type=2&id=3[/url]
    in the apache error log
    The task doesn’t get set up
    Both errors also seen at 1089, I’ve been installing the new svn over the top of the old, if that makes any difference
    I have seen references in the forums to the WEB_ROOT message.

    Any ideas?

  • Developer

    Capone problem solved, you had a missing quote in your fog.capone, corrected one attached.
    Don’t forget to chmod 755 it once you’ve copied into /bin

    Now to work on some of the other capone stuff!


  • Moderator

    Great Work Tom, will be spinning up a new .33 vm in a min

  • Thanks for the update tom. 🙂

  • MAC’s are supported as I’ve added the binaries to the init.gz, though I think this will have to be manual for the time being. I’ll have to add the MAC os to the OS Listing and have it translated to allow for hfs imaging.

  • r1095 released. Fixes space in the UDP part as stated in the BUGS forum.

  • Hi Tom seeing that we are using partclone now in 0.33b is it possible to image a mac. Not a great problem for me because we have only a few was just wondering. And looking to the future.

  • r1090 fixes an issue in the ImagingLog where it kept creating a new entry rather than updating the original one in the list. Should also fix multicast from going to port 666 no matter what. It uses the multicast_start_port from the globalsettings now. (Change in FOG Configuration->FOG Settings->FOG_UDPCAST_STARTINGPORT

    r1091 fixes an issue where I was a complete imbecile and for got to remove some of my testing parts. It was saying “Failed to update imaging log.” This should be fixed now.

  • I don’t know what you mean by that.

    They should work if you’ve enabled them. If they’re disabled globally AND/OR disabled on the host, then no they won’t work.

  • Question should the host name changer and joining a domain work by default?

  • the machine is imaging now I will test some more and let you know.

  • gotcha, so did that help out?

  • No I think I figured out why I dropped the database and reinstalled fog. then when I re-added my image on the machine i notice I was using a lower case w and not a Cap W.

  • Troye,

    Have you edited the Host.class.php file? Did you remove or change the line:
    [php]‘id’ => ‘hostID’,[/php]

    It should be line 11 in the file.

  • Hey Tom I have been having nothing but trouble with fog and hyper - V I finally got the machine to regester to the fog data base but now when I go to the Web gui to look at the computer I get this error

    FOG DEBUG HOST: Database load failed: ID 0, error: operation field not set: ID

  • Developer

    Testing capone on 1089, not working, dies early on. Other things work, strange thing is it fails the same if I replace fog.capone with the one I posted earlier. Will investigate further tomorrow.