Web interface slow navigating and gray screen - fog 0.32


  • Its just really slow and I can’t even image a workstation. I just get a gray screen after the image has been deploy… Thanks in advance.


  • Looks like I managed to resolved issue. I am pretty new to linux command, so I ask my co-worker how to add dns entry on my ubuntu lts. So he gave me commands below.

    vi /etc/network/interfaces
    then go to the end of the line gateway, type a, then hit enter.
    type dns-nameservers ipaddressofdns
    then hit ESC
    then :wq
    then /etc/init.d/networking restart

    My fogserver is faster than ever.


  • I wanted to let you guys know that. My old fog server is now fixed with this custom kernel.

    [url]http://fogproject.org/forum/threads/lenovo-x120e-upload-fail.339/[/url]

    The only issue just left is just slow navigating on WEB interfaces I think I could live with it. But, fogging workstation seems to be alright.


  • thanks for the quick reply. I will try that and report back.

  • Moderator

    Try a different kernel. Probably a driver issue in the bzImage kernel. You can update kernels using the FOG Web UI, or you can download and replace them manually in the /tftpboot/fog/kernel/ folder.


  • I am still cannot fog a host. I get stuck with this error

    failed to execute /sbin/v86d

    make sure that the v86d helper is installed and executable

    getting vbe info block failed


  • I guess I should only test 1 images and couple of workstation. I think i can move the images from old server to the new server. As far restarting the old server, I did that as well and many times haha.


  • [url]http://www.fogproject.org/wiki/index.php/Moving_Between_Servers[/url]

    [url]http://community.spiceworks.com/how_to/show/2631-moving-a-fog-server-to-new-hardware[/url]

    [url]http://fogproject.org/forum/threads/moving-images.112/[/url]

    I don’t know which will work best for you and your setup, but you should work.

    Also,

    Did the other server, by chance, get restarted before you started having the grey screen and such? Was tftpd-hpa service running? 12.04 has issues where tftp daemon starts before the NIC has an IP address, so it could potentially cause issues on the new server as well. Just a forewarning.

    [url]http://fogproject.org/forum/threads/tftp-issues-but-fixable.779/[/url]


  • I just end up creating a new hyper-v new ubuntu server 12.04.4 and new 0.32 fog server and works perfect. But, I have all the host and images, hardware inventory everything. Please advise how can I export then import to the new server. Thanks

  • Moderator

    Does your FOG server have internet access? The FOG web management login page tries to do an AJAX query to show the latest version and how many FOG servers are reporting in.


  • I checked the FOG_PROXY_IP it is empty.


  • When I go FOG Kernel Updates. I should query new updates but this one just giving me that “so if it seems like the process is hanging please be patient.”


  • I think the FOG Server having some dns issue. Though I added FOG_PXE_IMAGE_DNSADDRESS TO 8.8.8.8 but it seems not resolving names.


  • OK.


  • Thanks for the reply… When I tried wget --no-check-certificate -O /tftpboot/fog/kernel/bzImage [url]http://mastacontrola.com/fogboot/kernel/bzImage[/url] command I get an error temporary failure in name resolution. So I just download the file on my computer then upload via winscp. I did backup the old bzImage file first


  • Try a different kernel. That’s at least seeming to work for many others. I’ve built one doesn’t rely on the Video cards so should display something the entire time:

    [url]https://mastacontrola.com/fogboot/kernel/bzImage[/url]

    This file will go in the file system under:

    /tftpboot/fog/kernel/

    Just make sure you make a copy of your current one by doing:

    cp /tftpboot/fog/kernel/bzImage /tftpboot/fog/kernel/bzImage.orig

    Then run:
    EDITED FOR PROPER SYNTAX (SORRY)
    wget --no-check-certificate -O /tftpboot/fog/kernel/bzImage [url]http://mastacontrola.com/fogboot/kernel/bzImage[/url]

    Then try to do the task you’ve been attempting.


  • I have the Server 2008 R2 acting as the DHCP Server and I have the option where the 67 is set to pxelinux.0 and 66 where the IP of the FOG is. When host start and boot into pxe it sees the FOG and starting to do the commands and I see the image name. But, it do es not get me to the blue screen where I could see the progress bar of imaging status. Just gray screen.


  • So the tftp boot menu never appears on a client system?

    The slowness on the interface is what was thought to be indicative, but now it sounds like you have your setup to be FOG as the DHCP server. However, how are your clients connecting to FOG itself? Are you behind a router, switch, hub? If you’re in a router, you’ll need to tell your router to point to your fog server and pxelinux.0 for dhcp-boot. If you’re on a switch where the FOG Server is the DHCP server, you’ll need to make sure that firewalls are disabled on the server. Otherwise your server is blocking attempts for requests for DHCP.

    We still need more information I think.


  • Its alright I am noob in Linux in anyways… But, I think slowness I could get by with that. Is just whenever I tried to deploy image to a host. It just sits there and hangs then I get a gray screen. When I look at the active task on Fog management, it does not move the process bar. Just sits there and the computer is froze.


  • Creserva,

    Do you have a fundamental understanding of linux? I’m not trying to be mean, but what Hyper-V show’s isn’t necessarily what the system is actually using. It’s showing, more or less the assigned and CPU resource totals, not what the system’s actually using. If you know terminal open it up and get root access. Then type the command free and post the output of that. then type the command uptime and post the output of that. I’d still, highly, recommend a server restart. From terminal this can be performed with reboot, or shutdown -r now.

335
Online

8.7k
Users

15.4k
Topics

144.1k
Posts