Pigz abort

  • Senior Developer

    Does your fog server actually use /storage as the location for the images? Or is it the typical /images directory setup. If it’s /images, it’s trying to use your root system (120G) to store more than that worth of data which would fail. A bypass to that would be to move /images to /storage then link /storage/images to /images which could be done with->

    mv /images /storage; ln -s /storage/images /

    You wouldn’t have to make any configuration changes then. The other thing to check would be the /etc/exports file to see what your NFS system is trying to mount to store the image. My guess is it’s actually mounting /images even if your configuration is pointing to /storage

    To fix that, you’d simply change the file reference to /storage and /storage/dev (assuming that’s how your system is setup)

    Also check your .mntcheck files to see that they exist. They don’t actually contain information, but they need to be present. Make sure they exist by typing:

    touch /images/.mntcheck; touch /images/dev/.mntcheck; touch /storage/.mntcheck /storage/dev/.mntcheck

    chmod -R +x /images; chmod -R +x /storage

    Of course remove the items you don’t need as I don’t know what your particular setup requires.

    Then try again.

  • I’ve checked the disks, and they look good. /storage shows 1.2T Available (and / shows 120 G available)

    Somehow, the system doesn’t register what’s available. Any ideas where to look on the server? I’ve already looked up the Storage Management -> All Storage Nodes and double checked those settings, along with the config in /opt/fog/service/etc/config.php and /var/www/fog/commons/config.php.

    Would the memory_limit, post_max_size, and upload_max_filesize all set at 1900M in /etc/php5/apache2/php.ini cause a problem? (I tried to image a 325 G drive today and I still ran into a problem…)


  • Senior Developer

    From the sounds of it, your storage node is full which would explain why it stops imaging at, very nearly, the same point every time. Maybe try adding some storage space, if you can, or add another storage node that has the space available on it.

  • Yes, Tom, I think that is part of the problem. I’ve looked at the server settings, but I don’t see where it’s misconfigured. The strange thing is that previously I didn’t have any problems; it’s worked great for more than 18 months or so. I guess I got smacked by an update or two.

  • Senior Developer

    Can you try a system with a smaller image/partition table? Maybe even a different system altogether? This will let you know if it’s the system, or your fog server that can’t handle the issue.

    Also, are you sure you have 1.2 T available? This sounds like your storage location is full.

  • Actually, the “Image file size” continues to grow in size. Just did the all disk option, same (similar) results.


  • Senior Developer

    Something odd looks to be happening. The Image File size says that it’s only 3.97 GB, but the data that’s being copied is 173.88 GB? Does that sound right to you? It looks like it’s copying the image file size (3.97GB) then aborting the upload because it’s reached the file size. What if you try creating a new image with Multiple Partition, All Disks Non-resizeable. Then assign that image to the machine, then try to upload?

  • It’s a WD 500 GB SATA3 6 Gb /16 MB Cache (WD5000AAKX) and looks like a regular run of the mill platter to me.

    The only thing that looks odd to me is the Available space for image:… 1.66 GiB


  • Senior Developer

    So when the image is being uploaded/created, it tells you the size of the image upload. Is this Partition 2 the full size that it’s copying, or is there free space? Next question would be, what kind of Hard Drive is the 500 GB? Meaning, is it SATA/AHCI or SATA/IDE in the bios? Is it a Solid State, Solid State Hybrid, or regular Platter drive?

    This is important, as through some of my testing, I’ve found that, especially hybrid SSD, actually causes my kernel to crash because it can’t open a solid read/write stream to the drive. It keeps hanging and will give this pigz error anywhere between 2 minutes, to 10 minutes into the image upload cycle.

  • I’m not sure how big the image file will be. The drive is a 500 GB drive. The partitions are as follows:

    1 - 100 MB System
    2 - 456.70 GB NTFS
    3 - 8.86 GB HP Recovery
    4- 100 MB

    I have 1.2 TB available on the server.

  • Senior Developer

    What is the size of the image to be created? How much space is available to actually store the image?

Log in to reply