Problems Deploying Acrobat Snapins

  • Hello All,

    This is my first time posting so bear with me if I don’t give enough information. So, I installed Fog on a Debian virtual instance located on a ESXi server. It works wonderfully with most features. Uploading and Deploying images and Deploying most snapins works well. But I am having problems Deploying Adobe Acrobat Standard 9 and 10. I setup the server for larger snapins like Ubuntu per this post:
    I did an administrative install of Adobe Acrobat onto a server share, updated the server shares version of Adobe to the latest update, tested the server share to ensure that it will install, and then zipped them into a executable using SFXMaker. The snapins are pretty large coming in at 1.1 and 0.8 GB respectively. The server has worked with larger file sizes, MS Office 2007 was 297 MB, and so that makes me think that I have the configuration setup properly. I uploaded the files to the Fog server without any errors. When I assign a client to download it from the server I get this message in the fog.log:
    [QUOTE] 5/13/2013 6:57 AM FOG::SnapinClient Starting FOG Snapin Download
    5/13/2013 6:57 AM FOG::SnapinClient Failed to download file.
    5/13/2013 6:57 AM FOG::SnapinClient The remote server returned an error: (500) Internal Server Error.
    5/13/2013 6:57 AM FOG::SnapinClient at System.Net.WebClient.DownloadFile(Uri address, String fileName)
    at FOG.SnapinClient.startWatching()[/QUOTE]

    I cannot figure out what i am doing wrong. Any help would be appreciated.

  • I removed the snapin and added it again. Remade the snapin and added it again. There are 2 snapins that I was having trouble with and neither are downloading. I don’t know what the deal is. I made a work around that might work. I just made a script that maps the network share that the AI’s are located on and then runs them. Do you have any more ideas to get the regular snapin install to work?

  • Moderator

    I did not see anything in those logs. Can you remove the snap-in and files from fog and recreate it, then try to push it out again? See if you get the same error.

  • Okay, so I looked in the apache2 logs and there is a ton of information which means not a lot to me. To get a better Idea of what was going on I restarted the server to get fresh logs. I had a snapin already queued before the restart. The client pinged the server a lot once it checked in but it looks like the only errors were from me canceling the snapin on a different computer. I uploaded the access and error logs for apache2 but had to add .txt in order for it to upload to the forum. Hope that this gives you some info. Thank you.


  • Moderator

    check the apache log on the FOG server. It appears that whatever page the FOG client is requesting when it sees it has a snap-in waiting is not working well with your snap-in.