• I’m trying to create and deploy an Ubuntu image. Initially, I created the image using Ubuntu 12.04’s defaults & when I tried to deploy it I got an error that the partitions were corrupt. I finally realized that maybe FOG didn’t support ext4, so I set the partition to be ext3. I was able to grab the image, but deploying it gives me an error - partition filesystem missing. I get that on both the swap partition (which I expect), but also on the main ext3 partition. Any ideas?


  • Developer

    First make sure your image is set up for MULTIPLE PARTITIONS aka the WHOLE disk.

    Then take a look here: [url]http://fogproject.org/forum/threads/problem-uploading-ext3-ubuntu-image.459/[/url]

    I found this from the link above. Others have had success, try this below:

    Update: I finally tried manually using PartImage to pull the image with the plan to then copy it manually in to the server. In doing so, I saw that PartImage was erroring out (which FOG was hiding). Googling around found that running an fsck prior to uploading the image fixes the problem. I may dig in to the FOG code to see if I can make it automatically run an fsck prior to pulling any Linux image. For now, though, I just boot my source PC in to a live CD and fsck, then I upload the image. Works a treat.