Error mounting filesystem /images/dev on an NFS



  • Hi all, I’ve been going slightly crazy trying to figure this out. I have a Cisco NSS nas unit which I’ve created a share on for the FOG server.
    I’ve followed the guide here (http://www.fogproject.org/wiki/index.php?title=FOGUserGuide#Separate_NFS_Server) and performed the following commands:

    sudo mv /images /imagesold
    sudo mkdir /images
    sudo nano /etc/fstab

    and added the line
    nasipaddress:/fog /images nfs defaults 0 0

    I’ve also created a dev folder, and done sudo touch .mntcheck

    Both the images folder and dev folder are chown fog:root and the permissions are 777 on all files and folders within. From the shell, I can navigate into the dev folder, create folders and delete them.

    When I try to take an image of the machine I am working on, I receive
    "Fatal Error: Failed to mount NFS volume"

    Above it, I see "/images/dev failed, reason given by server: Permission Denied
    mount: mounting :/images/dev on /images failed: Bad File Descriptor

    However if I manually try and mount the dev folder somewhere in the OS, I can do what I want in there, create, delete etc.

    OS Is Ubuntu 12.04

    Can anyone offer any suggestions at all?



  • Finally got it working!

    My FTP settings on my FreeNAS box were not correct. I had to add a user to the FTP service called fog with the password used for the management console.

    Of course, when I say working, I mean the upload portion. I now get a permission denied error when trying to send an image to a system.

    So if I run it with Capone, it says ```
    mount: <ipaddress>:/images/ failed, reason given by server: permission denied

    mount: mounting <ipaddress>:/images/ on /images failed :Bad file descriptor

     
     
    I have two storage nodes setup like suggested, following the instructions listed in this thread by icarus.
     
    When I deploy an image, it tries to load the image off of defaultmember, which fails, then it tries to load off of my second storage node, which works fine, loads as it should.
     
    Why does Capone fail, but host deploying work?
     
     
    EDIT:
     
    When typing ```
    sudo exportfs -a
    

    I get the following:

    exportfs: Warning: /images/dev does not support NFS export.
    exportfs: Warning: /images does not support NFS export.
    

    My /etc/exports looks like

    /images             *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure,no_subtree_check)
    /images/dev         *(rw,sync,no_wdelay,no_root_squash,insecure,no_subtree_check)
    

    Sorry if it feels like I am hijacking this thread, not trying to, just didn’t think my issue deserved a whole new thread.



  • Just double checked.

    The FOG box is on CDT and my main machine is (Windows) Central with daylight savings time. Turning off the daylight savings time and setting the clock manually had no effect.

    I’ve RDP’d into the Ubuntu box and checked it locally on Epiphany, This too gives me the wrong time. System time is set correctly however


  • Moderator

    I think there is a known issue with the bandwidth graph time being off by 6/7 hours depending on daylight savings time. Have you made sure the client you are viewing the graph on has the proper date and time and time zone settings and the server is set in the correct time zone also?



  • How did you get on?

    My test worked ok, but the bandwidth graph still is 7 hours ahead and refuses to show information. Fortunately the system appears to actually be working!



  • My computer finished, and I had the “FTP connection…” error again. While the system was running, I changed the DefaultMember back to defaults, and created a new one, and the system finished, and the files moved as they should have.

    So I have deleted that image and am trying it again.



  • Just so the graph would work for remaining space.



  • Followed your directions and am currently uploading an image to test it.

    Why dd you add a storage node instead of editing the DefaultMember?



  • Got it! It’s working!
    I’m going to do a fresh install of this server I think. The time is messed up on the bandwidth receive graph.

    Ok so for future individuals, here’s my little guide during installation

    Adding a NFS share

    First, get rid of the old /images directory. Move it somewhere safe
    [B]sudo mv /images /imagesold[/B]
    [B]sudo mkdir /images[/B]
    [B]sudo chown –R fog:root /images[/B]
    [B]sudo chmod –R 777 /images[/B]

    Next, let’s edit your fstab
    [B]sudo nano /etc/fstab[/B]

    Add the line in your fstab for the nfs drive
    [B]IPADDRESS:/sharename /images nfs defaults 0 0[/B]

    Mount the drive
    [B]sudo mount -a[/B]

    Then reapply the permissions to the folder now that the drive is mounted. Create the dev folder and .mntcheck folders
    [B]sudo mkdir /images/dev[/B]
    [B]sudo touch /images/dev/.mntcheck[/B]
    [B]sudo touch /images/.mntcheck[/B]
    [B]sudo chown –R fog:root /images[/B]
    [B]sudo chmod –R 755 /images[/B]
    [B]sudo chmod –R 777 /images/dev[/B]

    Then login to the FOG panel, go to storage management, click Add Storage Node and then use these values

    Storage Node Name: Whatever you want
    Storage Node Description: Whatever you want
    IP Address: IP Address of your NFS share. JUST THE IP ADDRESS
    Max Clients: Whatever you want, I generally stick 10 in there
    Is Master Node: Yes. Note - if you tick this, it’ll wipe images you’ve already created
    Storage group: Default
    Image location: Enter the folder on your NAS drive that your images are stored in
    Is enabled: Tick it
    Management Username: the username you use to login to the FOG control panel
    Management Password: the password you use to login to the FOG control panel

    Click update, and you’re done!



  • @mootsfox, post: 11569, member: 1747 said:

    Is it uploading but not renaming and moving the img files from /dev?
    It was but I changed the TFTP password on the NAS and it looks like it went through. Right now it’s trying to upload an image for me and has 30 minutes left. I have some very strange things going on right now. Nothing in the Bandwidth - Receive graph. In fact right now it shows the time as 7pm, rather than 2pm. However if I manually go to the dev folder on the NAS and do an ls -lh I can see the file growing. So it’s not all bad I guess. Maybe I’ll map the NAS to my /images folder since that was able to see the disk size quite happily



  • Is it uploading but not renaming and moving the img files from /dev?



  • Alrighty so the test has worked and I’ve got the FTP error issue but it looks like it’s uploading ok.

    I’m running another test because suddenly in the dashboard, I can’t see anything relating to the size again on the DefaultMaster, whereas I could before.

    I will report back



  • UPDATE! = Success!

    I have it working I deleted and recreated the .mntcheck files in both the directories and BOOM suddenly it started working properly.

    I’m guessing that I must have corrupted the .mntcheck files with all the attempts

    UGH three days!

    I’m going for lunch and I’ll update exactly what my config is when I get back. Hopefully someone who searches in the future will be able to benefit from the information.



  • Ok, so I’ve gone ahead and unmounted the drives, removed from my fstab, removed any tasks outstanding and rebooted to make sure it’s all totally and utterly clear.

    I’ve moved the originally installed /images folder back to /images (all I did before was move it from /images to /imagesold

    I’ve made a directory at /media/images where I can mount my share. It’s chowned to fog:root, and chmodded to 777

    fstab now looks like this

    
    IPADDRESS:/fog /media/images nfs defaults, 0 0
    
    

    Then, sudo mount -a to mount the drive

    Ok, back into the fog dashboard
    Created storage node

    IP address is the IP address of the NAS
    image location /fog/
    Username and Password is the same username and password I use to login to the fog dashboard
    Click update

    Create new upload task annnnnddd
    same error as before, mounted - done. Checking mounted file system - error, failed to mount

    So, with the drive mounted

    sudo chmod -R 755 /images
    sudo chmod -R 777 /images/dev
    sudo chown -R fog:root /images

    Try again and nope.
    So, chmod -R 777 /images

    Nope!

    Head = Brickwall



  • Is your mount correct (can you still access it in the OS)? Your NAS must be mounted to the /images directory on the fog system.

    Are the settings in your storage node correct for your NAS?



  • Alright confirmed I can get it further than before. Thank you!

    New issue however. I now get

    
    Mounting File System........................DONE
    Checking Mounted File System...........................
     
    AN ERROR HAS BEEN DETECTED
     
    Fatal Error: Failed to mount NFS volume
    
    

    Now that’s wierd



  • SO, it works!

    I followed these instructions: http://fogproject.org/forum/threads/request-fog-nas-tutorial.419/#post-11178

    Instead of mnt/pools/A/A0/images, you will use your mount, and of course, your ip to your NAS instead of the one he used. The password should be fog/password unless you have changed the FOG password (not the system password).

    A word of caution, setting the node as Master (which I believe is needed for this to work) will overwrite your other nodes if you have any. Backup any images you need to keep.



  • /mnt/pools/A/A0/images is the directory on his NAS. You should still mount it to /images.

    To be clear, if you have the drive mounted correctly without any other changes, to /images , the FOG Dashboard should show the correct disk information. I really do believe that the mount is correct, and the problem is with the client not having correct permissions.



  • Thanks for the feedback. I’ll change the ownership to fog:root and give it a go.

    I too am having thoughts that it’s the TFTP client that doesn’t have permission to mount rather than fog. I feel like I should be giving the TFTP client a username or password for the NFS share but can’t seem to find a setting for it.

    Edit:
    Ok tried the fog:root permissions. No luck
    Tried following that guide to mount the NAS to another directory. Nothing. Actually get failed to connect on most things.

    Here’s what I did.
    Created the directory /mnt/pools/A/A0/fog
    Chowned the directory recursively as fog:root and chmodded it as 777 as well

    My /etc/fstab looks like this

    
    IPADDRESS:/fog/ /mnt/pools/A/A0/fog nfs user,bg,noexec 0 0
    
    

    It mounts, again I can navigate to it and do what I want in it, but the FOG dashboard says failed to connect if I try and create it. Unlike that guide, It doesn’t show up for me under disk information on either the DefaultMember group or it’s own connection.

    Hmm.

    Edit 2:
    Just to be sure I changed the /etc/fstab to mount it to /mnt/pools/A/A0/images rather than /fog
    Still no bueno!



  • I feel like the issue is the client not having read/write permissions on the NAS. Like you said, the FOG system has permissions, and the mount is fine. I am fairly sure that it is not a problem with the NAS, as (mine at least) has no password required, and guest access to read and write enabled, and the export has No_root_squash which should allow non-root to have full permissions.

    I have a feeling that there is a password field or setting in FOG that is being over looked.

    I also didn’t get a chance to build from scratch today. I don’t want to take down the FOG system I have because it is in production and the system I was going to use has a hardware failure. When I get my parts in, I’ll try again, using these directions:

    http://fogproject.org/forum/threads/request-fog-nas-tutorial.419/

    For your /images and /images/dev folder it looks like you have the ownership of root, when it should be (according to the above thread) fog.


Log in to reply
 

351
Online

38746
Users

10569
Topics

100052
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.