Cannot get iPXE to connect to FOG Server


  • @george1421 " dhcp server, dhcp options 66 should be the ip address of your fog server, and dhcp option 67 should be undionly.kpxe for a bios based computer or ipxe.efi for a uefi based computer."

    Can you tell me how to go about doing this?


  • @trev-lchs Yes, this is a linux/ubuntu server setup on VirtualBox


  • @george1421 I run an Ubuntu server on VirtualBox and we use this as part of our imaging process in my job. It’s isolated on a computer that’s not regulated by my company, so it’s free to do whatever without blocks or firewalls.

    I’m not sure how to change the dhcp options on my server.


  • @rav I was assuming you were setting this up on a windows network, with an Microsoft windows domain. So is your DHCP server a linux box then?


  • @trev-lchs Ohh, okay, that makes sense. A windows server would have made this a lot easier I think, haha. I appreciate the help though 🙂


  • @rav Sorry Rav my experience is with windows servers Maybe @george1421 will be better equipped to help you with this one.


  • @trev-lchs I typed all of this and I’m not sure what I need to change:

    subnet … {
    authoritative;

    }

    class “pxeclient” {
    match if substring (option vendor-class-identifier, 0, 9) = “PXEClient”;

    if substring (option vendor-class-identifier, 15, 5) = "00000" {
        # BIOS client 
        filename "undionly.kpxe";
    }
    elsif substring (option vendor-class-identifier, 15, 5) = "00006" {
        # EFI client 32 bit
        filename   "ipxe32.efi";
    }
    else {
        # default to EFI 64 bit
        filename   "ipxe.efi";
    }
    

    }


  • @rav https://wiki.fogproject.org/wiki/index.php/BIOS_and_UEFI_Co-Existence Hi Rav, follow this, but please add the fog server IP to option 66. Also if you have subnets to need to complete this on each subnet scope on the dhcp server, also if you have 2 DHCP servers you must do it on each one and on each subnet


  • @trev-lchs Can you tell me what the commands are to do this? Or maybe a guide on how to do this? I’m not sure where to begin.


  • @rav Can I just please add, if you are setting it up for UEFI, you must when adding the DHCP option to the new policy, you must put the Fog IP address in Option 66. You might think you don’t need to, as you already have it in for the BIOS booting. But if you are adding a policy for UFEI you must add the fog server address into option 66 for tftp server, otherwise the UFEI client does not know where to get the IPXE.EFI file (or whichever file you specify in option 67) from.

    This is not in the WIKI and is a step that is often missed. Especially by me.

  • Moderator

    @rav said in Cannot get iPXE to connect to FOG Server:

    I get the error “PXE E51: No DHCP or proxyDHCP offers were received.”

    This specific error is related to your infrastructure and not FOG (at the moment).

    The error is telling you that your dhcp server either didn’t respond to the target computer, or your dhcp server responded but it didn’t provide the proper pxe boot info.

    What device is your dhcp server?

    Is the imaging network part of your business network or is your imaging network isolated, where FOG is your dhcp server?

    On your dhcp server, dhcp options 66 should be the ip address of your fog server, and dhcp option 67 should be undionly.kpxe for a bios based computer or ipxe.efi for a uefi based computer.

254
Online

9.9k
Users

16.2k
Topics

149.0k
Posts