• Hello,

    I have ubuntu 20.4 and the latest version of Fog.
    When I want to inventory a new PC, it freezes at bzimage 4% or 7% or…
    What is the problem ?

  • Moderator

    @jmroc85 The problem is that ipxe.efi that ships with FOG 1.5.9 is 2 years old and we are finding compatibility issues with currently shipping hardware.

    So you used the tarball method of installing FOG? Was there a specific reason for going that route?

  • @george1421 Ok
    But I didn’t use the git method to install.
    I use ipxe.efi on very recent computers (hp 360 g4). Is this the correct boot loader ?


  • Moderator

    @jmroc85 said in bzimage freeze:

    I updated the kernel but the problem is still the same

    I might have given you too much info in the last post. Updating the kernel will not solve the transfer problem. bzImage IS the kernel and the problem is bzImage can’t get to the target computer. So updating it has no impact on your problem. It will solve a few problems you will have next. But for this one no.

    Updating of the iPXE boot loader might fix the problem, because its iPXE’s job to transfer bzImage to the target computer. This is the bit that’s failing. I’m not saying iPXE is causing the problem, but right now its actively doing something when we see the error.

    This error could also be your networking infrastructure or the specific computer you are using.

  • Thanks for your answer

    I updated the kernel but the problem is still the same

  • Moderator

    @jmroc85 Lets have you start by updating (installing) the latest version of iPXE using this tutorial: https://forums.fogproject.org/topic/15826/updating-compiling-the-latest-version-of-ipxe

    I’m not suggesting this will fix your issue but upgrading the version of iPXE will solve a few other issues you might run into.

    The second part is with bzImage (this one is not related to your current issue at all) but using the FOG Web UI -> FOG Configuration -> Kernel update. Update the version of FOS Linux kernel to 5.15.x for both the 64 and 32 bit versions.

    Once both have been updated, then try to image again.