• Hello!

    I’m having some trouble deploying a Rocky 8.5 image.

    It’s the same result as this user had (unfortunately the thread went dead before a solution was found/posted) https://forums.fogproject.org/topic/15325/centos-7-uuid-not-updated-during-imaging-will-not-boot?_=1652105608477

    I deploy the image and I get a warning the /dev/disk/by-uuid/blahblahblah does not exist and I get sent to emergency mode.

    I’m running FOG 1.5.9.

    Source Machine is a VMWare ESXi 7 VM. I’ve tried with LVM and standard Partitions.


    It’s the sda2 - SWAP partition that fails.

    Could someone give me a point in the right direction?


  • Thanks Wayne, I’ll get the the swap partitioned removed, recapture and try again!

  • @ben604 Fog doesn’t support LVM at all currently, so the only way to make lvm work is with a raw image, and destination disk being identical size as the source disk. Even at that, deploying raw takes ages, super slow.

    Use standard partitions instead to get the speed and resizing benefits.

    Also on your swap partition failure, im sure you know this but saying anyway incase someone else doesn’t and reads this. Swap is not required. Particularly not required if you have ample ram. But, even on systems without ample ram, things still work without a swap partition.

    Of course best thing is for fog to handle it right. Just offering something that might get you going.