• Hello, I’m a long time FOG server user, and first of all you do an amazing job !

    I’m imaging on Fujitsu computers (esprimo P558/P5010 Q558/Q7010) and laptops (lifebook A359/A3510 E559/E5510 U759/U7510) for around 3 years now.
    When I had difficulties with new generation (last 1/2 digits on product number 9/10 eq. 9/10th gen intel core proc) I used to update Kernels and iPxE and it just works.

    However I have an issue deploying image on last generation Fujitsu laptops (E5511 and U7511).
    FOG v1.5.9
    Kernels v5.10.71
    iPxE v1.21.1 [g1192e]
    I have a workaround, using a USB-network adapter and it works just fine booing and imathing through this ethernet interface ipv4. Atolla adapter on Amazon.fr
    When I try booting my laptop on the native ethernet interface ipv4, it successfuly loads up to FOG main menu then [deploy image] then it take ages to restore image [here is a picture i took during the process] 594cc77f-4d2d-4ff9-aaf5-5817ab0a3db8-IMG_20220201_173352.jpg

  • @sebastian-roth I had to hand over the U7511 and i did test on another laptop [E5511] ; i’m going to test on another U7511 when i’ll receive a new one next week. I’ll get you in touch.

    Thank you again for the good work you do !

  • Moderator

    @Francois Great!! I am surprised just as much as @george1421 is. While I did hope the newer kernel version might help it was more of a straw I pulled at. Anyhow, great this worked for you and thanks a lot for your quick response. This is a good starting point for us to move on and make the 5.15.x kernel series the new default. I just started a full build. New official (dev) kernel version will be available here soon: https://github.com/FOGProject/fos/releases

  • Moderator

    @francois Very nice setup!!

  • @george1421 I isolated my production network from my Deployment network.
    If you’re interested, here is a logical network plan of my FOG Network

    • “Switch FOG” is an old D-Link DGS-1016D
    • I also used D-Link DGS-1024D [with “Port isolation & Storm control switch” turned ON that comute only the 24th port with the others] when i mass deployed using multicast 24 laptops per deployment (last picture is 100% show off)
  • Moderator

    @francois Very good speeds. I would say you are running parts of your network on 10GbE on a healthy network to get those deployment speeds. Well done!.

    I am surprised that 5.10.71 was giving you those bad speeds where 5.15.x is working. Surprised in this case is a good thing.

  • @sebastian-roth It worked, Thank you very much !
    @george1421 It’s way better now, anything GB/min is far more desirable ! 🙂
    Thank you both of you, it’s solved.
    If anyone ever has the same issue [FUJITSU E5511 U7511 deploy image is super slow], here is what i did :

    • Download bzImage-5.15.19
    • Move it to /var/www/html/fog/service/ipxe/
    • On your FOG server web page go to [FOG Configuration] top menu > [FOG Settings] on the left pane > expand [TFTP Server] > replace [TFTP PXE KERNEL] item by bzImage-5.15.19
    • It should work now
      When the [Kernel Update] item on the left pane will be updated with new version you will have to change back [TFTP PXE KERNEL] item to bzImage

  • @sebastian-roth i’m going to start with this, thank you.

    @george1421 If the kernel update doesn’t work i’ll give it a try, thank you too.

  • Moderator

    @francois said in Fujitsu U7511 E5511 Imaging Deploy:

    When I try booting my laptop on the native ethernet interface ipv4, it successfuly loads up to FOG main menu then [deploy image] then it take ages to restore image [here is a picture i took during the process]

    This points to the Linux kernel driver not having an issue on this paticular device/network card or a firmware issue as George pointed out.

    As there is a new long term branch for the Linux kernel I just compiled a fresh 5.15.19 kernel. You are welcome to test it: https://github.com/FOGProject/fos/releases/download/testing/bzImage-5.15.19

  • Moderator

    @francois Have you checked to see if you have the latest firmware on these troubled Fujitsu computers?

    I agree that 944 KB/min is terrible. Who has time for that? (joke).

    I would first start by making sure firmware is up to date. Then we can debug more to see if its network or slow disk making imaging slow for you.