SOLVED Suddenly Unable to Recapture Image


  • Hey everyone,

    Getting a little desperate here. I’ve tried to recapture our normal image 3 times now. It’s the same computer, we just log into it, run Windows Updates, update any apps etc., and then capture about once a month.

    Today every time I try to capture it throws an error and fails, and on top of that it then wouldn’t start up after that one time. Had to connect a recovery disk to repair the MBR. Seems to be some problem with FOG trying to resize the disk. The only thing I did different today from normal was doing Disk Cleanup to hopefully shrink the image a little. Just restarting the computer shows everything is working just fine in Windows.

    Now, I’m getting errors like this every time I try to capture (see attached image). It seems to be choking on resizing. One time the resize test failed, another time it started resizing and then failed.

    Trying to upload a picture to this site is failing and so is attaching it here, so here’s an image link: https://ibb.co/grQCt9g

    Any help would be much appreciated, I’m on a deadline and I have no idea why this is just falling apart on me.

  • Moderator

    @gbarron Did you try what Sebastian posted in the thread you linked?

    "Please check in FOG Configuration -> FOG Settings -> General Settings -> CAPTURERESIZEPCT. From the help text:

    Default is adding 5 % and you can increase that as much as you like (up to 99 % which would not make sense)."

    See if FOG leaving more reserve space allows the capture to complete. This is not a true fix for the disk, but it may let you capture the image by telling the compacter program to not squeeze so much out of the disk before capture.


  • As for the rest, as long as it works in your organization there is no need to change because of what some dude on the internet says. From personal experience continuing to update a single golden image renders the image very messy and a bit bloated over time. But if it works for you, then there is no need to change.

    Don’t get me wrong- I know that’s not an optimal way to work long term and we’re working on other solutions. I’m not disagreeing with that, I just don’t think there’s an actual problem with the MFT specifically. I’m not an expert on imaging or NTSF by any means though, so I could be wrong. I’m not trying to be hostile, I just want to understand since the MFT seems well below normal tolerance for Windows.

  • Moderator

    @gbarron said in Suddenly Unable to Recapture Image:

    Yes, I changed the padding to 7% and it captured without issues.

    Excellent job if that solved your problem. There is no harm in leaving that setting. The only impact is slightly larger captured files on the FOG server.

    As for the rest, as long as it works in your organization there is no need to change because of what some dude on the internet says. From personal experience continuing to update a single golden image renders the image very messy and a bit bloated over time. But if it works for you, then there is no need to change.


  • @george1421 we’re hoping to go to AutoPilot soon, so if we’re going to have to find another solution that’s likely to be it. Sysprep is good for like 1000 captures on modern versions of Windows afaik, the only failures we’ve had are from some MS store issues that were easily resolved.

    Yes, I changed the padding to 7% and it captured without issues. I know you’re saying it’s not a true fix for the disk, but based upon my Windows knowledge and the research I’ve done today, there appear to be zero issues with the disk. The MFT is a perfectly normal size (rather small, even). Every screenshot of anyone, anywhere using NSFTInfo shows MFT at “100%” but that doesn’t seem to be a true figure. Try running it on a Windows machine of your own, I’d wager it will show 100%.

  • Moderator

    @gbarron Did you try what Sebastian posted in the thread you linked?

    "Please check in FOG Configuration -> FOG Settings -> General Settings -> CAPTURERESIZEPCT. From the help text:

    Default is adding 5 % and you can increase that as much as you like (up to 99 % which would not make sense)."

    See if FOG leaving more reserve space allows the capture to complete. This is not a true fix for the disk, but it may let you capture the image by telling the compacter program to not squeeze so much out of the disk before capture.

  • Moderator

    @gbarron said in Suddenly Unable to Recapture Image:

    600 MB is actually quite small for an MFT on a modern machine

    The think you have to remember is that FOG is based on linux and linux can’t mess with Windows internal working. Linux can’t expand the MFT table like windows can. Yes its only 600MB, linux can’t request new space for the table and since its at 100% there is no room to move things around. If there was 10% free space (guess) then the disk compaction could happen. Again that opinion is based on the error message thrown. With that said, I probably should look into the imaging process to see what command is being use at that point to shrink the disk.

    Unfortunately this is an issue because of the way you manage your golden image.

    Can you expand upon this? This seems to suggest that we’re doing something wrong, but if so I’ve no idea what it is.

    Every to open your golden image to updates you run the risk of sysprep not being able to complete as well add in fragmented files into your final image. Its better to start with a clean build each time with all of your updates included. One way to do this is to automate your golden image build using something like Microsoft’s MDT to build the golden image using the light touch process and to build the golden image using a VM to avoid loading any hardware specific drivers into your golden image. That’s not the only way to go about it, but its the most straightforward without a lot of extra work. The adding/deleting updates as well as applications can leave a lot of chaff behind in your image.


  • @george1421 Additionally, there seem to be other instances of this happening with FOG. I guess I’ll try this solution now, though this is still quite concerning.


  • @george1421 Furthermore, after additional research it seems this makes even less sense. The actual size of the MFT is only 600 MB and it seems from research that it always shows as “100%” when you run these kinds of commands. 600 MB is actually quite small for an MFT on a modern machine.

    The only way this makes sense is if FOG messed something up shrinking partitions, which seems to be exactly what happened. There’s well over 200 GB free on this image. Based on everything I’ve found this is an issue with FOG, no the computer’s MFT.


  • Unfortunately this is an issue because of the way you manage your golden image.

    Can you expand upon this? This seems to suggest that we’re doing something wrong, but if so I’ve no idea what it is.

    I ran that check and the MFT is indeed at 100%. The changes we make on the image are minor- just Windows updates and very infrequent updates to the handful of apps we have installed; do you have any idea what our mistake is that could be causing this? It seemed to me very much like it happened when FOG started resizing the image the first time. None of our other images have this problem.

  • Moderator

    @george1421 You can see the MFT table size and % usage with
    defrag c: /a /v from the quick searching I found it may be possible to extend the MFT table.

    Reference found on spiceworks: https://community.spiceworks.com/topic/1551829-shrink-my-mft-file

  • Moderator

    @gbarron Well looking at the error, this is a disk issue and not specifically a fog issue. Your are out of MFT (master file table) space on your disk. The MFT keeps track of all of the files on your disk. The MFT space cannot be released with the file’s deletion. Maybe some 3rd party applications could do this. Unfortunately this is an issue because of the way you manage your golden image.

    You should google shrinking or compacting your disk’s MFT

385
Online

9.1k
Users

15.7k
Topics

145.8k
Posts