HP Elitebook 840 G7 - Building over WiFi

  • Fog v1.4.4

    So we have 840 G7s - there’s no ethernet on these. They do have the option to wifi boot. Which i have working. I setup the wifi in the bios. setup the dhcp scope options and boot on wifi.

    I get the usual:
    Start PXE over IPv4

    It sees the server, gets the NBP filename etc, talks to DCHP get IP address.

    If i dont have a deployment task sitting i get the login screen to fog, then it just hangs on the 2nd boot.php…

    If i have a deployment task it hangs on the bzImage…

    Iv updated the kernals to the latest -
    bzImage Version: 5.10.50
    bzImage32 Version: 5.10.50

    Intel® Wi-Fi 6 AX201 160MHz

    What im a missing?

    Thanks Duncan

  • @george1421
    im just getting chain loading errors - we have the usbc to ethernet. that will have to do meantime.

    Cheers for the help there. much appreciated.


  • Moderator


    [8086:02f0] == Intel Wireless-AC 9462

    That network adapter is pretty new. I don’t see it specifically called out in the linux drives. I did just recompile the linux kernel using the latest stable release. The attached file is bzImageWiFi51063


    If you boot FOS Linux using the debug option the target computer will boot to a linux command prompt. From there you should type in ip a s to see if you can see the wifi adapter. Also don’t forget to set the kernel parameters from the article I linked so the target computer knows how to connect to wifi. In debug mode if you key in fog you will start the imaging process in single step mode. But this mode will give you the best chance to see any error message.

    In closing, I still think the usb to ethernet dongle approach is a better one and one that is more suited for imaging than over wifi.

  • its an Intel Wi-Fi 6 AX201 160MHz


  • Moderator

    @duncan YMMV with this solution.

    But I need to know the name and hardware ID vendor and device of this network adapter (you can see that through the windows device manager). I’ll have to see if I have the config files from 2019 for that kernel.

  • @george1421

    i just tried the bzimagewifi, but i suspect my wifi driver is not in the file.

    any chance you could update it to include it? pretty please…

  • Moderator

    @duncan Well you have 2 issues here.

    1. iPXE might not have the driver needed for wifi imaging.
    2. FOS Linux most likely doesn’t have the wifi driver for imaging.

    I did build a one off kernel and inits to support wifi imaging for a special use case. While it worked, all I can say is that it worked. It was not very fast at all, but for this specific use case it worked.

    Most people go with a USB to ethernet adapter. So if you want to go that route you will need to get an HP usb to ethernet adapter that is supported for PXE booting. Your elitebook needs to support this network adapter or it won’t show up as a bootable device. The alternate is to USB boot FOS Linux, then you can use a generic USB3 to ethernet adapter (or USB2 to ethernet adapter). Once imaging is done then you remove the usb to ethernet adapter and the computer boots normally.

    I did find my kit from back in 2019. Here is the updated wifi kernel https://drive.google.com/file/d/1OnLxsKRboYoxv3LMcupyZAMDgvkTp-qa/view?usp=sharing

    Here is the USB boot image: https://drive.google.com/file/d/1trOHt0B3X1SUYTVczYxs1TI3qQWC06Sy/view?usp=sharing

    Here is the feature request where I outlined the code in the files: https://forums.fogproject.org/topic/14006/adding-wifi-capabilities-to-fos-linux


  • @duncan ok, its almost working. MTU was lowered on Vlan and can now deploy an image.
    I now get a irq 16: nobody cared (try booting it with the “irqpoll” option)

    then the error no network interfaces found.