• Hi all,

    I’m trying to boot rescuezilla but i keep getting a blinking cursor only, what am i doeing wrong?

    thanks in advance for helping!

    this is my input:

    kernel http://${fog-ip}/fog/rescuezilla/vmlinuz
    initrd http://${fog-ip}/fog/rescuezilla/initrd.lz
    imgargs vmlinuz boot=live config noswap nolocales edd=on nomodeset ocs_live_run=“ocs-live-general” ocs_live_extra_param="" ocs_live_keymap="" ocs_live_batch=“no” ocs_daemonon=“ssh” usercrypted=Kb/VNchPYhuf6 ocs_lang="" vga=788 nosplash noprompt fetch=http://${fog-ip}/images/os/rescuezilla/filesystem.squashfs
    boot || goto failed
    goto start


  • @george1421 well no also is an awnser 😉 I really appriciate the time you spend on it for me! Thanks a lot!!

  • Moderator

    @zc0rp There are some systems that simply can’t be netbooted. This is because the developers expect certain hardware to be present. In the case of this software the developers are trying to mount the cdrom /dev/sr0 right in the init (boot up file akin to autoexec.bat was to DOS) file. I tried a number of things to try to pass all of the files to the kernel but I had no luck. I did not look into the initrd file to see what they are trying to access.

    Here are the last two kernel tries I attempted to boot. Neither one could get around the /dev/sr0 issue.

    kernel tftp://${fog-ip}/os/rescuez/vmlinuz initrd=initrd.lz boot=casper quiet splash fastboot toram fsck.mode=skip noprompt edd=on loglevel=7 fetch=http://${fog-ip}/filesystem.squashfs
    initrd tftp://${fog-ip}/os/rescuez/initrd.lz
    boot || goto menu
    
    kernel tftp://${fog-ip}/os/rescuez/vmlinuz initrd=initrd.lz boot=casper quiet splash fastboot toram fsck.mode=skip noprompt edd=on loglevel=7 
    initrd tftp://${fog-ip}/os/rescuez/initrd.lz
    imgfetch tftp://${fog-ip}/os/rescuez/filesystem.squashfs
    boot || goto menu
    

    These kernel parameters was taken from the grub configuration file in the iso image.

    sr0_err.png


  • anyone who can help me with this?


  • @george1421 honestly i copied the from another clonezilla so it sure can be wrong…

  • Moderator

    @zc0rp I guess I have to ask where did you get those kernel parameters from in your OP?

  • Moderator

    @zc0rp I can see what the problem is, its unable to mount the rootfs. On the fog server settings if you change the log level to 7 you can see the actual error. The default of 4, you just see a blank screen until it crashes. The net results are there is a missing kernel parameter. It looks like the kernel is a ubuntu generic kernel. So that may give us a key to what it needs.

  • Moderator

    @zc0rp OK let me take a look at it. I’m downloading the iso now.


  • @george1421 Thanks for the input 🙂 ive created the folder structure and placed the file but still same blinking cursor 😞

  • Moderator

    @zc0rp said in booting rescuezilla:

    http://${fog-ip}/images/os/rescuezilla/filesystem.squashfs

    Lets start with this. Since you are using http:// you need to make sure your squashfs is located under /var/www/html/images/os/rescuezilla Understand for http (web server) the base directory is /var/www/{html} not /images as for NFS.

    Just a note the web server root for RHEL based systems is /var/www/html and for debian based systems its /var/www

297
Online

9.1k
Users

15.7k
Topics

145.8k
Posts