at wits end: trying to pxe boot an ubuntu 20.04 iso to laptops connected with usb-c ethernet cables (long post with many details) LINUX experts wanted

  • X-Posted to linuxadmin

    So basically i have FOG setup to currently boot windows mdt isos.

    Ive been working the last few months via trial and error to get this working for Ubuntu.

    Ubuntu fully works properly via vmware virtual machines because built-in network adapters are no problem.

    When i go to take the public initrd and vmlinuz files from the public ISO and boot them to the usb-c adapters on the laptops. 2 things happen

    no actual interfaces are found

    because of this its unable to download the iso from the local server

    So my first thought is “oh well seems like drivers are missing”

    I then went ahead and tried to create my own initrd that includes the module (r8152) this didnt work

    I threw every module into /etc/initramfs-tools/modules and updated the initrd file. This worked The network adapter was able to get an ip address

    the real problem

    “gave up waiting for root file system” “/dev/ram0 doesnt exist”

    This is the part i cant get past. As you can see /dev/ram0 exists, i dont see why its not mounting the (initrd?) file system on the ramdisk?

    Im not the most experienced in linux, but i feel like im missing something here, i cant be the only one who is pxe booting ubuntu laptops under 20.04

    side note: I should add the mini.iso that previously existed under 18.04 is not being distributed for 20.04 which the laptop actually booted properly. I may end up using this and upgrading to 20.04 once fully installed, but i really want to do it this way.

    Another way is to just capture an image which is quite simple, i want to stay the path of “thin imaging”.

    Any help is appreciated

  • Moderator

    @Generalcanada Not exactly sure but maybe this post might help you: