Changing hostname from fog broken


  • I used to change computer name from within Fog however I noticed that it is not working anymore could by maybe due to updates of ubuntu?

    Is there a command maybe that may resync the computers to fog ?

    Fog1.5.9
    Ubuntu 20.04.2 LTS


  • @tom-elliott I tested on another computer and its working.

    on this particular pc its not working. I will try and uninstall fog client from the pc and reinstall it again and will see if it works.

    IF it still doesnt work will try to remove from fog server and re add

  • Senior Developer

    @dejv Can you please run:

    sudo -i
    mv /var/www/fog{,_back}
    ln -s /var/www/html/fog /var/www/fog
    

    This should help fix the fact that your environment sees 2 separate fog instances (one in /var/www/fog and one in /var/www/html/fog with the one in /var/www/html being the newest version.)

    The commands I give will move the /var/www/fog to /var/www/fog_back (you can simply delete this if you feel comfortable to do so.)

    Thank you,


  • @sebastian-roth said in Changing hostname from fog broken:

    http://fog

    http://fog/fog/management/ - doesnt seem to open
    http://192.168.0.58/fog/management - works

    however when I ping fog I get a reply

    I only got 1 fog server

    Command as requested:

    root@fog:~# ls -al /var/www/{,html}
    /var/www/:
    total 16
    drwxr-xr-x  4 root     root     4096 Jan 29  2019 .
    drwxr-xr-x 15 root     root     4096 Jan 29  2019 ..
    drwxr-xr-x 11 www-data www-data 4096 Jan 29  2019 fog
    drwxr-xr-x  3 root     root     4096 Mej 26 12:24 html
    
    /var/www/html:
    total 28
    drwxr-xr-x  3 root     root      4096 Mej 26 12:24 .
    drwxr-xr-x  4 root     root      4096 Jan 29  2019 ..
    drwxr-xr-x 10 www-data www-data  4096 Mej 26 12:26 fog
    -rw-r--r--  1 root     root     10918 Jan 29  2019 index.html
    -rw-r--r--  1 www-data www-data    52 Ott  8  2020 index.php
    root@fog:~#
    
  • Senior Developer

    @dejv In the fog.log we see the hostname fog in the URL - http://fog/fog/management/… Does this hostname resolve to the IP 192.168.0.58?

    Do you have just one FOG server (master node) or other FOG storage nodes as well?

    Please run ls -al /var/www/{,html} as terminal command on your FOG server and post the full output here.


  • @sebastian-roth

    I downloaded from : https://github.com/FOGProject/fogproject.
    Fog server and clients are on different subnets however have been like this for around 2years, I have a sophos utm router, without proxy server

    ------------------------------------------------------------------------------
    ----------------------------------UserTracker---------------------------------
    ------------------------------------------------------------------------------
     6/4/2021 3:24:23 PM Client-Info Client Version: 0.11.19
     6/4/2021 3:24:23 PM Client-Info Client OS:      Windows
     6/4/2021 3:24:23 PM Client-Info Server Version: 1.5.9
     6/4/2021 3:24:23 PM Middleware::Response ERROR: Unable to get subsection
     6/4/2021 3:24:23 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
     6/4/2021 3:24:23 PM Service Sleeping for 60 seconds
     6/4/2021 3:25:23 PM Middleware::Communication URL: http://fog/fog/management/index.php?sub=requestClientInfo&configure&newService&json
     6/4/2021 3:25:23 PM Middleware::Communication ERROR: Could not contact FOG server
     6/4/2021 3:25:23 PM Middleware::Communication ERROR: The remote server returned an error: (502) Bad Gateway.
     6/4/2021 3:25:23 PM Middleware::Response Success
     6/4/2021 3:25:23 PM Service ERROR: Invalid promptTime, using default
     6/4/2021 3:25:23 PM Middleware::Communication URL: http://fog/fog/management/index.php?sub=requestClientInfo&mac=74:D0:2B:35:33:6B&newService&json
     6/4/2021 3:25:23 PM Middleware::Communication ERROR: Could not contact FOG server
     6/4/2021 3:25:23 PM Middleware::Communication ERROR: The remote server returned an error: (502) Bad Gateway.
     6/4/2021 3:25:23 PM Middleware::Response Success
     6/4/2021 3:25:23 PM Middleware::Communication URL: http://fog/fog/service/getversion.php?clientver&newService&json
     6/4/2021 3:25:23 PM Service ERROR: Unable to get cycle data
     6/4/2021 3:25:23 PM Service ERROR: The remote server returned an error: (502) Bad Gateway.
     6/4/2021 3:25:23 PM Middleware::Response Success
    
    ------------------------------------------------------------------------------
    ---------------------------------ClientUpdater--------------------------------
    ------------------------------------------------------------------------------
     6/4/2021 3:25:23 PM Client-Info Client Version: 0.11.19
     6/4/2021 3:25:23 PM Client-Info Client OS:      Windows
     6/4/2021 3:25:23 PM Client-Info Server Version: 1.5.9
     6/4/2021 3:25:23 PM Middleware::Response ERROR: Unable to get subsection
     6/4/2021 3:25:23 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    ----------------------------------TaskReboot----------------------------------
    ------------------------------------------------------------------------------
     6/4/2021 3:25:23 PM Client-Info Client Version: 0.11.19
     6/4/2021 3:25:23 PM Client-Info Client OS:      Windows
     6/4/2021 3:25:23 PM Client-Info Server Version: 1.5.9
     6/4/2021 3:25:23 PM Middleware::Response ERROR: Unable to get subsection
     6/4/2021 3:25:23 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     6/4/2021 3:25:23 PM Client-Info Client Version: 0.11.19
     6/4/2021 3:25:23 PM Client-Info Client OS:      Windows
     6/4/2021 3:25:23 PM Client-Info Server Version: 1.5.9
     6/4/2021 3:25:23 PM Middleware::Response ERROR: Unable to get subsection
     6/4/2021 3:25:23 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     6/4/2021 3:25:23 PM Client-Info Client Version: 0.11.19
     6/4/2021 3:25:23 PM Client-Info Client OS:      Windows
     6/4/2021 3:25:23 PM Client-Info Server Version: 1.5.9
     6/4/2021 3:25:23 PM Middleware::Response ERROR: Unable to get subsection
     6/4/2021 3:25:23 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------PrinterManager--------------------------------
    ------------------------------------------------------------------------------
     6/4/2021 3:25:23 PM Client-Info Client Version: 0.11.19
     6/4/2021 3:25:23 PM Client-Info Client OS:      Windows
     6/4/2021 3:25:23 PM Client-Info Server Version: 1.5.9
     6/4/2021 3:25:23 PM Middleware::Response ERROR: Unable to get subsection
     6/4/2021 3:25:23 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------PowerManagement-------------------------------
    ------------------------------------------------------------------------------
     6/4/2021 3:25:23 PM Client-Info Client Version: 0.11.19
     6/4/2021 3:25:23 PM Client-Info Client OS:      Windows
     6/4/2021 3:25:23 PM Client-Info Server Version: 1.5.9
     6/4/2021 3:25:23 PM Middleware::Response ERROR: Unable to get subsection
     6/4/2021 3:25:23 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    ----------------------------------UserTracker---------------------------------
    ------------------------------------------------------------------------------
     6/4/2021 3:25:23 PM Client-Info Client Version: 0.11.19
     6/4/2021 3:25:23 PM Client-Info Client OS:      Windows
     6/4/2021 3:25:23 PM Client-Info Server Version: 1.5.9
     6/4/2021 3:25:23 PM Middleware::Response ERROR: Unable to get subsection
     6/4/2021 3:25:23 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
     6/4/2021 3:25:23 PM Service Sleeping for 60 seconds
    
  • Senior Developer

    @dejv said in Changing hostname from fog broken:

    I am getting the below number when accessesing the following link: http://192.168.0.58/fog/service/getversion.php?clientver&newService&json
    0.12.0

    While this sounds like it does work as it should the version number is different to what we saw in the fog-client log. When you re-installed the FOG server did you use the latest dev-branch version?

    Possibly you are hitting a different error now. Please post the latest fog-client fog.log here so we see if it’s still the same problem or a different one.

    Are your FOG server and the client machine in the same subnet? No router, gateway or maybe proxy server in between? I ask because we had someone with very strange fog-client issues that were caused by a proxy server. The fog-client seems to be using the global Windows proxy settings.


  • @sebastian-roth

    Thanks 🙂

    I am getting the below number when accessesing the following link: http://192.168.0.58/fog/service/getversion.php?clientver&newService&json

    0.12.0

  • Senior Developer

    @dejv Found some time to look into this and I think I was on the wrong track. I looked through the code and I don’t think that part can be triggered by a registered client. It does not match what we see in the fog-client log file. As well the logs posted last (that include the register.php call) are from May 20. But the fog-client log posted earlier is from May 21. Just doesn’t match.

    So let’s try to tackle this from a different angle. What happens if you open the URL http://fog/fog/service/getversion.php?clientver&newService&json in your browser on a normal work PC?

    I ask because in the fog-client log we see that URL request triggered a HTTP 502 Bad Gateway error and I am wondering if you see that when opening the URL manually as well.


  • @sebastian-roth

    yes client was registered already

  • Senior Developer

    @dejv said in Changing hostname from fog broken:

    AH01071: Got error ‘PHP message: PHP Fatal error: Uncaught Error: Call to a member function isValid() on null in /var/www/html/fog/lib/fog/host.class.php:305\nStack trace:\n#0 /var/www/html/fog/lib/fog/fogbase.class.php(1832): Host->save()\n#1 /var/www/html/fog/lib/client/fogclient.class.php(179): FOGBase->sendData()\n#2 /var/www/html/fog/service/register.php(32): FOGClient->__construct()\n#3 {main}\n thrown in /var/www/html/fog/lib/fog/host.class.php on line 305’

    That might be a first hint on what might be causing the problem. But on the other hand I am wondering why it’s calling register.php. Is this client registered in FOG already or not?


  • Tried redownloading and installing fog as its pretty easy and straightforward however still same issue.

    [Tue May 25 00:00:04.404259 2021] [mpm_prefork:notice] [pid 801] AH00163: Apache/2.4.41 (Ubuntu) OpenSSL/1.1.1f configured -- resuming normal operations
    [Tue May 25 00:00:04.404282 2021] [core:notice] [pid 801] AH00094: Command line: '/usr/sbin/apache2'
    [Wed May 26 00:00:06.516283 2021] [mpm_prefork:notice] [pid 801] AH00171: Graceful restart requested, doing restart
    AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
    
    [Mon May 24 00:00:07.495210 2021] [mpm_prefork:notice] [pid 801] AH00163: Apache/2.4.41 (Ubuntu) OpenSSL/1.1.1f configured -- resuming normal operations
    [Mon May 24 00:00:07.495231 2021] [core:notice] [pid 801] AH00094: Command line: '/usr/sbin/apache2'
    [Tue May 25 00:00:03.853271 2021] [mpm_prefork:notice] [pid 801] AH00171: Graceful restart requested, doing restart
    AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
    
    [Thu May 20 00:00:07.690477 2021] [mpm_prefork:notice] [pid 801] AH00163: Apache/2.4.41 (Ubuntu) OpenSSL/1.1.1f configured -- resuming normal operations
    [Thu May 20 00:00:07.690497 2021] [core:notice] [pid 801] AH00094: Command line: '/usr/sbin/apache2'
    [Thu May 20 14:46:05.550377 2021] [proxy:error] [pid 901639] (111)Connection refused: AH00957: FCGI: attempt to connect to 127.0.0.1:9000 (*) failed
    [Thu May 20 14:46:05.556623 2021] [proxy_fcgi:error] [pid 901639] [client 192.168.0.254:49042] AH01079: failed to make connection to backend: 127.0.0.1
    [Thu May 20 14:46:05.575487 2021] [proxy:error] [pid 901622] (111)Connection refused: AH00957: FCGI: attempt to connect to 127.0.0.1:9000 (*) failed
    [Thu May 20 14:46:05.575640 2021] [proxy_fcgi:error] [pid 901622] [client 192.168.0.254:49043] AH01079: failed to make connection to backend: 127.0.0.1
    [Thu May 20 14:46:07.616286 2021] [proxy:error] [pid 901620] (111)Connection refused: AH00957: FCGI: attempt to connect to 127.0.0.1:9000 (*) failed
    [Thu May 20 14:46:07.616353 2021] [proxy_fcgi:error] [pid 901620] [client 192.168.0.254:49065] AH01079: failed to make connection to backend: 127.0.0.1
    [Thu May 20 14:46:08.280219 2021] [mpm_prefork:notice] [pid 801] AH00169: caught SIGTERM, shutting down
    [Thu May 20 14:46:42.725606 2021] [mpm_prefork:notice] [pid 801] AH00163: Apache/2.4.41 (Ubuntu) OpenSSL/1.1.1f configured -- resuming normal operations
    [Thu May 20 14:46:42.760133 2021] [core:notice] [pid 801] AH00094: Command line: '/usr/sbin/apache2'
    [Thu May 20 15:49:43.614999 2021] [proxy_fcgi:error] [pid 1133] [client 192.168.0.93:49784] AH01071: Got error 'PHP message: PHP Fatal error:  Uncaught Error: Call to a member function isValid() on null in /var/www/html/fog/lib/fog/host.class.php:305\nStack trace:\n#0 /var/www/html/fog/lib/fog/fogbase.class.php(1832): Host->save()\n#1 /var/www/html/fog/lib/client/fogclient.class.php(179): FOGBase->sendData()\n#2 /var/www/html/fog/service/register.php(32): FOGClient->__construct()\n#3 {main}\n  thrown in /var/www/html/fog/lib/fog/host.class.php on line 305'
    [Thu May 20 15:56:04.356205 2021] [proxy_fcgi:error] [pid 1896] [client 192.168.0.95:49766] AH01071: Got error 'PHP message: PHP Fatal error:  Uncaught Error: Call to a member function isValid() on null in /var/www/html/fog/lib/fog/host.class.php:305\nStack trace:\n#0 /var/www/html/fog/lib/fog/fogbase.class.php(1832): Host->save()\n#1 /var/www/html/fog/lib/client/fogclient.class.php(179): FOGBase->sendData()\n#2 /var/www/html/fog/service/register.php(32): FOGClient->__construct()\n#3 {main}\n  thrown in /var/www/html/fog/lib/fog/host.class.php on line 305'
    [Fri May 21 00:00:10.688815 2021] [mpm_prefork:notice] [pid 801] AH00171: Graceful restart requested, doing restart
    AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
    
    
    

    I found some other files that were compressed please find above.

    The php7.4 log is all the same as posted before

  • Senior Developer

    @dejv said in Changing hostname from fog broken:

    If I redownload Fog and reinstall it will it fix the issue?

    Well, without further information we don’t know what is causing the problem. Therefore I can’t tell you if re-installing will help either.


  • @sebastian-roth If I redownload Fog and reinstall it will it fix the issue? (hopefully it will keep all settings)

  • Senior Developer

    @dejv The Apache log seems to be very recent (“May 24”). Depending on log rotation the errors might be in an older log file. See what you have in /var/log/apache/… Or make sure the fog-client is still trying to access the server. In that case we should still see more recent errors in the logs.

    The PHP-FPM log looks very old on the other hand. No idea why the log ends in October 2020?!


  • Below please find the logs.

    [Mon May 24 00:00:07.495210 2021] [mpm_prefork:notice] [pid 801] AH00163: Apache/2.4.41 (Ubuntu) OpenSSL/1.1.1f configured -- resuming normal operations
    [Mon May 24 00:00:07.495231 2021] [core:notice] [pid 801] AH00094: Command line: '/usr/sbin/apache2'
    
    
    [11-Oct-2020 00:00:09] NOTICE: error log file re-opened
    [11-Oct-2020 09:49:33] NOTICE: [pool www] child 220447 exited with code 0 after 62752.185039 seconds from start
    [11-Oct-2020 09:49:33] NOTICE: [pool www] child 294616 started
    [11-Oct-2020 11:49:36] NOTICE: [pool www] child 227216 exited with code 0 after 64180.202051 seconds from start
    [11-Oct-2020 11:49:36] NOTICE: [pool www] child 303013 started
    [11-Oct-2020 11:50:33] NOTICE: [pool www] child 227237 exited with code 0 after 64208.569037 seconds from start
    [11-Oct-2020 11:50:33] NOTICE: [pool www] child 303067 started
    [11-Oct-2020 11:51:23] NOTICE: [pool www] child 227308 exited with code 0 after 64179.441704 seconds from start
    [11-Oct-2020 11:51:23] NOTICE: [pool www] child 303113 started
    [11-Oct-2020 11:51:29] NOTICE: [pool www] child 227309 exited with code 0 after 64185.604016 seconds from start
    [11-Oct-2020 11:51:29] NOTICE: [pool www] child 303114 started
    [11-Oct-2020 11:51:30] NOTICE: [pool www] child 227310 exited with code 0 after 64185.954870 seconds from start
    [11-Oct-2020 11:51:30] NOTICE: [pool www] child 303115 started
    [11-Oct-2020 11:51:33] NOTICE: [pool www] child 227311 exited with code 0 after 64188.782480 seconds from start
    [11-Oct-2020 11:51:33] NOTICE: [pool www] child 303124 started
    [11-Oct-2020 11:52:05] NOTICE: [pool www] child 227328 exited with code 0 after 64207.607142 seconds from start
    [11-Oct-2020 11:52:05] NOTICE: [pool www] child 303153 started
    [11-Oct-2020 11:52:07] NOTICE: [pool www] child 227329 exited with code 0 after 64207.198656 seconds from start
    [11-Oct-2020 11:52:07] NOTICE: [pool www] child 303154 started
    [11-Oct-2020 11:52:07] NOTICE: [pool www] child 227330 exited with code 0 after 64203.649467 seconds from start
    [11-Oct-2020 11:52:07] NOTICE: [pool www] child 303155 started
    [12-Oct-2020 04:39:29] NOTICE: [pool www] child 294616 exited with code 0 after 67796.633867 seconds from start
    [12-Oct-2020 04:39:29] NOTICE: [pool www] child 373882 started
    [12-Oct-2020 06:29:28] NOTICE: [pool www] child 303013 exited with code 0 after 67192.174632 seconds from start
    [12-Oct-2020 06:29:28] NOTICE: [pool www] child 381455 started
    [12-Oct-2020 06:30:21] NOTICE: [pool www] child 303067 exited with code 0 after 67188.452916 seconds from start
    [12-Oct-2020 06:30:21] NOTICE: [pool www] child 381500 started
    [12-Oct-2020 06:30:42] NOTICE: [pool www] child 303113 exited with code 0 after 67159.281246 seconds from start
    [12-Oct-2020 06:30:42] NOTICE: [pool www] child 381522 started
    [12-Oct-2020 06:30:52] NOTICE: [pool www] child 303114 exited with code 0 after 67162.234980 seconds from start
    [12-Oct-2020 06:30:52] NOTICE: [pool www] child 381531 started
    [12-Oct-2020 06:30:58] NOTICE: [pool www] child 303115 exited with code 0 after 67168.493160 seconds from start
    [12-Oct-2020 06:30:58] NOTICE: [pool www] child 381540 started
    [12-Oct-2020 06:30:59] NOTICE: [pool www] child 303124 exited with code 0 after 67165.743174 seconds from start
    [12-Oct-2020 06:30:59] NOTICE: [pool www] child 381541 started
    [12-Oct-2020 06:31:27] NOTICE: [pool www] child 303153 exited with code 0 after 67161.361412 seconds from start
    [12-Oct-2020 06:31:27] NOTICE: [pool www] child 381566 started
    [12-Oct-2020 06:31:28] NOTICE: [pool www] child 303155 exited with code 0 after 67160.922435 seconds from start
    [12-Oct-2020 06:31:28] NOTICE: [pool www] child 381568 started
    [12-Oct-2020 06:31:30] NOTICE: [pool www] child 303154 exited with code 0 after 67162.579554 seconds from start
    [12-Oct-2020 06:31:30] NOTICE: [pool www] child 381569 started
    [12-Oct-2020 11:05:20] NOTICE: [pool www] child 373882 exited with code 0 after 23150.036460 seconds from start
    [12-Oct-2020 11:05:20] NOTICE: [pool www] child 401119 started
    [12-Oct-2020 11:25:44] NOTICE: [pool www] child 381455 exited with code 0 after 17775.586921 seconds from start
    [12-Oct-2020 11:25:44] NOTICE: [pool www] child 402785 started
    [12-Oct-2020 11:25:49] NOTICE: [pool www] child 381540 exited with code 0 after 17690.623225 seconds from start
    [12-Oct-2020 11:25:49] NOTICE: [pool www] child 402794 started
    [12-Oct-2020 11:25:50] NOTICE: [pool www] child 381500 exited with code 0 after 17728.170402 seconds from start
    [12-Oct-2020 11:25:50] NOTICE: [pool www] child 402795 started
    [12-Oct-2020 11:25:51] NOTICE: [pool www] child 381531 exited with code 0 after 17699.001427 seconds from start
    [12-Oct-2020 11:25:51] NOTICE: [pool www] child 402796 started
    [12-Oct-2020 11:25:58] NOTICE: [pool www] child 381522 exited with code 0 after 17715.320488 seconds from start
    [12-Oct-2020 11:25:58] NOTICE: [pool www] child 402805 started
    
    
  • Senior Developer

    @dejv said in Changing hostname from fog broken:

    The remote server returned an error: (502) Bad Gateway.

    Looks like the fog-client can’t get a proper response from the FOG server. Please check the Apache and PHP-FPM log (see my signature).


  • @sebastian-roth

    Sorry below please find the log

    ------------------------------------------------------------------------------
    ---------------------------------ClientUpdater--------------------------------
    ------------------------------------------------------------------------------
     5/21/2021 8:56:09 AM Client-Info Client Version: 0.11.19
     5/21/2021 8:56:09 AM Client-Info Client OS:      Windows
     5/21/2021 8:56:09 AM Client-Info Server Version: 1.5.9
     5/21/2021 8:56:09 AM Middleware::Response ERROR: Unable to get subsection
     5/21/2021 8:56:09 AM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    ----------------------------------TaskReboot----------------------------------
    ------------------------------------------------------------------------------
     5/21/2021 8:56:09 AM Client-Info Client Version: 0.11.19
     5/21/2021 8:56:09 AM Client-Info Client OS:      Windows
     5/21/2021 8:56:09 AM Client-Info Server Version: 1.5.9
     5/21/2021 8:56:09 AM Middleware::Response ERROR: Unable to get subsection
     5/21/2021 8:56:09 AM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     5/21/2021 8:56:09 AM Client-Info Client Version: 0.11.19
     5/21/2021 8:56:09 AM Client-Info Client OS:      Windows
     5/21/2021 8:56:09 AM Client-Info Server Version: 1.5.9
     5/21/2021 8:56:09 AM Middleware::Response ERROR: Unable to get subsection
     5/21/2021 8:56:09 AM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     5/21/2021 8:56:09 AM Client-Info Client Version: 0.11.19
     5/21/2021 8:56:09 AM Client-Info Client OS:      Windows
     5/21/2021 8:56:09 AM Client-Info Server Version: 1.5.9
     5/21/2021 8:56:09 AM Middleware::Response ERROR: Unable to get subsection
     5/21/2021 8:56:09 AM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------PrinterManager--------------------------------
    ------------------------------------------------------------------------------
     5/21/2021 8:56:09 AM Client-Info Client Version: 0.11.19
     5/21/2021 8:56:09 AM Client-Info Client OS:      Windows
     5/21/2021 8:56:09 AM Client-Info Server Version: 1.5.9
     5/21/2021 8:56:09 AM Middleware::Response ERROR: Unable to get subsection
     5/21/2021 8:56:09 AM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------PowerManagement-------------------------------
    ------------------------------------------------------------------------------
     5/21/2021 8:56:09 AM Client-Info Client Version: 0.11.19
     5/21/2021 8:56:09 AM Client-Info Client OS:      Windows
     5/21/2021 8:56:09 AM Client-Info Server Version: 1.5.9
     5/21/2021 8:56:09 AM Middleware::Response ERROR: Unable to get subsection
     5/21/2021 8:56:09 AM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    ----------------------------------UserTracker---------------------------------
    ------------------------------------------------------------------------------
     5/21/2021 8:56:09 AM Client-Info Client Version: 0.11.19
     5/21/2021 8:56:09 AM Client-Info Client OS:      Windows
     5/21/2021 8:56:09 AM Client-Info Server Version: 1.5.9
     5/21/2021 8:56:09 AM Middleware::Response ERROR: Unable to get subsection
     5/21/2021 8:56:09 AM Middleware::Response ERROR: Object reference not set to an instance of an object.
     5/21/2021 8:56:09 AM Service Sleeping for 60 seconds
     5/21/2021 8:57:09 AM Middleware::Communication URL: http://fog/fog/management/index.php?sub=requestClientInfo&configure&newService&json
     5/21/2021 8:57:09 AM Middleware::Communication ERROR: Could not contact FOG server
     5/21/2021 8:57:09 AM Middleware::Communication ERROR: The remote server returned an error: (502) Bad Gateway.
     5/21/2021 8:57:09 AM Middleware::Response Success
     5/21/2021 8:57:09 AM Service ERROR: Invalid promptTime, using default
     5/21/2021 8:57:09 AM Middleware::Communication URL: http://fog/fog/management/index.php?sub=requestClientInfo&mac=74:D0:2B:35:33:6B&newService&json
     5/21/2021 8:57:09 AM Middleware::Communication ERROR: Could not contact FOG server
     5/21/2021 8:57:09 AM Middleware::Communication ERROR: The remote server returned an error: (502) Bad Gateway.
     5/21/2021 8:57:09 AM Middleware::Response Success
     5/21/2021 8:57:09 AM Middleware::Communication URL: http://fog/fog/service/getversion.php?clientver&newService&json
     5/21/2021 8:57:09 AM Service ERROR: Unable to get cycle data
     5/21/2021 8:57:09 AM Service ERROR: The remote server returned an error: (502) Bad Gateway.
     5/21/2021 8:57:09 AM Middleware::Response Success
    
    ------------------------------------------------------------------------------
    ---------------------------------ClientUpdater--------------------------------
    ------------------------------------------------------------------------------
     5/21/2021 8:57:09 AM Client-Info Client Version: 0.11.19
     5/21/2021 8:57:09 AM Client-Info Client OS:      Windows
     5/21/2021 8:57:09 AM Client-Info Server Version: 1.5.9
     5/21/2021 8:57:09 AM Middleware::Response ERROR: Unable to get subsection
     5/21/2021 8:57:09 AM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    ----------------------------------TaskReboot----------------------------------
    ------------------------------------------------------------------------------
     5/21/2021 8:57:10 AM Client-Info Client Version: 0.11.19
     5/21/2021 8:57:10 AM Client-Info Client OS:      Windows
     5/21/2021 8:57:10 AM Client-Info Server Version: 1.5.9
     5/21/2021 8:57:10 AM Middleware::Response ERROR: Unable to get subsection
     5/21/2021 8:57:10 AM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     5/21/2021 8:57:10 AM Client-Info Client Version: 0.11.19
     5/21/2021 8:57:10 AM Client-Info Client OS:      Windows
     5/21/2021 8:57:10 AM Client-Info Server Version: 1.5.9
     5/21/2021 8:57:10 AM Middleware::Response ERROR: Unable to get subsection
     5/21/2021 8:57:10 AM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     5/21/2021 8:57:10 AM Client-Info Client Version: 0.11.19
     5/21/2021 8:57:10 AM Client-Info Client OS:      Windows
     5/21/2021 8:57:10 AM Client-Info Server Version: 1.5.9
     5/21/2021 8:57:10 AM Middleware::Response ERROR: Unable to get subsection
     5/21/2021 8:57:10 AM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------PrinterManager--------------------------------
    ------------------------------------------------------------------------------
     5/21/2021 8:57:10 AM Client-Info Client Version: 0.11.19
     5/21/2021 8:57:10 AM Client-Info Client OS:      Windows
     5/21/2021 8:57:10 AM Client-Info Server Version: 1.5.9
     5/21/2021 8:57:10 AM Middleware::Response ERROR: Unable to get subsection
     5/21/2021 8:57:10 AM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------PowerManagement-------------------------------
    ------------------------------------------------------------------------------
     5/21/2021 8:57:10 AM Client-Info Client Version: 0.11.19
     5/21/2021 8:57:10 AM Client-Info Client OS:      Windows
     5/21/2021 8:57:10 AM Client-Info Server Version: 1.5.9
     5/21/2021 8:57:10 AM Middleware::Response ERROR: Unable to get subsection
     5/21/2021 8:57:10 AM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    ----------------------------------UserTracker---------------------------------
    ------------------------------------------------------------------------------
     5/21/2021 8:57:10 AM Client-Info Client Version: 0.11.19
     5/21/2021 8:57:10 AM Client-Info Client OS:      Windows
     5/21/2021 8:57:10 AM Client-Info Server Version: 1.5.9
     5/21/2021 8:57:10 AM Middleware::Response ERROR: Unable to get subsection
     5/21/2021 8:57:10 AM Middleware::Response ERROR: Object reference not set to an instance of an object.
     5/21/2021 8:57:10 AM Service Sleeping for 60 seconds
    
    
  • Senior Developer

    @dejv Please post the full fog-client log here in the forums. You find that in C:\fog.log on the client machine.

287
Online

8.6k
Users

15.3k
Topics

143.4k
Posts