Windows 10 and FOG: product key problem 20H2


  • Hello,
    I have fog version 1.5.9, updated kernel to the latest available version, centOS.
    I noticed a problem with the Windows 10 license key. After preparing the image from devices (Lenovo E15 Gen 2, Vostro 3681, Optiplex 3080) and uploading the images to other devices, the license key is copied from the first device from which I recorded the image. Until now, Windows activated with the key assigned to a given device, automatically detecting the key in the BIOS.
    I don’t know if it’s the fault of the FOG itself or the Windows update. Has anyone reported any problems with the latest build of Windows and uploading images from FOG?
    I will add that computers / laptops are brand new. They have a pre-installed system and new license keys provided by laptop / computer manufacturers.
    I have tried various combinations with Slmgr but to no avail. Sysprep does not solve the problem either.
    Image: Windows 10 Pro, x64, 20H2 latest build.


  • @sebastian-roth yes, the command only calls the product key. I activate it via the “change key” option in the settings. Enters the called key.

    as i wrote “After preparing the image from devices (Lenovo E15 Gen 2, Vostro 3681, Optiplex 3080) and uploading the images to other devices, the license key is copied from the first device from which I recorded the image”.

  • Senior Developer

    @poteznybonio This command does not look like it can set and activate a key I find.


  • @sebastian-roth wmic path softwarelicensingservice get OA3xOriginalProductKey


  • @poteznybonio

    OEM must enter the product key Windows 10 Pro, and activating before shipping it to you (if you buy PC with license Windows 10 Pro, of course).

    in you Golden Image OEM use this product key: VK7JG-NPHTM-C97JM-9MPGT-3V66T

    this default key set Windows Operation System, OEM_DM channel

    if you environment use KMS server, use in Golden Image KMS this product key: W269N-WFGWX-YVC9B-4J6C9-T83GX

  • Senior Developer

    @poteznybonio said in Windows 10 and FOG: product key problem 20H2:

    I can activate a key using a command to call the key and enter it.

    Which command exactly did you use? Another user in the forums posted that he was not able to manually enter the key and activate in 20H2.


  • @sebastian-roth
    If FOG calls the commands from slmgr.vbs, maybe the latest build changes something in the way of activating the keys? Can you verify it somehow?
    I can activate a key using a command to call the key and enter it. The point is that windows “stopped doing it by itself” after uploading the image.
    December build works fine.
    I could enter manually the keys assigned to the device, but there are many of them so it is very difficult.

    The question is: on what level is the problem? fog or windows? 🙂

    Regards.

  • Senior Developer

    @poteznybonio Do you use the fog-client software at all? This is the only point where FOG will “try to help you” - set a product key and activate if and only if a product key is set for this particular host in the DB and the fog-client is enabled. In the fog-client code we simply use the slmgr.vbs calls that one would use manually too. So I don’t think there is too much we can do wrong.

    If you don’t use fog-client, then FOG is not be involved.

    I have tried various combinations with Slmgr but to no avail.

    Do I get this right? You can’t even set a product key and activate manually using slmgr.vbs?

281
Online

8.2k
Users

15.1k
Topics

141.9k
Posts