Wake on lan difference between basic tasks and power management ?


  • Hi,
    I have problem with Wake on lan in Power Management.
    If i launch Wake on lan from Host or Group / Basic tasks / advanced / wake-up it’s work fine.
    But if i use on Power Management to schedule, it’s not work.
    Power Management work for Reboot.
    Any ideas ?

    Regards


  • @florent
    Sorry i found the problem, i think it’s bad value on the mysql table.
    I go to the powerManagement table and see line like this with “-” :
    0 8 - * wol 0
    I have deleted this line and restart FOGScheduler, after it’s ok

    [03-04-21 5:08:23 pm]  * Found a wake on lan task that should run.
    [03-04-21 5:08:23 pm]  | Task sent to XXX
    

    It’s resolved for me


  • @sebastian-roth My log is weird :

    [03-04-21 1:54:23 pm] Interface Ready with IP Address: 127.0.0.1
    [03-04-21 1:54:23 pm] Interface Ready with IP Address: 127.0.1.1
    [03-04-21 1:54:23 pm] Interface Ready with IP Address: xx.xx.xx.xx
    [03-04-21 1:54:23 pm] Interface Ready with IP Address: fog.mydomain.fr
    [03-04-21 1:54:23 pm]  * Starting TaskScheduler Service
    [03-04-21 1:54:23 pm]  * Checking for new items every 60 seconds
    [03-04-21 1:54:23 pm]  * Starting service loop
    [03-04-21 1:54:23 pm]  * Sending 1 wake on lan request.
    [03-04-21 1:54:23 pm]  * 1 total mac attempting to wake up.
    [03-04-21 1:54:23 pm]  * 601 tasks found.
    

    and the last line (line 562) is this, nothing happen at the time i have schedule wake on lan :

    [03-04-21 1:54:24 pm]  * Task run time: Tue, 09 Mar 2021 07:30:00 +0100
    

    This morning i have try to restart FOGScheduler service but change nothing.

  • Senior Developer

    @Florent For me it seems to work with power management. Scheduled a task and checked with tcpdump it actually sends the magic packets (WOL).

    Can you please check /var/log/fog/fogscheduler.log to see what it says. In my test case I see this:

    [03-03-21 4:35:27 pm]  * Sending 1 wake on lan request.
    [03-03-21 4:35:27 pm]  * 1 total mac attempting to wake up.
    [03-03-21 4:35:27 pm]  * 1 task found.
    [03-03-21 4:35:27 pm]  * Task run time: Wed, 03 Mar 2021 16:35:00 +0000
    [03-03-21 4:35:27 pm]  * Found a wake on lan task that should run.
    [03-03-21 4:35:27 pm]  | Task sent to testhost
    

  • Hi @sebastian-roth
    FOG 1.5.9 on Debian 10

  • Senior Developer

    @Florent Which version of FOG do you use?

    @testers Anyone able to confirm this is an issue?

292
Online

8.4k
Users

15.2k
Topics

142.6k
Posts