No configuration methods succeeded


  • FOG Server 1.5.9 on Ubuntu 20.04 VM
    Kernel : 5.10.12

    Hello,
    I have a fog server that works perfectly except with a single pos model I followed several posts on this forum, I updated the kernel to the latest version but still the same problem I still have the error : No configuration methods succeeded
    can you help please?

    111111.jpg

  • Senior Developer

    @wbilel There is an interesting hint in the new topic @jtappen opened: https://forums.fogproject.org/post/141287

    I’m sure I’ve seen your original error message too about no configuration methods. I can’t remember if this was solved via BIOS update - or if it was more switch-port related.


  • @sebastian-roth Hello, I tried several settings ipxe.kpxe and ipxe.pxe … on legacy mode but still the same problem here is the hardware id of the network card thank you

    22222.jpg

  • Senior Developer

    @wbilel I would suggest using different iPXE binaries. Looks like you boot in legacy BIOS Mode (not UEFI), right? Then try setting ipxe.kpxe or ipxe.pxe in your DHCP config.

    @jtappen Please open your own topic and post a picture of your screen. Also we need to know the FOG version you use.


  • @george1421
    I do not want to hijack this post, however I have the same issue and what seems to be similar NIC card (Mine is also Realtek PCIe GBE Family)

    If it helps others… here is what this laptop model NIC info shows…

    nic.jpg

    If anyone can assist those of us that have this issue it would be much appreciated!

    Thanks

  • Moderator

    @wbilel Your issue is within iPXE and not the FOS Linux kernel (updating the kernel will not fix this issue). For some reason iPXE can not configure the network interface.

    From a working computer of the same exact model, will you tell us what the hardware ID if this network adapter is? I need the vendor and device hardware numbers.

    If we can’t get iPXE to init the network we can try usb booting into FOS Linux. But lets start with getting the hardware ID of this network adapter.

312
Online

8.7k
Users

15.4k
Topics

144.1k
Posts