• Hello everybody !

    I have some problems with Fog print.
    When i turn on my PCs eveything is good. All users can see printers assigned on FOG.

    Problem : I’m working for a school and many users can log in on a same PC during a day. When the first user logout the session and a second user log in the same PC, sometimes printers dissapear randomly.

    Same problem if i use FOG print management or only assigned printer on web interface.
    Same problem on all PCs Windows 10 and Seven

    Fog.log on client indicate everything is good : “printer are already configured” but they don’t appear.

    to resolv this problem :
    I have to restart in “services.msc” spooler print or fog client service or my computer.

    Any ideas ??

    Fog is on Ubuntu server
    And client on Windows 10

    Sorry for my English
    Have a good day, waiting to read you

  • Senior Developer

    @cedre2 We didn’t mean to ignore you question. Though printers is not an easy topic. The fog-client was developed by someone not being in the team anymore and while I am trying to work on this as good as I can I don’t have the equipment to even test printer stuff.

    Looking through the code I can see that currently the fog-client would only restart the printer spooler if a new printer would be added. From other situations I know that Windows 10 can be a real pain with updating printer information and you need to restart the spooler more often than not. Though I don’t think it’s a good idea to just do a restart of the spooler every time the fog-client looks at the printers.

    Not really sure what to do about this.

395
Online

8.7k
Users

15.4k
Topics

144.0k
Posts