Dell Optiplex 5080- Network Interface not found

  • Moderator

    Hey guys,

    Hoping you could help. I have new Dell Optiplex 5080 desktops which I’m trying to create an image for. It gets to the menu but then says “No Network Interfaces found, your kernel is most probably missing the correct driver”

    I’ve updated the kernel to 5.6.18 but still cannot get it to go past that error.

    Any pointers?



  • Moderator


    So I ended up building a new FOG server and this time everything worked as it should. Not sure what was causing the old server to act that way, but even after manually downloading and saving the new files, it still showed the old version.

    Anyhow, thanks for your guidance with this.


  • Moderator

    @roc1479-0 That is what I figured. If the update didn’t go as planned then you would not have 5.6.18.

    You can manually download the kernels from here save as bzImage

    and save as bzImage32 (note case is important)

    Move those files to /var/www/html/fog/service/ipxe on the fog server.

    You can confirm that you have the right files by running this command file /var/www/html/fog/service/ipxe/bzImage If it returns 5.6.18 in the resultant string then you have the right kernel in place.

    One last tidbit if your fog server has internet access you can use the wget command like this wget and it will download the kernel to the current directory. Then just move it to the right location.

  • Moderator


    Attached is the pic. For whatever reason, the kernel is not the correct one, eventho the update said it worked.

  • Moderator

    This post is deleted!
  • Moderator

    @roc1479-0 said in Dell Optiplex 5080- Network Interface not found:


    Was first supported in linux kernel 5.5, so 5.6.18 should support that hardware.

    What I want you to do is stop any currently running capture/deploy task.

    Then schedule a new task but before you hit the schedule task button, tick the debug checkbox then schedule the task.

    PXE boot the target computer. After a few screens of text that you need to clear with the enter key you will be dropped to a linux command prompt. At that command prompt key in the following commands. Snap a clear picture of the results with a mobile phone and post it here.
    uname -r
    ip a s

    The uname command should return 5.6.18 if you are running the updated kernel. If its any value less than 5.6.18 then you don’t have the proper kernel downloaded (we can address that later).

    The ip command should return the found network adapters. It should find the loopback adapter as well as the physical network adapter. If it doesn’t find the physical network adapter then run this command.
    lspci -nn | grep -i net and post the results.

  • Moderator

    Hi Sebastian,

    I did see the post and followed those instructions, however, mine just does not find a network.

    Intel Ethernet l219-LM

  • Moderator

    @Roc1479-0 Here we have a post about the 5080’s in the forum: - saying that a kernel update did help with the network driver.

    Can you get us the PCI IDs from the Windows device management?