Update Kernels - GUI says successful, but its not


  • I’m trying to update the kernels on my fog server and the GUI says they are successful but on the Fog Configuration > Home > Kernel Versions screen the versions installed still show 4.19.143.

    I would like to get to 5.6.18 as the current kernels does not work with our latest computers purchased.

    Fog Server Version: 1.5.9.49 (Newly Upgraded from 1.5.6)
    OS: Ubuntu 16.04 LTS (Newly Upgraded from 14.04 LTS)

    Am I missing something?

    Thanks for any help!

  • Senior Developer

    @JDnoble18 As George said, permissions look fine. Now that I think of it again I can imagine you ran into an issue where the installer would mess up with a link to the web root directory. Please run the following commands and post output here:

    grep FOG_VERSION /var/www/html/fog/lib/fog/system.class.php
    grep FOG_VERSION /var/www/fog/lib/fog/system.class.php
    ls -al /var/www
    

    I just tested kernel update on FOG 1.5.9.49 and it works as expected. So it does not seem to be a general issue.

  • Moderator

    @jdnoble18 said in Update Kernels - GUI says successful, but its not:

    and I’ve also tried it directly from Firefox on the Ubuntu machine that fog runs on and still get the same result.

    Understand this download action would be from the FOG server reaching out to the internet and downloading the file directly from the FOG Mother ship. The browser being used does not matter once you hit the download button its all FOG server and mother ship talking. I think the manual method is the quickest solution for you.


  • @george1421 I’ve tried this update from a computer across a VPN, and I’ve also tried it directly from Firefox on the Ubuntu machine that fog runs on and still get the same result.

    As for getting a specific error, I don’t get any error. It says “Transfer Succeeded” in green and below that “Your new FOG Kernel has been installed!”

  • Moderator

    @jdnoble18 Interesting you have the right permissions on these files.

    Is your fog server behind a proxy server?

    Are you getting a specific error or its says its working but doesn’t?

    The quickest way to as solution is probably the manual way I mentioned, but that doesn’t really solve the issue.


  • @sebastian-roth

    it@fogserver:~$ sudo ls -al /var/www/html/fog/service/ipxe/
    total 58084
    drwxr-xr-x 2 fogproject www-data     4096 Dec  2 18:01 .
    drwxr-xr-x 3 www-data   www-data     4096 Dec  2 18:00 ..
    -rw-r--r-- 1 fogproject www-data     1966 Dec  2 18:00 advanced.php
    -rw-r--r-- 1 fogproject www-data    16272 Dec  2 18:00 bgdark.png
    -rw-r--r-- 1 fogproject www-data    21280 Dec  2 18:00 bg.png
    -rw-r--r-- 1 fogproject www-data     1139 Dec  2 18:00 boot.php
    -rw-r--r-- 1 fogproject www-data  8446624 Dec  2 18:01 bzImage
    -rw-r--r-- 1 fogproject www-data  7842720 Dec  2 18:01 bzImage32
    -rw-r--r-- 1 fogproject www-data   234697 Dec  2 18:00 grub.exe
    -rw-r--r-- 1 fogproject www-data      592 Dec  2 18:00 index.php
    -rw-r--r-- 1 fogproject www-data 20574204 Dec  2 18:01 init_32.xz
    -rw-r--r-- 1 fogproject www-data 21161356 Dec  2 18:01 init.xz
    -rw-r--r-- 1 fogproject www-data    25340 Dec  2 18:00 memdisk
    -rw-r--r-- 1 fogproject www-data  1839104 Dec  2 18:00 memtest.bin
    -rw-r--r-- 1 fogproject www-data   202624 Dec  2 18:00 refind_aa64.efi
    -rw-r--r-- 1 fogproject www-data    29719 Dec  2 18:00 refind.conf
    -rw-r--r-- 1 fogproject www-data   262592 Dec  2 18:00 refind.efi
    -rw-r--r-- 1 fogproject www-data   201600 Dec  2 18:00 refind_ia32.efi
    -rw-r--r-- 1 fogproject www-data   208776 Dec  2 18:00 refind_x64.efi
    
  • Senior Developer

    @JDnoble18 Yeah, manual install as described will surely work. We can also try to see if it’s a permission problem causing the web UI kernel update to fail. Run ls -al /var/www/html/fog/system/ipxe/ and post output here.

  • Moderator

    @jdnoble18 You can manually download the kernels from here. https://fogproject.org/kernels/

    save the 64 bit kernel as bzImage (watch your case) and the 32 bit kernel as bzImage32 (watch your case). These files go into /var/www/html/fog/service/ipxe directory on the fog server. I would rename the existing files before you install the new ones.

314
Online

8.7k
Users

15.4k
Topics

144.1k
Posts