• I have an air gapped instance of fog 1.5.8. I have some new devices with unsupported storage devices.

    I want to try some of the other boot images to see if they have the correct drivers. They used to be searchable, but i cannot find them of late.

  • Moderator

    @cmurray139 I’m going to close one eye and squint with the other to read between the lines here…

    I read this as: I have a fog server on a dedicated imaging network. This server has no connection to the outside world. I just purchase new hardware that I can’t image because the FOS Linux kernel is too old. How can I manually install the later version of the FOS Linux kernel that supports my new computers?

    If I guessed right then you need to get the kernels from here: https://fogproject.org/kernels/ Download Kernel.TomElliott.5.6.18.32 and save it as bzImage32 (watch your case) and Kernel.TomElliott.5.6.18.64 save it as bzImage. Now move these to the FOG server into /var/www/html/fog/service/ipxe directory replacing the files in that directory. You might want to rename the existing files just in case you need to back track to the older kernels. Now just pxe boot the target computers and see if the updated kernels do what you need.

    Now I also have to say since you specifically called out storage devices on these target computer, go into the bios (firmware setup) and make sure that the disk controller mode is ahci and not raid or raid-on. This will cause all version of the FOS Linux kernel to not be able to detect the storage device behind the disk controller.

  • Senior Developer

    @cmurray139 I’m not sure I understand your question.

    We don’t have “other boot images”. We don’t keep any person’s images period.

341
Online

8.0k
Users

14.9k
Topics

140.5k
Posts