• Hello guys, after upgrade to 1.5.9 versions I got a problem with windows 10 VM registration and deployment. After executing in menu quick/full registration or deployment VM crash (booting in uefi or legacy mode)
    hypervisor specs:
    Hypervisor: VMware ESXi, 6.5.0, 16576891
    Model: ProLiant DL380p Gen8
    Processor Type: Intel® Xeon® CPU E5-2640 v2 @ 2.00GHz

    After I migrated to another hypervisor the same VM everything worked as usual.

  • Senior Developer

    @kkthnxbb Thanks for posting the video. Looks like the crash happens exactly at the point where iPXE hands over to the Linux kernel. I stepped through the video and saw it showing ok for both bzImage and init.xz. While it could be a problem with the Linux kernel as well I would expect the issue to be in iPXE.

    Do I get this right, migrating the VM from ESXi 6.5.0 to ESXi 6.7.0 fixes the issue for you?

    Let’s try to go back to an earlier iPXE version. Which version of FOG did you use before 1.5.9? You can download older iPXE binaries on github using this URL: https://github.com/FOGProject/fogproject/tree/1.5.8/packages/tftp (just put in whichever version you had before, 1.5.8 or 1.5.7 or …). You don’t need to download all the binaries. Just grab ipxe.efi and put that into /tftpboot/ directory on your FOG server. Then boot up the VM again.

    You might want to pay attention to the iPXE version string printed when it starts just to make sure the switch of the binary actually worked.

  • Moderator

    @kkthnxbb Ok the video helped pinpoint where the crash was happening.

    So when you migrated to another hypervisor do you mean another esxi box or a different hypervisor like hyper-v or proxmox?

    I see that its an efi based VM that the kernel is basically crashing even before it starts running. So I wonder if you were to go into the fog ui and FOG Configuration -> Kernel update and download FOS Linux kernel 5.6.18 (you may need this one anyway if you have 2020 version hardware) and see if that kernel crashing.

    Now the other possibility is ipxe.efi because that is responsible to download bzImage and init.xz (FOS Linux) into memory and running them. Its possible the hand off between iPXE and bzImage is breaking. (just thinking about the point where the VM aborts)

    I do have to say I run my FOG environment on vSphere from version 5.0 to now 6.7 without any kind of issues like this. I build my golden image on a vSphere VM so I do exactly what you showed in the video without any issues.

  • @george1421 Sorry George, VM im talking about is Windows 10 x64 workstation. It’s strange at first I thought that init.xz cause crash after fog project upgrade. But then I did try fresh VM on other hypervisor and everything was good. After that I migrated VM (Windows 10 x64 workstation) what is my base image for deployment. And everything worked out.

    Preview of the problem I uploaded here: https://files.fm/u/htjhuuu8 , hope it helps to understand it.

  • Moderator

    @kkthnxbb Sorry your response still was not clear. Which VM crashed the FOG server or a target computer or VM you were registering?

    The registration process on the target computer doesn’t change the target computer’s settings at all. It only reads the hardware and updates the FOG server with the values. I can also read your post as the captured image when deployed to a new VM, when that new VM boots it crashes. Understand we need to get a picture in our heads from what is happening using your words.

    I agree with Sebastian, we need to see a picture or even better a video if it shows what happened just before the crash.

  • @Sebastian-Roth said in Vmware pxe boot crash:

    @kkthnxbb What exactly do you mean by crash? Please be more specific or even better post a picture or video of what you see in screen.

    Which other hypervisor do you migrate to to make it work?

    After I take quick registration option screen went black and VM did shut down with out any error on screen in uefi mode. In Legacy mode registration continued, but at some point it failed with error, there was a bit more information. Didn’t take a screenshot, was trying to fix it as soon as possible.

    Migrated to:
    Hypervisor: VMware ESXi, 6.7.0, 16316930
    Model: ProLiant DL360 Gen10
    Processor Type: Intel® Xeon® Silver 4110 CPU @ 2.10GHz

  • Senior Developer

    @kkthnxbb What exactly do you mean by crash? Please be more specific or even better post a picture or video of what you see in screen.

    Which other hypervisor do you migrate to to make it work?