After image deploy bios settings are changed?


  • I thought I saw a forum post regarding this issue a bit ago but could not find it with a quick search, so if this is a double post my apologies.

    Anyway I have been having some issues after fog deployments to single hosts. The deployment goes fine and the drive is written as expected, but for some reason my boot priorities change and pxe boot is no longer the first priority.

    In some cases, not only is the boot priority changed, but CSM has been re-enabled on the host motherboard as well. The image I am deploying to the host is an ubuntu image if that matters.

    Anyone else see this behavior?

  • Senior Developer

    @wmw509 Give the steps outlined by George a try but I can imagine this being caused by some fancy logic within the UEFI firmware. As George said FOG is not at all touching any firmware or boot settings… unless you have added post deploy scripts doing something special.

    Here is another test: Schedule the deploy task as debug. When you get to the shell run efibootmgr command (don’t know if you need parameters or not from the top of my head) and take a picture of the output in screen. Now start the task with command fog and step through it. At the end run efibootmgr again, take a picture and compare/post here. Before you type reboot schedule another debug task for this machine and see if it PXE boots into it.

  • Moderator

    @wmw509 said in After image deploy bios settings are changed?:

    The deployment goes fine and the drive is written as expected, but for some reason my boot priorities change and pxe boot is no longer the first priority.

    When I first read this bit I was going to say, well that is windows for you. Windows will change the boot order during WinSetup/oobe.

    But since you are using ubuntu that add a bit of a different dynamic here. I can tell you that FOG does not touch the boot order, actually that causes issues for a different reason. The operating systems can interface with the uefi firmware and change boot order settings.

    But lets go ahead and find out if its FOG or not doing this.

    1. Ensure that pxe booting is the default for this test computer.
    2. Schedule a deploy task but before you hit the schedule button tick the checkbox to shutdown the computer after imaging.
    3. Now pxe boot into imaging. At the end of imaging the computer will shutdown.
    4. Power the computer up under your control and go immediatly into the bios (firmware) and confirm the boot order. If its still pxe boot then fog didn’t touch it.
    5. Exit out of the firmware and let the computer boot into ubuntu and let ubuntu do its thing to the computer.
    6. Reboot and go back into the firmware setup.

    Did the boot order change? If so when?

334
Online

8.8k
Users

15.5k
Topics

144.5k
Posts