Having problems deploying Win7 image to ASUS M5A88-M mobo

  • Hi all,

    I have a FOG v0.32 server running on Turnkey Linux v12 (basically Debian Squeeze) as an OVZ container on a ProxmoxVE server. I ended up having trouble getting NFS working under OVZ so I created a new KVM vm as a storage node (also TKLv12/Debian6). (FYI the main FOG node and the FOG storage node are VMs on the same hardware). I had a few teething issues initially but all running sweet now (at least on 3 PCs…)

    Here’s what I’ve done so far:
    []Installed Win7 to a VM and then uploaded it to my FOG setup
    ]Deployed it to 1 of the 7 PCs I have, tweaked it a little more and uploaded it again
    []Deployed it on 2 other machines with exactly the same hardware - still all good
    ]Deployed it to another PC that has different hardware and issues…! 😞
    The motherboard of the machine it’s not working on is an ASUS M5A88-M (according to FOG full inventory which ran fine). When I tried to deploy my (working) Win7 image to the machine it stated that it there was no Win7/sys.img.000 (or words to that effect). I doubled checked (by ls /images/Win7/ on the storage node) and sure enough it was there. To check my setup I re deployed (the same image) to one of the machines that is working successfully and it still worked fine… Regardless I also ‘chmod -R 777 /images/’ on my storage node, jsut in case. So I updated the FOG boot kernel (to the latest) and now it freezes during boot with:
    [CODE]Trying to load: pxelinux.cfg/20690bac-35c5-e011-b652-14dae9b3a5ce
    Trying to load: pxelinux.cfg/01-14-da-e9-b3-a5-ce
    Loading fog/kernel/bzImage…[/CODE]
    So I don’t know what to try next?? Any ideas…??

    [update] I downgraded the kernel a couple of versions and got back to my original situation (ie the system boots ok, but can’t find the image).

  • I ended up testing on another (4th) machine and that worked too but this ASUS still refused to play ball.

    However, finally solved it!! (I couldn’t work out how to change the title, if an admin wants to mark it solved, please go for it)

    It ends up the problem seemed to be that my Fog server (within TFTP) was handing out the wrong DNS server IP (DHCP was handing out the right one, just it was wrong in the Fog settings). I’m still not sure why or how that was the problem (my FOG storage server was set using IP not hostname) and it was strange that all the other machines worked ok (just not this one). But that seemed to fix it, so happy days! 🙂