Not able to use Legacy on BIOS :(

  • Hello!
    I have 84 new HP laptops that I need to image, but the BIOS installed on these only has UEFI options in the bootloader. There is no option for Legacy whatsoever. I have tried contacting HP to no avail. I tried to upgrade the BIOS but HP no longer provides any files to do so.

    My question is: is it possible to image from FOG over UEFI? I have tried this already but PXE gets stuck on “Start PXE over ipv4 on MAC {mac address}.

    Thanks in advance folks!

  • @george1421 said in Not able to use Legacy on BIOS 😞:


    George, you are the best. You constantly help me out on these forms. If I could take you out for a working lunch I would.

    I switched it over to ipxe.efi and it worked.

  • Moderator

    @Naline said in Not able to use Legacy on BIOS 😞:

    NBP filename undionly.kpxe

    Well NBP refers to a UEFI system and you are sending a bios (legacy) mode boot loader to the target computer. Bios and UEFI are not compatible. You should be sending ipxe.efi for a uefi based computer.

    When I change the DHCP bootfile name to boot\x64\wdsmgfw.efi

    Umm, this is a WDS problem/issue not FOG.

    If you are using FOG and have a Windows 2012 or newer DHCP server this document may help you create a dynamic boot file that will support both bios and uefi clients pxe booting.

  • Hello, I am running into the same problem with some new Lenovo Thinkpad machines. I can get it to Start PXE over IPv4, get an IP address, it loads with NBP filename undionly.kpxe, says the NBP file downloaded successfully and then flips back to the standard boot menu.

    When I change the DHCP bootfile name to boot\x64\wdsmgfw.efi I get an IP address, but it says the PXE-E23: Client received TFTP error from the server. I have never used this one but saw it online so thought I would try it.

    When you refer to what kid of DHCP and version, what are you referring to? We use a Windows Server 2016 for our DHCP services.

    Thanks for the help.

  • Senior Developer

    @bwenig Did you setup the DHCP yourself or is this the DHCP FOG put up for you when you ran the FOG installer?

  • I am using DHCP on an Ubuntu 18.04 VM. Sorry, I am very green to FOG and all of this!

  • Senior Developer

    @bwenig Sure, FOG can image UEFI machines since many years!

    The difference is you need to provide another iPXE binary for UEFI machines within your DHCP server configuration.

    What kind of DHCP (and version) do you use?