How to: Modify the PXE boot menu to allow the booting of .iso files



  • There have been some really basic guides on the fog user guide, and some quick videos on youtube that show how to append the default file under the tftpboot folder in Linux so you can pxe boot your own .iso applications.

    I just wanted to take the time and break down the instructions into a friendlier video that might help people a bit more.

    To use this guide I’m assuming the following 6 things

    1. You have a working version of Fog (obvious)
    2. You have modified your TFTP password under the fog UI - [url]http://fogproject.org/wiki/index.php?title=Unable_to_connect_to_TFTP#For_Versions_.24_.2B[/url]
    3. You have a copy of the .iso you wish to boot (example: Dell Diagnostics)
    4. You have a copy of memdisk from kernel.org - [url]http://www.kernel.org/pub/linux/utils/boot/syslinux/[/url]
    5. You have an FTP program such as filezilla that will allow you to copy / paste / and append files on your fog server
    6. You can copy and paste + edit the following text below to meet your needs

    [CODE]LABEL Dell Diagnostics
    MENU MASTER PASSWD password
    kernel fog/dell/memdisk
    append iso initrd=fog/dell/delldiags.iso raw
    MENU LABEL Dell Diagnostics
    TEXT HELP
    Dell™ Diagnostic software
    ENDTEXT[/CODE]

    Ok! ;) Now watch the video for a quick overview on how to create a folder under tftpboot/fog, copy over your .iso and memdisk file to the new folder, append the default file with a text editor under tftpboot/default.cfg

    [media=youtube]KYp-XVPxg3I[/media]

    I just wanted to point out that the video also includes 720p so you can put it on high res and zoom in to see the detail, text if needed.

    If you guys have any questions let me know.

    Enjoy!



  • I´ve used memdisk from /tftpboot and it worked with fog 0.32:)



  • I´m using fog 0.32. There are memdisk in /tftpboot.
    Can I use that file?


  • Developer

    none of those if you’re using fog 1.0+
    [url]http://fogproject.org/forum/threads/fog-0-33b-edit-pxe-menu.10403/#post-26420[/url]
    there is a memdisk file located in <fog-web-root>/service/ipxe/memdisk



  • [COLOR=#000080][B][SIZE=4]Sorry for [/SIZE][/B][/COLOR][COLOR=#000080][B][SIZE=4]my ignorance[/SIZE][/B].[/COLOR]o_O

    What is the file that I have to use.:confused:
    In syslinux-6.00.tar.bz2, into the directory memdisk there are many files called memdisk memdisk.:eek:



  • Yes, the DocumentRoot is /var/www/html.
    If I try to post my advanced configuration options it’s marked as spam.

    EDIT: I changed the DocumentRoot to /var/www and the chmod of my folder to 777. Now it’s working.


  • Senior Developer

    What is the document root of the server? Is it /var/www or /var/www/html?


  • Developer

    if you provide a copy of what you put in your advanced boot options, i can help you troubleshoot it



  • Yes I know that. I checked it several times. The URL is not wrong.
    I will do some more research tomorrow.


  • Developer

    if the files are within your web root, and you can’t download them with a browser, then you almost certainly have the URL wrong. keep in mind that anything past the first / is case sensitive



  • Yes i tried testing the location in Chrome/Firefox/IE. I tried setting the permissions to 644 either.
    I get the following error message: “[SIZE=4][FONT=Times New Roman][COLOR=#000000]The requested URL … was not found on this server.”
    [/COLOR][/FONT][/SIZE]


  • Developer

    i keep my ISO files in a separate folder from www/fog, and it works fine and my permissions are set to 644.
    have you tried testing the location you put into the “advanced” menu in a browser? it should ask if you want to download the file.



  • Thank you.
    It works, but only if the ISO is in the “www/fog” directory.
    If I create an own directory “www/ISO” and set chmod to 777 it does not work.


  • Senior Developer

    [quote=“qUoTuM, post: 26870, member: 24126”]Is there any way i can do this in FOG 1.0.0?
    I looked it up but its kind of different and i cant figure out how to do it.[/quote]

    I direct you to a couple of other posts wanting, basically, the same things:
    [url]http://fogproject.org/forum/threads/switching-to-gpxelinux.3995/[/url]
    [url]http://fogproject.org/forum/threads/fog-0-33b-edit-pxe-menu.10403/[/url]

    They both talk about how to add entries under the advanced menu system as many things are rather touchy with the BootMenu directly. That said, so long as there’s information contained in the Advanced menu, changes are likely things will work for your scenario.

    Thank you,



  • Is there any way i can do this in FOG 1.0.0?
    I looked it up but its kind of different and i cant figure out how to do it.



  • Great tutorial video! Really helped me out! Thanks a lot!



  • Old thread I know but hoping someone can help me here.

    I have edited the PXE boot menu before a few times (all thanks to this guide - thanks a lot ssx ;)) and never had a problem, however on this latest fog server I have set up I cannot seem to get it to work. I can edit the default file fine to display the menu options and also dropped the ISO files into the correct directory, but when ever I select one of them from the menu it only gets so far and then just says “loading boot sector… booting…”. It would appear that fog has found the iso and started to load it, but a problem lies somewhere else maybe? I have tried a few different memdisk versions, and this still happens on various ISOs such as Ultimate boot CD, Dell Diags, WinPE tools etc…

    Any ideas on this would be greatly appreciated :)



  • The thing about booting an ISO, is that you have to transfer the size of the ISO over the wire using tftp… Which can take long. The usual approach to live booting on PXE is to send a smaller image, then have the root mounted off NFS, so that it doesn’t have to wait until everything is loaded to boot.


  • Senior Developer

    That is it loading. It loads for a while.



  • SO i got it to bypass the email now i get get lines and lines of …

    how can i get this to just load!!!


Log in to reply
 

390
Online

38937
Users

10696
Topics

101490
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.