Upgrade to 1.5.9-RC2 gone wrong



  • I had a 1.5.3 running
    I upgraded according to the wiki to 1.5.9-RC2.
    No errors in the script, so far. Everything went smoothly.

    I can login to the WebGUI, but here some problems occur: Several link just show blank pages. Without any content:

    • Hosts
    • FOG Settings
    • Tasks -> list hosts
    • Tasks -> active snapins (no tasks are running)
    • Several reports just generate blank pages, too.

    Please, can anybody tell me how to track this down?

    Thanks a lot!
    Chris


  • Senior Developer

    @fogusnew said in Upgrade to 1.5.9-RC2 gone wrong:

    [proxy_fcgi:error] [pid 9320] [client 172.28.171.4:53982] AH01071: Got error 'PHP message: PHP Fatal error:  Allowed memory size of 2097152 bytes exhausted (tried to allocate 16384 bytes) in /var/www/html/fog/lib/fog/fogcontroller.class.php on line 260\n', referer: http:// .... fog/management/index.php?node=home
    

    [proxy_fcgi:error] [pid 9320] [client 172.28.171.4:55178] AH01071: Got error 'PHP message: PHP Fatal error:  Allowed memory size of 2097152 bytes exhausted (tried to allocate 65536 bytes) in /var/www/html/fog/lib/fog/fogbase.class.php on line 467\n', referer: .... /fog/management/index.php?node=about
    

    Took a look at the code lines mentioned in the errors. Can’t make sense of these yet.

    By the way, PHP 7.0 … what Linux OS and version do you run?


  • Moderator

    @fogusnew Yeah 60 clients should push this over the top. If you had 6000 then I can understand.



  • @george1421 said in Upgrade to 1.5.9-RC2 gone wrong:

    @fogusnew said in Upgrade to 1.5.9-RC2 gone wrong:

    I was looking for memory_limit values in the files I mentioned above.

    If php-fpm is managing the php on your FOG server this should be the proper config file /etc/php/7.0/fpm/pool.d/www.conf

    This is the proper value to change php_admin_value[memory_limit] Then restart pphp-fpm.

    I did that.

    How many computers (with fog client installed) are hitting this FOG server? If you have a master node and multiple storage nodes, I need to know all computers from all sites that have the fog client installed.

    I run only one bar metal server with fog on it. We have ~60 PCs to manage. I did not hit the memory limit before I did the upgrade.
    I’m off site again, but will be back next week. I’ll check everything once more and report back. Thanks, again!


  • Moderator

    @fogusnew said in Upgrade to 1.5.9-RC2 gone wrong:

    I was looking for memory_limit values in the files I mentioned above.

    If php-fpm is managing the php on your FOG server this should be the proper config file /etc/php/7.0/fpm/pool.d/www.conf

    This is the proper value to change php_admin_value[memory_limit] Then restart pphp-fpm.

    As you increase this above value the error message

     Allowed memory size of 2097152 bytes exhausted (tried to allocate 65536 bytes)
    

    should also increase. This error is telling me you have 256M configured for the memory limit. So the real question is why are we hitting a memory limit??

    How many computers (with fog client installed) are hitting this FOG server? If you have a master node and multiple storage nodes, I need to know all computers from all sites that have the fog client installed.



  • @Sebastian-Roth I restarted the services and the system. I can see the the increasing memory in the log; but still “more” is requested.
    @george1421 I was looking for memory_limit values in the files I mentioned above. I doubled them several times from 128M to 256M, and then step by step to 2048M. In all those files.

    Still no change.

    Thnaks a lot for your efforts


  • Moderator

    @fogusnew What parameter did you change to increase memory size?


  • Senior Developer

    @fogusnew Did you restart Apache and PHP-FPM after changing the settings?



  • Increasing the memory limit in /etc/php/7.0/fpm/php.ini and /etc/php/7.0/apache2/php.ini and /etc/php/7.0/fpm/pool.d/www.conf does not help.



  • Well, sorry, that I bring up this issue after such a long time. But I’ve been off site for a while. Now I was able to look at the logs.
    I get a white screen and a PHP error

    [proxy_fcgi:error] [pid 9320] [client 172.28.171.4:53982] AH01071: Got error 'PHP message: PHP Fatal error:  Allowed memory size of 2097152 bytes exhausted (tried to allocate 16384 bytes) in /var/www/html/fog/lib/fog/fogcontroller.class.php on line 260\n', referer: http:// .... fog/management/index.php?node=home
    

    when I try to access the “hosts list” page.

    a similar one when I try to get to the fog settings:

    [proxy_fcgi:error] [pid 9320] [client 172.28.171.4:55178] AH01071: Got error 'PHP message: PHP Fatal error:  Allowed memory size of 2097152 bytes exhausted (tried to allocate 65536 bytes) in /var/www/html/fog/lib/fog/fogbase.class.php on line 467\n', referer: .... /fog/management/index.php?node=about
    

    No errors in the php7.0-fpm log
    I searched the forum for similar topics, could find some, but can not make a solution out of them.


  • Senior Developer

    @fogusnew Check Apache and PHP-FPM logs. See my signature…


Log in to reply
 

235
Online

7.2k
Users

14.4k
Topics

135.6k
Posts