Interface not ready, waiting for it to come up FOG 1.5.8



  • CentOS Linux 7.7.1908
    FOG 1.5.8

    Updated to Stable Release FOG 1.5.8. Now my Master Storage Group is not replicating to its child members.

    10.XX.XX.32 is the server that has FOG installed on it and its it own storage group that only hosts Snapins and no Images. It is not apart of the Master Storage group so I am not sure why my Master Node cares about it.

    [06-17-20 8:43:19 am] Interface not ready, waiting for it to come up: 10.XX.XX.32
    

  • Senior Developer

    @UWPVIOLATOR said in Interface not ready, waiting for it to come up FOG 1.5.8:

    I could not do grep php /opt/fog/.fogsettings as I tried a fresh install. fogsettings-firstInstall

    I think we are mixing up way too many things in this one topic. It was about FOG on CentOS 7 and upgrades. Now we are talking about Ubuntu 19.04 fresh install. May I please ask you to open new topics for new issues to prevent confusion and missunderstanding? Please open a fresh topic for the Ubuntu fresh install and I will move the posts over.

    While I am not sure yet it seems like there is an issue with PHP version numbers when using FOG 1.5.8 on Ubuntu 19.04. The later is end of life already and we won’t backport fixes to FOG 1.5.8 either. So you might want to think about giving the most current versions a try as it seems to be a fresh install anyway.



  • @Sebastian-Roth

    error_logs

    /usr/bin/lsb_release
    /usr/bin/systemctl
    systemd
    /usr/sbin/iptables
    ii  mysql-server   5.7.30-0ubuntu0.18.04.1 all          MySQL database server (metapackage depending on the latest version)
    'universe' distribution component is already enabled for all sources.
    Ign:1 http://download.webmin.com/download/repository sarge InRelease
    Hit:2 http://download.webmin.com/download/repository sarge Release
    Hit:3 http://ppa.launchpad.net/ondrej/php/ubuntu disco InRelease
    Hit:4 http://archive.ubuntu.com/ubuntu bionic InRelease
    Get:6 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]
    Hit:7 http://archive.ubuntu.com/ubuntu bionic-backports InRelease
    Hit:8 http://archive.ubuntu.com/ubuntu bionic-security InRelease
    Ign:9 http://archive.ubuntu.com/ubuntu disco InRelease
    Err:10 http://archive.ubuntu.com/ubuntu disco Release
      404  Not Found [IP: 91.189.88.142 80]
    Reading package lists...
    E: The repository 'http://archive.ubuntu.com/ubuntu disco Release' does not have a Release file.
    ii  apache2        2.4.38-2ubuntu2.3 amd64        Apache HTTP Server
    ii  bc             1.07.1-2build1 amd64        GNU bc arbitrary precision calculator language
    ii  build-essential 12.6ubuntu1  amd64        Informational list of build-essential packages
    ii  cpp            4:8.3.0-1ubuntu3 amd64        GNU C preprocessor (cpp)
    ii  curl           7.64.0-2ubuntu1.2 amd64        command line tool for transferring data with URL syntax
    ii  g++            4:8.3.0-1ubuntu3 amd64        GNU C++ compiler
    ii  gawk           1:4.2.1+dfsg-1build1 amd64        GNU awk, a pattern scanning and processing language
    ii  gcc            4:8.3.0-1ubuntu3 amd64        GNU C compiler
    ii  genisoimage    9:1.1.11-3ubuntu2 amd64        Creates ISO-9660 CD-ROM filesystem images
    ii  git            1:2.20.1-2ubuntu1.19.04.1 amd64        fast, scalable, distributed revision control system
    ii  gzip           1.9-3        amd64        GNU compression utilities
    ii  htmldoc        1.9.3-1      amd64        HTML processor that generates indexed HTML, PS, and PDF
    ii  isolinux       3:6.04~git20171011.af7e95c3+dfsg1-6 all          collection of bootloaders (ISO 9660 bootloader)
    ii  lftp           4.8.4-2build1 amd64        Sophisticated command-line FTP/HTTP/BitTorrent client programs
    dpkg-query: no packages found matching libapache2-mod-php7.3
    ii  libc6:amd64    2.29-0ubuntu2 amd64        GNU C Library: Shared libraries
    ii  libcurl4:amd64 7.64.0-2ubuntu1.2 amd64        easy-to-use client-side URL transfer library (OpenSSL flavour)
    ii  liblzma-dev:amd64 5.2.4-1      amd64        XZ-format compression library - development files
    ii  m4             1.4.18-2     amd64        macro processing language
    ii  mysql-client   5.7.30-0ubuntu0.18.04.1 all          MySQL database client (metapackage depending on the latest version)
    mysql-server-5.7
    mysql-server
    default-mysql-server-core
    default-mysql-server
    mysql-server-core-5.7
    ii  mysql-server   5.7.30-0ubuntu0.18.04.1 all          MySQL database server (metapackage depending on the latest version)
    ii  net-tools      1.60+git20180626.aebd88e-1ubuntu1 amd64        NET-3 networking toolkit
    ii  nfs-kernel-server 1:1.3.4-2.3ubuntu3 amd64        support for NFS kernel server
    ii  openssh-server 1:7.9p1-10   amd64        secure shell (SSH) server, for secure access from remote machines
    dpkg-query: no packages found matching php7.3
    dpkg-query: no packages found matching php7.3-bcmath
    dpkg-query: no packages found matching php7.3-cli
    dpkg-query: no packages found matching php7.3-curl
    dpkg-query: no packages found matching php7.3-fpm
    dpkg-query: no packages found matching php7.3-gd
    dpkg-query: no packages found matching php7.3-json
    dpkg-query: no packages found matching php7.3-ldap
    dpkg-query: no packages found matching php7.3-mbstring
    dpkg-query: no packages found matching php7.3-mysql
    dpkg-query: no packages found matching php7.3-mysqlnd
    ii  php-gettext    1.0.12-0.1   all          transitional dummy package for php-php-gettext
    ii  tar            1.30+dfsg-5  amd64        GNU version of the tar archiving utility
    ii  tftpd-hpa      5.2+20150808-1ubuntu3 amd64        HPA's tftp server
    ii  tftp-hpa       5.2+20150808-1ubuntu3 amd64        HPA's tftp client
    ii  unzip          6.0-22ubuntu1 amd64        De-archiver for .zip files
    ii  vsftpd         3.0.3-12     amd64        lightweight, efficient FTP server written for security
    ii  wget           1.20.1-1ubuntu4 amd64        retrieves files from the web
    ii  xinetd         1:2.3.15.3-1 amd64        replacement for inetd with many enhancements
    ii  zlib1g:amd64   1:1.2.11.dfsg-1ubuntu2 amd64        compression library - runtime
    Reading package lists...
    Building dependency tree...
    Reading state information...
    genisoimage is already the newest version (9:1.1.11-3ubuntu2).
    tftp-hpa is already the newest version (5.2+20150808-1ubuntu3).
    tftpd-hpa is already the newest version (5.2+20150808-1ubuntu3).
    php-gettext is already the newest version (1.0.12-0.1).
    xinetd is already the newest version (1:2.3.15.3-1).
    mysql-client is already the newest version (5.7.30-0ubuntu0.18.04.1).
    mysql-server is already the newest version (5.7.30-0ubuntu0.18.04.1).
    apache2 is already the newest version (2.4.38-2ubuntu2.3).
    bc is already the newest version (1.07.1-2build1).
    build-essential is already the newest version (12.6ubuntu1).
    cpp is already the newest version (4:8.3.0-1ubuntu3).
    curl is already the newest version (7.64.0-2ubuntu1.2).
    g++ is already the newest version (4:8.3.0-1ubuntu3).
    gawk is already the newest version (1:4.2.1+dfsg-1build1).
    gcc is already the newest version (4:8.3.0-1ubuntu3).
    git is already the newest version (1:2.20.1-2ubuntu1.19.04.1).
    git set to manually installed.
    gzip is already the newest version (1.9-3).
    htmldoc is already the newest version (1.9.3-1).
    isolinux is already the newest version (3:6.04~git20171011.af7e95c3+dfsg1-6).
    lftp is already the newest version (4.8.4-2build1).
    libc6 is already the newest version (2.29-0ubuntu2).
    libcurl4 is already the newest version (7.64.0-2ubuntu1.2).
    liblzma-dev is already the newest version (5.2.4-1).
    m4 is already the newest version (1.4.18-2).
    net-tools is already the newest version (1.60+git20180626.aebd88e-1ubuntu1).
    nfs-kernel-server is already the newest version (1:1.3.4-2.3ubuntu3).
    openssh-server is already the newest version (1:7.9p1-10).
    tar is already the newest version (1.30+dfsg-5).
    unzip is already the newest version (6.0-22ubuntu1).
    vsftpd is already the newest version (3.0.3-12).
    wget is already the newest version (1.20.1-1ubuntu4).
    zlib1g is already the newest version (1:1.2.11.dfsg-1ubuntu2).
    Calculating upgrade...
    The following packages have been kept back:
      gir1.2-javascriptcoregtk-4.0 gir1.2-webkit2-4.0 libfreerdp-client2-2
      libfreerdp2-2 libgl1-mesa-dri libjavascriptcoregtk-4.0-18
      libpython2.7-minimal libpython2.7-stdlib libpython3.7 libpython3.7-minimal
      libpython3.7-stdlib libwebkit2gtk-4.0-37 libwinpr2-2 libxatracker2
      mesa-vulkan-drivers netplan.io python2.7 python2.7-minimal python3.7
      python3.7-minimal
    0 upgraded, 0 newly installed, 0 to remove and 20 not upgraded.
    ii  apache2        2.4.38-2ubuntu2.3 amd64        Apache HTTP Server
    ii  bc             1.07.1-2build1 amd64        GNU bc arbitrary precision calculator language
    ii  build-essential 12.6ubuntu1  amd64        Informational list of build-essential packages
    ii  cpp            4:8.3.0-1ubuntu3 amd64        GNU C preprocessor (cpp)
    ii  curl           7.64.0-2ubuntu1.2 amd64        command line tool for transferring data with URL syntax
    ii  g++            4:8.3.0-1ubuntu3 amd64        GNU C++ compiler
    ii  gawk           1:4.2.1+dfsg-1build1 amd64        GNU awk, a pattern scanning and processing language
    ii  gcc            4:8.3.0-1ubuntu3 amd64        GNU C compiler
    ii  genisoimage    9:1.1.11-3ubuntu2 amd64        Creates ISO-9660 CD-ROM filesystem images
    ii  git            1:2.20.1-2ubuntu1.19.04.1 amd64        fast, scalable, distributed revision control system
    ii  gzip           1.9-3        amd64        GNU compression utilities
    ii  htmldoc        1.9.3-1      amd64        HTML processor that generates indexed HTML, PS, and PDF
    ii  isolinux       3:6.04~git20171011.af7e95c3+dfsg1-6 all          collection of bootloaders (ISO 9660 bootloader)
    ii  lftp           4.8.4-2build1 amd64        Sophisticated command-line FTP/HTTP/BitTorrent client programs
    ii  libc6:amd64    2.29-0ubuntu2 amd64        GNU C Library: Shared libraries
    ii  libcurl4:amd64 7.64.0-2ubuntu1.2 amd64        easy-to-use client-side URL transfer library (OpenSSL flavour)
    ii  liblzma-dev:amd64 5.2.4-1      amd64        XZ-format compression library - development files
    ii  m4             1.4.18-2     amd64        macro processing language
    ii  mysql-client   5.7.30-0ubuntu0.18.04.1 all          MySQL database client (metapackage depending on the latest version)
    ii  mysql-server   5.7.30-0ubuntu0.18.04.1 all          MySQL database server (metapackage depending on the latest version)
    ii  net-tools      1.60+git20180626.aebd88e-1ubuntu1 amd64        NET-3 networking toolkit
    ii  nfs-kernel-server 1:1.3.4-2.3ubuntu3 amd64        support for NFS kernel server
    ii  openssh-server 1:7.9p1-10   amd64        secure shell (SSH) server, for secure access from remote machines
    ii  php-gettext    1.0.12-0.1   all          transitional dummy package for php-php-gettext
    ii  tar            1.30+dfsg-5  amd64        GNU version of the tar archiving utility
    ii  tftpd-hpa      5.2+20150808-1ubuntu3 amd64        HPA's tftp server
    ii  tftp-hpa       5.2+20150808-1ubuntu3 amd64        HPA's tftp client
    ii  unzip          6.0-22ubuntu1 amd64        De-archiver for .zip files
    ii  vsftpd         3.0.3-12     amd64        lightweight, efficient FTP server written for security
    ii  wget           1.20.1-1ubuntu4 amd64        retrieves files from the web
    ii  xinetd         1:2.3.15.3-1 amd64        replacement for inetd with many enhancements
    ii  zlib1g:amd64   1:1.2.11.dfsg-1ubuntu2 amd64        compression library - runtime
    New password: Retype new password: passwd: password updated successfully
    Failed to stop php7.3-fpm.service: Unit php7.3-fpm.service not loaded.
    
    

    I could not do grep php /opt/fog/.fogsettings as I tried a fresh install. fogsettings-firstInstall


  • Senior Developer

    @UWPVIOLATOR Please run find / -name "installfog.sh" to find the directory where the error_logs are.

    Ok, so this is an Ubuntu 19.04 install. Run grep php /opt/fog/.fogsettings as well and post output here.



  • @Sebastian-Roth Unable to find the log path bin/error_logs/… But here is the dpkg -l | grep php

    Storage Nodes are Ubuntu this one is Ubuntu Linux 19.04 The other one is offline but I believe it is also 19.04.

    ii  libapache2-mod-php7.2                      7.2.24-0ubuntu0.19.04.2                          amd64        server-side, HTML-embedded scripting language (Apache 2 module)
    ii  php-common                                 2:69ubuntu1                                      all          Common files for PHP packages
    ii  php-gettext                                1.0.12-0.1                                       all          transitional dummy package for php-php-gettext
    ii  php-pear                                   1:1.10.6+submodules+notgz-1.1                    all          PEAR Base System
    ii  php-php-gettext                            1.0.12-0.1                                       all          read gettext MO files directly, without requiring anything other than PHP
    ii  php-xml                                    2:7.2+69ubuntu1                                  all          DOM, SimpleXML, WDDX, XML, and XSL module for PHP [default]
    ii  php7.2                                     7.2.24-0ubuntu0.19.04.2                          all          server-side, HTML-embedded scripting language (metapackage)
    ii  php7.2-bcmath                              7.2.24-0ubuntu0.19.04.2                          amd64        Bcmath module for PHP
    ii  php7.2-cli                                 7.2.24-0ubuntu0.19.04.2                          amd64        command-line interpreter for the PHP scripting language
    ii  php7.2-common                              7.2.24-0ubuntu0.19.04.2                          amd64        documentation, examples and common module for PHP
    ii  php7.2-curl                                7.2.24-0ubuntu0.19.04.2                          amd64        CURL module for PHP
    ii  php7.2-fpm                                 7.2.24-0ubuntu0.19.04.2                          amd64        server-side, HTML-embedded scripting language (FPM-CGI binary)
    ii  php7.2-gd                                  7.2.24-0ubuntu0.19.04.2                          amd64        GD module for PHP
    ii  php7.2-json                                7.2.24-0ubuntu0.19.04.2                          amd64        JSON module for PHP
    ii  php7.2-ldap                                7.2.24-0ubuntu0.19.04.2                          amd64        LDAP module for PHP
    ii  php7.2-mbstring                            7.2.24-0ubuntu0.19.04.2                          amd64        MBSTRING module for PHP
    ii  php7.2-mysql                               7.2.24-0ubuntu0.19.04.2                          amd64        MySQL module for PHP
    ii  php7.2-opcache                             7.2.24-0ubuntu0.19.04.2                          amd64        Zend OpCache module for PHP
    ii  php7.2-readline                            7.2.24-0ubuntu0.19.04.2                          amd64        readline module for PHP
    ii  php7.2-xml                                 7.2.24-0ubuntu0.19.04.2                          amd64        DOM, SimpleXML, WDDX, XML, and XSL module for PHP
    
    

  • Senior Developer

    @UWPVIOLATOR said in Interface not ready, waiting for it to come up FOG 1.5.8:

    So I got it replicating

    You mean the message “Interface not ready, waiting for it to come up” is gone? What exactly did you do?

    To be able to help we’d need a better understanding of your setup. You seem to have several nodes but there is no detailed information on this.

    I could not update 2 of my nodes as it errored out on the install.

    On those nodes can you please grab the last 10 lines of the error log you find in the installer directory under bin/error_logs/... and post those here? As well it would be great to know which Linux OS and version you have on those two nodes? Are they all CentOS 7? Run rpm -qa | grep php or dpkg -l | grep php and post output here as well. The stopping web service issue is usually due to a PHP version change which should not be the case if you run CentOS 7.



  • @Sebastian-Roth So I got it replicating. All storage nodes need to be updated or turned off. I could not update 2 of my nodes as it errored out on the install.

    * Stopping web service........................................Failed!
    


  • @Sebastian-Roth So I changed the fogsettings file back to correct interface reran installer and still not working. This time no IP its waiting for.

    Interface not ready, waiting for it to come up: 
    


  • @Sebastian-Roth Updated from 1.5.6 so we already did the storage node upgrade. I just updated to 1.5.9 RC2 and still seeing the issue. Also, it looks like it changed my interface from bond0 to em1

    You will need this, write this down!
    IP Address: 10.XXX.XXX.30
    Interface: em1
    Management Username: fogproject

    8f664cc3-c4c5-4dab-94c2-b25cecb6d771-image.png


  • Senior Developer

    @UWPVIOLATOR Did you upgrade all your nodes? Just asking this as a first question because if you upgraded from 1.5.4 and earlier there was a major change in replication that would force a never ending full re-sync of all image files over and over again because hash sums would never match.

    Interface not ready, waiting for it to come up

    There was an issue in 1.5.8 which I think is what you see here. We fixed that a few weeks ago and I may ask you to upgrade to 1.5.9-RC2 and give it a try.

    I can understand you might not be keep to update to a release candidate version but hey, we are only able to see if this actually fixes the problem in your situation if you update (or manually add the fix). If you just wait for 1.5.9 to be released we might find out that I was wrong and your issue is different to what we had reported in the forums back then when the fix came out.


Log in to reply
 

299
Online

7.1k
Users

14.3k
Topics

135.1k
Posts