SOLVED Dell Latitude 5510 No network interface found! Kernel might not have the correct driver!


  • Im getting this message when im trying to upload.

    “No Network Interface found, your kernel is most probably missing the correct driver! Please check your network setup and try again!”

    I’ve already changed patch cord and upgraded to the latest fog which is the 1.5.9-RC2.9. Can anybody help with this issue i’ve been cloning and capturing with no issue but since this is a new model of laptop i think it might have a newer card. The card that i has its an Intel Ehternet Connection l219-LM. Any help will be greatly appreciated!


  • Guys, I have some Dell Latitude 5510 with the same problem, I tested it with a USB-C adapter, and it really works, I don’t know what the explanation is but it works !!


  • @asbenavides we have imaged the Latitude 5510’s. I am trying to remember if we just used the USB-C to ethernet adapters or if we used the onboard ethernet. It was a while ago.


  • @sebastian-roth Sorry, i was updating the firmware but in the wrong directory. I messed up something in the www path and there was two service/ipxe directory, so stupid mistake, my bad

    thank you for the help again

  • Moderator

    @lachagnasse Ok this one is new/strange.

    I want you to schedule a new capture/deploy (doesn’t matter) but before you hit the schedule task button, tick the debug checkbox then schedule the task.

    PXE boot the target computer. You will still get the error but after a few screens of text you need to clear with the enter key, you should be dropped to the FOS Linux command prompt.

    At the fos linux command prompt key in the following ip a s see if it lists more than the loopback network adapter. Hopefully there is more than just the loop back.

    If it only shows the loop back then key in the following. lspci -nn | grep -i net. I know you have already done that because you have posted the results. I’m putting this here for others that might find this post.

    Using the output you already provided.

    00:14.3 Network Controller [0280]: Intel Corporation Device [8086:02f0]
    00:1f.6 Ethernet Controller [0200]: Interl Corporation Ethernet Connection (10) I219-V [8086:0d4f}
    

    Beyond the device ID that says its an i219-v network adapter the hardware location is important for this next bit {00:1f.6}
    Key in the following command (similar to before but with different details) lspci -k -nn | more

    With that command look through the output for the hardware location 00:1f.6. With a mobile phone take a clear shot of that line. I need to see the line with the 00:1f.6 on it plus the following 2-3 lines. I need to see the kernel driver that is being used.

    And finally key in uname -r that should return the kernel version 5.6.18.

  • Senior Developer

    @lachagnasse said in Dell Latitude 5510 No network interface found! Kernel might not have the correct driver!:

    Hi everyone, we have exactly the same issue on the same computer (latitude 5510).

    Please take a picture if the error on screen and post here.


  • @george1421
    Thank you for your help, so it seems it’s okay :
    bzImage: Linux kernel x86 boot executable bzImage, version 5.6.18 (sebastian@Tollana) #1 SMP Tue Jun 16 16:55:16 CDT 2020, RO-rootFS, swap_dev 0x8, Normal VGA

    And yes we can see bzImage … OK then init.xz… OK

    (We tried with the custom file earlier and could see bzImage553 before, we read the thread by date descending… Set the original back after.)

  • Moderator

    @lachagnasse said in Dell Latitude 5510 No network interface found! Kernel might not have the correct driver!:

    [8086:0d4f]

    Is/was first supported in linux kernel 5.5 so the 5.6.18 kernel should be working for you.

    On the fog server’s host OS console key in the following.

    cd /var/www/html/fog/service/ipxe
    file bzImage
    

    The file command will print out the kernel version. Make sure it says 5.6.18.

    Also when you pxe boot directly into image or pick registration from the FOG iPXE menu make sure it says bzImage that gets transferred to the target computer. You will have to read fast but it will say bzImage … OK then init.xz … OK. The key is to make sure its bzImage that gets transferred and not some other name like bzImage4152 or such.


  • Hi everyone, we have exactly the same issue on the same computer (latitude 5510). I updated the kernel by 5.6.18 for 32 and 64 but still have the same issue (fog 1.5.9).

    lspci output :

    00:14.3 Network Controller [0280]: Intel Corporation Device [8086:02f0]
    00:1f.6 Ethernet Controller [0200]: Interl Corporation Ethernet Connection (10) I219-V [8086:0d4f}

    Any help would be much appreciated


  • @george1421 Thanks a lot for your reply. Sorry, this was my first time and I will create a new post.

  • Moderator

    @rodrigonm Different problem should be tracked in a different post. But upgrade the FOS Linux kernel to 5.6.18 or later and try again. You can upgrade using the FOG WebUI under FOG Settings ->Kernel. Upgrade both the 64 bit and 32 bit kernels. That should address any new hardware issues.,


  • @george1421 said in Dell Latitude 5510 No network interface found! Kernel might not have the correct driver!:

    is the 5510 Precision workstation it should be a similar platform to the 3510 laptops we have. If so those laptops are 3-4 years old, the FOS Linux kernel for FOG 1.5.9 should have the proper driver in it.
    What I want you to do is setup a new deploy task, but before you hit the schedule button tick the debug checkbox, then schedule the task.
    PXE boot the target computer and after a few screens of text that you need to clear with the enter key you will be dropped to the FOS Linux command prompt on the target computer. At the

    I am facing this challenge for three days and I did not resolved the issue.

    The computer is a Dell Optiplex 7480 and when I try to deploy Image comes up this message all the time.
    Any suggestions and help for solving this problem.

    Thank you so much!
    Rodrigo


  • @george1421
    Thank you!
    That fixed our issue. Much appreciated.


  • @george1421 ok once im done imaging ill change it. Thanks a lot for your help!

  • Moderator

    Just an update on this thread. There is no need to use this one-off kernel to get new hardware support. The FOG Developers have released an officially supported version of the 5.x kernel to the normal kernel repository. This officially released kernel can be updated from within the FOG Ui as all other kernels are released.

    @asbenavides Ok you have a few options then.

    1. Go into the FOG settings and change the default kernel from bzImage to bzImage553
    2. For every 5510 set the host kernel value to bzImage553.

    The one-off kernels are built for specific purposes and are not part of the main FOG distribution. There these kernels may support additional hardware not found in the default FOG distribution, otherwise they are functionally equivalent. If I remember right the FOG 1.6.x series of FOG will include the 5.x line of linux kernels.

    You may continue to use this kernel as I’ve outlined in steps 1 or 2 without any problems.


  • @george1421 the steps you provided worked great!

  • Moderator

    @asbenavides I forgot to mention that you will still get the error but debug mode will give us a chance to try to understand why its not working.

    Intel Wireless-AC 9462 [8086:02f0] first available in linux kernel 5.0
    Intel Ethernet Connection (10) I219-LM [8086:0d4e] first available in linux kernel 5.5

    So in short the version of bzImage supplied with the current release of FOG does not support the built in ethernet adapter.

    I have a one off kernel for FOG that is 5.5.3 that you can try: https://drive.google.com/file/d/1thopskSYJd7ueDQeFg_VT4eeNcrNHvIx/view?usp=sharing

    Download that file to /var/www/html/fog/service/ipxe directory on the FOG server. Make sure the case of the file name is kept intact it should be called bzImage553

    Then go into the host definition for this Latitude 5510 and set the Host Kernel parameter to bzImage553. Now pxe boot the computer into imaging. Understand what we are doing right now is only testing to see if this one-off kernel works for this system.


  • @george1421

    this is what im getting disregard the previous reply.

    1. lo: <loopback.up.lower_up> mtu65536 qdisc noqueue qlen 1000
      link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
      inet 127.0.0.1/8 scope host to lo
      valid_lft forever preferred_lft forever

    2. I get
      00:14.3 Network Controller [0280]: Intel Corporation Device [8086:02f0]
      00:1f.6 Ethernet Controller [0200]: Interl Corporation Ethernet Connection (10) I219-LM [8086:0d4e}


  • @george1421 tried that debug checkout box but I still get the same error. “No network interface found” and i’ve check to see if the ethernet port has connectivity and it does has and any other pc does work fine in the same port.


300
Online

7.7k
Users

14.7k
Topics

138.5k
Posts