SOLVED Fujitsu p558 no get ip adresse

  • Hello world,

    I have a probleme with fujitsu p558 i3-9100, and ONLY this model, because with dell 3070, it’s working great.

    Technical information:

    Fog is running on ubuntu 18.04 lt’s a fresh install from 23/03/20. (yesterday in fact)
    For dhcp, we’re using fortigate,
    I followed these steps to do this======>

    boot ok BUT:

    after disable secure boot, i boot on pxe boot uefi ipv4, the fog menu comes, but when a choose something in the menu,
    this f***ing pc does not received ip address.

    Here a video on youtube, so you can see:

    Here a picture of the error

    “Failed to get an ip via dhcp!”

    Can somebody have an idea?

    This is for my job.

    Thank you for your help

  • Senior Developer

    @kyokushin Please schedule a debug task and boot the machine again. Then when you get to the shell run the following commands:

    ip a s
    dhclient -v -r enp0s1
    ip a s

  • Hello world,

    I still have problem with fujitsu p558 e85+

    When i boot on pxe, i have the fog menu, and when i choose option, it happens this:

    Also, this the description of the network card in windows:

    Here, the fos kernel:

    If somebody have any idea?

    Thanks you

    Best and regards

  • Moderator

    Just to add a bit of detail to this issue.

    The linux driver that comes with the stock linux kernel is insufficient to configure and use these new breed of realtek 8168 network adapters. Last fall I created a one off kernel with the updated linux drivers from the realtek web site. These updated realtek drivers seem to work better with these new nics than the stock 4.x kernel drivers.

    I asked the OP to try the latest one off 5.5.3 stock linux kernel and that version also did not work with this realtek nic. I have not tried to patch the 5.x series kernels as of now with the updated realtek drivers as I did with the 4.19.x series.

    key search term is bzImageRT

    For now I had the OP change the global FOS boot kernel to bzImageRT in the fog configuration page. That way all systems will use this one-off kernel. The only changes from the base FOG kernel is that it has the updated realtek drivers.


  • Hello world,

    Just for give information for everybody

    George give to me a kernel to download and it’s working great!

    But At this time, i must add host manually and in kernel argument on fog server, i must specify the good kernel then i downloaded

    (sorry for my english, i come from france, and we’re not really for langages)

    I have to find a way to automate the process.

    George, your the best!
    bravo george!

  • Moderator

    @kyokushin Look at the forum chat bubble for some additional hints.

  • Moderator

    @kyokushin Ok you have a realtek nic [10ec:8168] that driver has been in the linux kernel for a long time. But we’ve seen that a driver newer than the linux kernel is needed. I need to check but I think I compiled a one-off kernel for testing.

  • @george1421 said in Fujitsu p558 no get ip adresse:

    FOS Linux kernel version


    Here, the network card id in windows:

    Here the linux kernel:

    I’m using fog 1.5.8.

    The result of debug mode:

    Thank you!
    I’m waiting for you

  • Thank you for your very fast support.
    I do whatever you say, and come back to you.
    I am in the workshop of my job.

  • Moderator

    1.From a running windows computer can you give me the hardware ID of this network interface?


    Schedule a capture or deploy but tick the debug checkbox. PXE boot the target computer you will get the same error but will be able to bypass the error. After a few enter key presses you will be dropped to a linux command prompt on the target computer. At the FOS Linux command prompt key in lspci -nn | grep -i net and post the results here. I need the value in the square brackets (i.e. [8086:1F3E] /made up number to show what I’m looking for/)

    2.What version of FOG are you using?
    3.What FOS Linux kernel version are you using?