Keeping hostname when imaging



  • Its usually recommended, but not doing it isn’t likely to be causing the host-name issue as I believe the unique identifiers etc which are modified by Sysprep are mainly used for things like WSUS.
    Ive found its best to build a base image not based upon an existing machine, although if you’re Syspreping the image it shouldn’t matter too much if it was.



  • No I don’t. Is it necessary for XP?



  • Are you using Sysprep when deploying hosts? Its usually best to do so and use the answer file to give the machine a random name.



  • Hi,
    Thanks for answer. But I missed something.
    I imaged from GEA156 (host name) after fog client setup and reboot.
    I enable for the group the hostnamechanger service, also for settings fog in other informations
    hostnamechanger option is enabled in fog server and in fog client (enabled when installing).
    I deploy for example GEA157 (link to GEA156 image). After imaging, GEA157 is renamed GEA156.
    I don’t use AD, only workgroup.
    How to debug this?
    Ok I shall look at fog.log on host …
    Regards
    Ubantu 12.04
    fog 0.32
    XP hosts



  • This post is deleted!

  • Moderator

    Wait what? You specify host name when you register. If you have hostnamechanger options enabled in the fog client and the fog server, the host is renamed to match the host record in fog after imaging is complete.


Log in to reply
 

380
Online

6.4k
Users

13.8k
Topics

130.0k
Posts