Fog version 1.6 on Ubuntu 19.10 - So close



  • Hello,

    I decided to try setting up FOG on the new Ubuntu. After failing with the latest stable release I read it didn’t work because non LTS versions didn’t do PHP or something and to use version 1.6.

    So I did another fresh install of 19.10 and installed version 1.6. This time I made it past “Stopping web service…Failed!”

    I made it to almost the end where I need to update the database schema

    but when I go to 192.x.x.x/fog/management

    This is displayed

    "{“error”:"An SQL error occurred: SQLSTATE[3D000]: Invalid catalog name: 1046 No database selectedSQL: SELECT hostID,hostID,hostName,hostName,hostDesc,hostIP,hostImage,hostImage,hostBuilding,hostCreateDate,hostLastDeploy,hostCreateBy,hostADUser,hostProductKey,hostPrinterLevel,hostKernelArgs,hostKernel,hostDevice,hostInit,hostPending,hostPingCode,hostExitBios,hostExitEfi,hostEnforce,imageName,hmMAC\n FROM hosts\n LEFT OUTER JOIN images\n ON hosts.hostImage = images.imageID\n LEFT JOIN hostMAC\n ON hosts.hostID = hostMAC.hmHostID\n AND hostMAC.hmPrimary = ‘1’\n WHERE hostPending = ‘1’\n ORDER BY hostName ASC\n “}”

    No idea. I can always go back to 18.04 but wanted to try out this new one.



  • @Tom-Elliott

    Nice, it is working now.

    There was a slight blip where it got stuck at

    Downloading kernel, init and fog-client binaries…

    So I ‘quit’ the install removed user fogproject and ran the install again.

    I was able to update the database schema, continue the install and login.

    New interface looks slick!



  • @Sebastian-Roth
    Sorry about the 16. It was late

    I used these steps to install Fog

    sudo -i
    git clone https://github.com/FOGProject/fogproject
    cd fogproject
    git checkout working-1.6
    cd bin
    ./installfog.sh
    
    

    I will try git pull

    @Tom-Elliott

    So… the newest Fog has been updated since I originally posted

    working-1.6
    Updated 10 hours ago by mastacontrola
    Cool

    Gonna spin up 19.10 in a VM and see what happens.


  • Developer

    @Tom-Elliott Well done!

    @Fog_Newb Run git pull in your fogproject directory to get the latest changes and run the installer again.


  • Senior Developer

    @Tom-Elliott I delved deeper trying to understand the problem.

    I dropped the database and simulated a “fresh” install. After doing so, I found out what was causing the problem.
    I was able to fix it in the latest.

    Thank you,


  • Senior Developer

    @Fog_Newb said in Fog version 1.6 on Ubuntu 19.10 - So close:

    SELECT hostID,hostID,hostName,hostName,hostDesc,hostIP,hostImage,hostImage,hostBuilding,hostCreateDate,hostLastDeploy,hostCreateBy,hostADUser,hostProductKey,hostPrinterLevel,hostKernelArgs,hostKernel,hostDevice,hostInit,hostPending,hostPingCode,hostExitBios,hostExitEfi,hostEnforce,imageName,hmMAC FROM hosts LEFT OUTER JOIN images ON hosts.hostImage = images.imageID LEFT JOIN hostMAC ON hosts.hostID = hostMAC.hmHostID AND hostMAC.hmPrimary = ‘1’ WHERE hostPending = ‘1’ ORDER BY hostName ASC

    I’m not able to see any issue with this, though I’m also not using ubuntu 19.10.

    With that said, the issue isn’t something FOG is doing. this query is perfectly valid. Why it’s saying it’s failed is because there is no database selected. For example, did somebody change the database name? Did somebody drop the database named fog?


  • Developer

    @Fog_Newb To install on Ubuntu 19.10 you need to use dev-branch or working-1.6 from github repo.

    I have to admit that I have not tested working-1.6 on Ubuntu 19.10 lately. There is a chance this is failing.

    @Tom-Elliott Would you have a chance to test Ubuntu 19.10?

    The version not called 16 but more like working-1.6 or FOG pre 1.6 (note the dot between 1 and 6). I corrected your post to not confuse others.


Log in to reply
 

323
Online

6.8k
Users

14.1k
Topics

133.2k
Posts