File size mismatch - FOGreplicator



  • So I decided to create a new FOG server from scratch. We have existing nodes at each of the school sites. I uninstalled FOG and installed latest version 1.5.7 FOG storage on each node. Everything is working great. Only issue that I can see is with fogreplicator. Keep getting this error and the replication keeps overwriting img files.

    [01-08-20 10:44:45 am] | Sync finished - Resource id #1182
    [01-08-20 10:41:38 am] | Sync finished - Resource id #1246
    [01-08-20 10:36:35 am] | Started sync for Image Windows 10 Staff - Resource id #1246
    [01-08-20 10:36:35 am] | CMD: lftp -e ‘set xfer:log 1; set xfer:log-file /opt/fog/log/fogreplicator.Windows 10 Staff.transfer.Link Node.log;set ftp:list-options -a;set net:max-retries 10;set net:timeout 30; mirror -c --parallel=20 -R --ignore-time -vvv --exclude “.srvprivate” “/images/Windows10Staff” “/images/Windows10Staff”; exit’ -u fogproject,[Protected] 10.4.30.93
    [01-08-20 10:36:35 am] # Windows 10 Staff: Deleting remote file d1p4.img
    [01-08-20 10:36:35 am] # Windows 10 Staff: File size mismatch - d1p4.img: 13051790429 != 166888541
    [01-08-20 10:36:35 am] # Windows 10 Staff: No need to sync d1p3.img (Link Node)
    [01-08-20 10:36:35 am] # Windows 10 Staff: No need to sync d1p2.img (Link Node)
    [01-08-20 10:36:34 am] # Windows 10 Staff: No need to sync d1p1.img (Link Node)
    [01-08-20 10:36:33 am] # Windows 10 Staff: No need to sync d1.partitions (Link Node)
    [01-08-20 10:36:33 am] # Windows 10 Staff: No need to sync d1.original.swapuuids (Link Node)
    [01-08-20 10:36:33 am] # Windows 10 Staff: No need to sync d1.original.fstypes (Link Node)
    [01-08-20 10:36:33 am] # Windows 10 Staff: No need to sync d1.minimum.partitions (Link Node)
    [01-08-20 10:36:32 am] # Windows 10 Staff: No need to sync d1.mbr (Link Node)
    [01-08-20 10:36:32 am] # Windows 10 Staff: No need to sync d1.fixed_size_partitions (Link Node)
    [01-08-20 10:36:31 am] | Image Name: Windows 10 Staff
    [01-08-20 10:36:31 am] * Found Image to transfer to 1 node

    Image size at Main server and node are exactly the same size 26.32 GiB and transfers in under 10 minutes.

    de7db7a6-23c7-4d54-b41e-cf66655faa6c-image.png

    I also increased the IMAGEREPSLEEPTIME to 1800. Is there something I’m missing?


  • Moderator

    @cmachado The integer is overflowing on the node because 32bit has a 2GB limit for integers, but the filesizes exceed that number.

    If you get a 64 bit node your problems will disappear I reckon.



  • @Sebastian-Roth Yes. I marked @Quazz as the correct answer.


  • Senior Developer

    @cmachado said in File size mismatch - FOGreplicator:

    Yes that worked.

    What exactly worked? Did you reinstall on 64 bit Linux OS?



  • @Quazz Yes that worked.

    [01-08-20 2:51:25 pm] * All files synced for this item.
    [01-08-20 2:51:25 pm] # Windows 10 Class: No need to sync d1p4.img (Link Node)
    [01-08-20 2:51:24 pm] # Windows 10 Class: No need to sync d1p3.img (Link Node)
    [01-08-20 2:51:24 pm] # Windows 10 Class: No need to sync d1p2.img (Link Node)
    [01-08-20 2:51:23 pm] # Windows 10 Class: No need to sync d1p1.img (Link Node)



  • This post is deleted!

  • Moderator


  • Senior Developer

    @cmachado The 32 bit limitation described is probably caused by PHP being 32 bit. I am wondering if there is a way that we can get filesize in KB rather than bytes to get around such issues.


  • Moderator

    @cmachado The integer is overflowing on the node because 32bit has a 2GB limit for integers, but the filesizes exceed that number.

    If you get a 64 bit node your problems will disappear I reckon.



  • @Quazz Node is 32bit. Server is 64bit.


  • Moderator

    @cmachado Is the OS that FOG is installed on 32 bit perhaps?


  • Senior Developer

    @cmachado said in File size mismatch - FOGreplicator:

    28268901712 != -1795869360

    Negative number?!? This looks like a integer overflow. I’ll take a look at the code when I get home.



  • @Quazz Good catch! Same there too. Only 2 images and both same issue.

    [01-08-20 10:36:29 am] # Windows 10 Class: Deleting remote file d1p4.img
    [01-08-20 10:36:29 am] # Windows 10 Class: File size mismatch - d1p4.img: 28268901712 != -1795869360
    [01-08-20 10:36:29 am] # Windows 10 Class: No need to sync d1p3.img (Link Node)
    [01-08-20 10:36:29 am] # Windows 10 Class: No need to sync d1p2.img (Link Node)
    [01-08-20 10:36:29 am] # Windows 10 Class: No need to sync d1p1.img (Link Node)
    [01-08-20 10:36:28 am] # Windows 10 Class: No need to sync d1.partitions (Link Node)
    [01-08-20 10:36:28 am] # Windows 10 Class: No need to sync d1.original.swapuuids (Link Node)
    [01-08-20 10:36:28 am] # Windows 10 Class: No need to sync d1.original.fstypes (Link Node)
    [01-08-20 10:36:28 am] # Windows 10 Class: No need to sync d1.minimum.partitions (Link Node)
    [01-08-20 10:36:28 am] # Windows 10 Class: No need to sync d1.mbr (Link Node)
    [01-08-20 10:36:28 am] # Windows 10 Class: No need to sync d1.fixed_size_partitions (Link Node)
    [01-08-20 10:36:27 am] | Image Name: Windows 10 Class


  • Moderator

    You’re looking in the Windows10Class image folder while the log complains about Windows10Staff. So does the other image line up?


Log in to reply
 

347
Online

7.1k
Users

14.3k
Topics

135.1k
Posts