Support for EFI GPT systems?

  • Hi,

    I’m hoping someone can help me with this problem.

    I have a few HP Z210 workstations. These units use UEFI and the Windows installation creates 3 partitions- 100MB boot, 128MB MSR (system reserved), and the rest is standard NTFS.

    I’m using multiple partition, single disk as the image type.

    I can upload the image, and all three partitions get uploaded. I can then deploy the image and all three partitions get deployed.
    The system will then fail to boot to Windows with a black screen that states:
    Status: 0xc0000225
    Info: Boot selection failed because a required device is inaccessible.

    Running fdisk from the fog debug menu shows only one partition on the disk.
    It is of id: ee which is EFI GPT.

    My other systems (non-HP Z210 and are working) are all id: 7 HPFS/NTFS and have the default two partitions for Windows 7 when I run fdisk.

    I read that partition type of ee is not supported unless maybe I use Raw Image as the image type.
    I would like to avoid this as the hard disk sizes are 320GB.

    I’ve tried a variety of different partitioning schemes on this disk but, no matter what I do the disk is always listed as EFI GPT by fdisk after Windows is installed.

    Has anyone else experienced something like this or know how to get around it?
    Is this a limitation I should expect from other UEFI based systems?
    This is my first experience with this problem but, I read that (U)EFI systems are becoming more popular.

    I appreciate any help or ideas.


  • It finally works. After completing the steps above, it took booting into a Linux LiveCD (sysrescCD to be exact) and changing the partition table to msdos from GPT with parted. After that, Windows installed and imaged beautifully. Thanks!

  • Nevermind. I had disabled UEFI options as a whole by pressing F5 on the root menu. I had to disable each device individually with F5 (and then the root menu for good measure).

  • Brent,

    When you went to install windows after disabling the UEFI boot options, did Windows 7 come up with 2 or 3 partitions?

  • Thanks!

    FYI, if you build a 2.6.X (in my case, I did and add the networking support for the e1000e card, it will run faster than the 3.2.4 kernel.

    I am looking forward to reinstalling windows 7 with your tip. I will keep the forum updated. Thanks!

  • [quote=“Jesse, post: 2077, member: 358”]OK, thanks. Which kernel did you use? 3.2.4?[/quote]
    The most recent one yes.

  • OK, thanks. Which kernel did you use? 3.2.4?

  • I got mine working with turning off UEFI in the boot order, and having it set to RAID+SATA. Just install win7 like normal. When you go to upload you will get some errors and it will pause for a minute but it will upload and deploy.

  • I am having issues with the same machine (z210). Unfortunately I see NO place to set any UEFI options (short of taking them out of the boot order) and the Sata options are either RAID+SATA or IDE. I set it to IDE and took the UEFI options out of the boot menu, but Win7 still tried to create the 3 partitions.

  • Hopefully you’ve re-installed windows. The default HP install does come with an extra partition that will mess up the process.

  • Turning UEFI boot off for me will still generate errors. I get the “vbe_init failed” using the normal kernel and an NFS error using KS and others. However when I used kernel args with the normal kernel I can get it to upload but it fails with tons of buffer IO errors. sigh I’ve been fighting this for hours

  • I was able to get my laptop to boot after changing a few setting in the BIOS. I change the sata controller to compatibility mode and I set the UEFI settings on the startup page to boot to legacy device first. You should not have to re-image the computer but you may have to use the windows 7 disc to repair the installation.



    I hope this helps.


  • I am also having this problem when trying to image our Lenovo T520’s. The error code I get is 0xc000000e and the info is “Boot selection failed because a required device is inaccessible.”

    Please help