PXE Booting UEFI, Fog 1.5.6 - Dell Latitude 5400

  • So my issue is as follows. I have a heap of Dell Latitude 5400 laptops that i need to image. These machines do NOT have legacy boot options so i have to use UEFI.

    I cannot seem to get these laptops to PXE boot. Here’s my setup.

    Ubuntu, running Fog 1.5.6. DHCP is setup on my Fortigate with Option 67 specifying undionly.kpxe

    When i try to pxe boot i don’t even get any processing it just says it fails to boot and to retry or reboot the machine.

    Can someone help me get pointed in the right direction? I think i’m missing something in my DHCP but i’m not 100% sure and i’m having some trouble finding info especially considering my fortigate.

    Screen cap below is of my DHCP options on my Fortigate

  • @george1421 Wonderous. I did use the ipxe change like you suggested and it worked. I’ll hammer out the dnsmasq and see about gettin that working at a later time.

    Thanks so much. Love this software and the people who help support it.

  • Moderator

    @Diablo909 If you want to boot the uefi system right away without doing anything, change dhcp option 67 from undionly.kpxe to ipxe.efi and then all uefi systems will pxe boot.

    With the dnsmasq, if you use the config file supplied it will just work dynamically for both.

  • @george1421

    George, thanks i’ll review these notes and see about adding that. Which bootfile should i be specifying in my dhcp if i do that?

  • Moderator

    @Diablo909 I would say if your current dhcp server is working don’t add fog as your main dhcp server. The logic here is if the fog server “dies” so does your dhcp server. My recommendation would be to use dnsmasq on the fog server. That way if fog dies you only loose pxe booting (which requires the fog server anyway).

    It should take about 10 minutes to setup.

  • @george1421 said in PXE Booting UEFI, Fog 1.5.6 - Dell Latitude 5400:


    Would it be beneficial to just have the fog server be my DHCP server? I’m happy to swap over to that but need to know how to enable it now after the fact.

  • Moderator

    for uefi system you need to use a uefi boot loader like ipxe.efi instead of the bios boot loader of undionly.kpxe. Change dhcp option 67 to ipxe.efi

    If you need dynamic support for both uefi and bios based systems

    1. See if your current dhcp server supports both uefi and bios based booted stems (pfsense will).
    2. Use a different DHCP server like linux or windows 2012 or later dhcp server.
    3. Install dnsmasq on your fog server to supply pxe boot information only. The IP addresses will still be assigned by your main dhcp server.