Problems with new images under Fog IPXE

  • Hello,

    My Host is a Windows 10 PC where I am running Hyper-V. Ihave installed Debian 10 and then in debian the fog.
    I have an old Test PC as an client(no uefi).
    First i triend to test if the fog ipxe is runnung. That works. my PC shows on network boot the Menun and preinstalled tools like memdisk are working fine.
    Then i tried to make a Win10 running. And there starts the odyssey.
    I have used this tutorial and also for UEFI Clients.
    When i start with my non uefi client the non uefi Win 10 I get an error.
    IMG_2014 (2).JPG
    My DNS is the router (Zyxel USG60W).

    that is my menu entry in fog :
    IMG_2015 (2).JPG

    my iso is in the right place…

    I think I have some mistakes anywhere in the dns settings…?..

    (sry for my english, my native language is german and I am pretty new in the linux community…)


  • Hello,

    I have now configured the samba and now is the setup starting.
    But it takes nearly 8 minutes until the setup prompt is shown.

    Because I am not a linux expert there can be one or two little mistakes. I trie to discribe my samba setup.

    Debian 10

    first installed the samba

    sudo apt-get install samba -y

    then save the config

    sudo mv /etc/samba/smb.conf /etc/samba/smb.orig

    create a new config

    sudo gedit /etc/samba/smb.conf

    (yes I need a little bit gui support)

    then I created a smbuser and gave him a password

    sudo useradd -s /bin/false smbuser
    sudo smbpasswd -a smbuser

    my smb.conf file

    workgroup = smb
    security = user
    map to guest = never
    comment = Home Directories
    browsable = no
    read only = no
    create mode = 0750
    valid users = smbuser
    #Wir beschränken den Zugriff auf den User ''smbuser''
    #valid users = @smbusers
    #Alternativ kann auch auf eine Benutzergruppe eingeschränkt werden
    path = /images/os/mswindows/10Pro-x64/
    public = no
    writable = yes
    comment = Windows 10 Setup-Ordner
    printable = no
    guest ok = no
    create mask = 0600
    directory mask = 0700

    then I assigned the smbuser to my directory and gave him rights

    sudo chown -R smbuser:smbuser /images/os/mswindows/10Pro-x64/
    sudo chmod 700 /images/os/mswindows/10Pro-x64/

    and at least I restarted the smb

    sudo systemctl restart smbd.service

    I customized the startnet.cmd(WinPE) for my smbuser and thats it.

    I have run a test installation on my old client and it completed successfully.
    But the start of my setup takes realy long…

    Did anybody see a mistake or has a optimization for me?

    (I found the discription for the samba in the german Thomas-Krenn-Wiki: and )


  • Yeah, I am pretty stupid ^^ I Thought only the {} are the space holder… I deleted the $ and now is also the gparted working … you guys are awsome …


  • Moderator

    If you look at the tutorial this is the parameters section

    initrd nfs://${fog-ip}:/images/os/mswindows/7Pro-x64/WinPE_amd64.iso
    chain memdisk iso raw
    boot || goto MENU

    The iPXE variable ${fog-ip} will be dynamically replaced with the IP address of your fog server. So there is no need to modify the parameters section, just paste it in.

    Also understand this menu item will only work for bios based computers. I need to write a new tutorial for uefi based computers. This is because the memdisk utility is bios only.

  • WoW…that was a really fast answer… And it workedpost-6026-0-80474700-1322248538.jpg

    The WinPE is now starting and i see i have to fix the startnet.cmd
    If i have some other problems I will post it…

    Many,many thanks to you and george1421(who tried to help me via chat)


  • Senior Developer

    Your NFS line in the parameters has a $ symbol, please remove this.