SOLVED FOG, client getting "//" in front of index.php

  • Originally thought I miss configured somewhere, so after couple days on the old server and going nowhere, I setup a new server with Ubuntu 18.04 & just FOG ( and let FOG installed all the additional software ); logging into sever is fine. On clients, during PXE boot, they get IPs and find the next sever listed, but is getting the error message “unable to access http://<sever>/fog//index.php” from the FOG server. The double “//” in front of index.php is the problem. I have went through php files in /var/www/fog, but can’t identify which one is giving this. Please help. Thank you.

  • Thank you. yes, you are right the problem is NOT the “//” but SPT on the switch that caused “udhcpc failed”. the solution is posted here:

    Tested imaging with a dumb switch, and everything worked.

  • Senior Developer

    @snap7B While the double slash is kind of ugly I am fairly sure this is not causing your problem unless you have some kind of fancy web application firewall trying to prevent some mystical URL attack pattern.

    At the stage of PXE boot you are describing the client is trying to contact the FOG web server to see if it has a proper connection up. This has worked (including the double slash) for so many other people and I am sure there is something in your setup that prevents this from working.

    It can be different things:

    • Client being in a different subnet than the FOG server and route not set properly or HTTP access not allowed
    • HTTP access not allowed on the FOG server from the client IP source
    • IP not handed out properly (on PXE boot the IP is requested from the server three times, first PXE ROM, second iPXE and third Linux kernel - if the first two work nicely it doesn’t mean the Linux kernel is getting it too)

    The best you can do is taking a picture or video of the error on screen and post here. Quite often there is some information on the screen that we notice that might help us finding out what’s wrong.

    Other than that you can start by booting up the client to it’s operating system on disk and try accessing the http://<sever>/fog//index.php URL in the browser. Does this work? If not, is there a firewall in between?