• Hello

    FOG version 32
    I went through all the topics that were telling how to change my password form mysql etc. Tried to change the password from mysql database with:
    mysql -u root fog
    mysql> UPDATE users SET uPass = MD5(‘password’) WHERE uName = ‘fog’;

    after that I went through “/var/www/fog/commons/config.php” and “/opt/fog/service/etc/config.php” and changed all the instances of fog passwords to the one I changed into the mysql.
    After that I did “sudo passwd fog” and changed the system user password to the one I chose.

    And now… I cannot connect to the webui… but I can login to the local computer with the fog user.

    I tried changing all the passwords back to the default one, but now even that wont work.

    I also tried to change the password without the MD5 part but still no use…

    Should the uType and uCreatedDate contain some data? as it is, UcreatedDate is just zeros and dashes, and uType is empty.

  • % is a wildcard(like * in bash, or Windows explorer) in MySQL when using some operators such as LIKE, it can be escaped and used as a literal % sign by placing a backslash sign in front of it. [CODE]%[/CODE]

    I don’t believe this to directly to be the reason, i assume that fog strips out/substitutes the % sign because it may be used in some sort of web based attack on the fog server. Just guessing though.

  • Okay I found the problem. The password cannot contain% for some reason… And when I added the password directly through mysql, it borked the whole system. Setting the password back to default with MD5 works wonders.